Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installed W7x64 on new SSD, MBR is on old Win7x64 HDD, having trouble.

18 May 2014   #1

Windows 7 Ultimate 64bit
Installed W7x64 on new SSD, MBR is on old Win7x64 HDD, having trouble.

Hey guys, I have 2 Win7 installs on my PC (one on SSD, one on HDD). The one on the HDD holds the MBR and other boot files, and I want to move or set the MBR on my SSD so I can format my old HDD. However when I use my Win7x64 CD to repair, I get no OSs showing up here:

(screenshot from your MBR tutorial)

Basically what I am trying to do is unplug all but my SSD and use a Windows 7 CD to add the MBR to the SSD, however the repair CD does not recognize the OS on my SSD (or the HDD for that matter), so I am unable to use the repair CD to add the MBR.

What else I have tried:
I tried the commandline Saltgrass told someone to use here: Delete active system partition - Windows Forums[2] to manually add boot files to the C: drive and that didn't work either.

Here is my Drive layout in case it helps:

The 746gb unallocated is managed by SeaGate DiscWizard as it's a 3TB HDD which my Motherboard/OS does not support.

My System SpecsSystem Spec
18 May 2014   #2

Windows 7 Ultimate 64bit

Okay, weird. I decided to put in the repair CD while all drives were plugged in. It noticed that my old HDD install was corrupted or something and fixed it. This inadvertently moved the MBR to my SSD and everything went fine. I formatted the old boot drive!
My System SpecsSystem Spec
19 May 2014   #3
Microsoft MVP


According to the screenshot, the partition which is presently booting Win7 is on H as signified by the System flag. Did it move? If not, Mark C Partition Active, Mark H Partition Inactive, unplug all other hard drives besides Disk0, boot into Win7 installation media System Recovery Options or System Repair Disk to run Startup Repair - Run 3 Separate Times to write the System boot files to C.

An automated method to do this is here: Bootmgr - Move to C:\ with EasyBCD
however all partitions except C must still be marked Inactive, and C marked Active.

Afterwards, plug back in the other hard drives making sure C remains first HD to boot in BIOS setup,
My System SpecsSystem Spec


 Installed W7x64 on new SSD, MBR is on old Win7x64 HDD, having trouble.

Thread Tools

Similar help and support threads
Thread Forum
Trouble with Brother MFC 8300 driver (installed with "Windows Update")
I need help getting my printer to work with a fresh install of Windows 7 Home Premium 64bit. I had to re-install due to a CMOS error which I think was due to a dead battery. It still could be something else seeing as I have had other problems with this install (explained below). Anyway, the...
Re-installed Windows 7 and having trouble connecting to the internet
Hello, bare with me here I don't know much about this stuff but I'll try to give as much info as I can. Today I re-installed a hard drive and OS for my ASUS, Model: U56E. The hard drive is an HGST Travelstar 500GB, 7200RPM and 16 MB/Mo and the Operating System is Windows 7 Home premium 64bit. The...
clean win7x64 installed on hp dm1 4302ep(win8),now i cant find drivers
that's pretty much the topic.. did a clean win7x64 with sp1 install, but now some drivers are missing, i cant use the ethernet, or the Fn keys on laptop.. does someone knows a solution? these are the ethernet possibilities, i got them trough the info on the windows 8 driver: ...
Installation & Setup
bluetooth peripheral device - drivers not installed W7x64 USB 4.0
I recently installed a Kinivo BTD-400 usb bluetooth adapter so I could transfer files from my Samsung Galaxy s2 I727 phone. I downloaded the current installation files from the Broadcom site. At the end of installation, a message box lists several items "ready to use" (AV source, headset, etc) but...
Hardware & Devices
4GB DDR2-1066 Installed... Win7x64 Not Booting
I have four identical 1GB sticks of G.Skill PC2-8500 memory, and I cannot seem to get Windows 7 to boot with all of them installed. I am using a ASUS Rampage Formula board in which I have successfully used 4GB of PC2-6400 memory in the past. I've done a BIOS update to the latest version and still...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:07.
Twitter Facebook Google+