Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 fails to install and USB keeps on turning off

24 May 2014   #1

Windows 7
Windows 7 fails to install and USB keeps on turning off

I was recently given a computer from a friend and I thought I'd install Windows 7 Ultimate 32bit over a Windows XP that it had pre-installed but it doesn't seem to install properly.

So here's the story:
A while ago, he told me that all of a sudden his USB keyboard and mouse would turn off and the computer would basically freeze and not respond to any actions, even when unplugging and plugging back the USB keyboard and mouse.

I thought it could be an OS issue so I decided to upgrade it to Windows 7 since it meets the hardware requirements (Dual core processor, 2GB RAM, 1GB VGA) but the installation keeps on failing with different problems each time.

First of all, I tried to install Windows 7 with the original DVD but the first time it got stuck on 87% at "Windows is expanding files" just like how it would freeze when the USB keyboard and mouse stop working. I would also like to mention that instead of displaying "87%" it would display "8769". The mouse's laser turned off yet the keyboard's Num Lock light stayed on but I couldn't turn it off or on as it got stuck as well but it kept on being turned on. So I rebooted the computer while it was stuck there and I ended up with a disk check which took me hours of waiting and never ended. Apparently it was trying to recover some orphaned file which could not get recovered after hours of waiting.

My second try was to transfer the installation files to a USB flash drive using the Windows 7 Download Tool but that also couldn't fix the problem. The installation got stuck on "Completing installation" when again, the USB mouse's laser turned off and the USB keyboard froze. I then tried to re-do the installation by turning off the USB keyboard and mouse right after the installation began but guess what, it got stuck on "Expanding files".

I'm out of clues on what I should try next. If anyone has experienced this problem and has resolved it then please let me know. I'm starting to think that the motherboard is malfunctioning. I've also tried with a PS2 keyboard only without using anything USB related and miraculously the installation finally completed but the computer is acting super slow. By that I mean it takes like 2 minutes to open up My Computer.

By the way, I did try turning off USB Legacy support from BIOS but that also didn't help.
My System SpecsSystem Spec
24 May 2014   #2
Microsoft MVP

Windows 10 Pro x64 ; Xubuntu x64

What was the source of the installation DVD?

Download an .ISO from this location:
Windows 7 Direct Download Links, Official Disk Images from Digital River

Write it to USB using this tool:

Insert the USB into a USB2.0 port and install as normal. Activate it, then run this tool and post the results:

1. Download and save this tool to your desktop:

2. Run the tool, and then click Copy - ignore any errors if they appear

3. Use CTRL+V to paste the unedited results of the tool here in your next reply
My System SpecsSystem Spec
24 May 2014   #3
Microsoft MVP


My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
update fails, SP1 install fails, troubleshooter fails
I'm simply attempting to run update on my Windows 7 machine. Update will not run, downloading and running the SP1 update fails, downloading and running the Update Readiness Tool fails, trying to launch a troubleshooter fails. I ran sfc and have attached the log along with all the error codes...
Windows Updates & Activation
Computer fails to turn on display after going to sleep/turning it off
Hello. I've a computer with these specs: Windows 7 Ultimate x64 CPU: AMD FX-8320 Motherboard: ASUS M5A97 R2.0 Memory: 8 GB GeIL DRAGON 1600 (2x4GB) Graphics Card: Sapphire R9 280X Dual-X Hard Drives: 1 TB Internal Seagate Barracuda, 1 TB Seagate External PSU: Corsair VS550 80+ Gold Case:...
General Discussion
Windows update fails to install IE10 after repair install
I did a repair install of W7 Ult. x64 SP1. Applied all updates, but if fails to install IE10 update : (as you see it is a dutch version). If have run sure & sfc /scannow. Both report no problems. CBS files are attached. Please help ?
Windows Updates & Activation
Windows 7 Install Disc fails to see hard disk after Ubuntu install
After I tried to make a dual boot with Ubuntu and Windows 7 Ultimate (64-bit), Windows now does not boot. I have tried to reinstall and repair the HDD but the disc fails to recognize my HDD (Western Digital Scorpio Black 500 GB). My HDD is Basic, has 3 primary partitions and 1 extended (3 logical)....
Installation & Setup
Two issues: Upgrade install of W7x86 fails and W7x64 fails to clean install
Clean installing W7 x86 is no problem. But 1) upgrading Vista x86 to W7 x86 fails and automatically rolls back to Vista, and 2) attempt to clean install W7 x64 results in BSOD when rebooting to finalize the process. Any suggestion would be appreciated.
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:42.
Twitter Facebook