Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to install W7 Ultimate SP1 to a blank SSD using GPT

08 Jun 2014   #1

Windows 7 Ultimate x64
Unable to install W7 Ultimate SP1 to a blank SSD using GPT

I'm doing a fresh install on a newly-assembled PC. It has an SSD (~220GB) and a magnetic HDD (1TB). Ultimately I plan to dual-boot with Fedora Linux, so I want to partition for Windows to not use the whole disks.

The first time I did this installation, I didn't pay attention to whether Windows 7 used MBR or GPT partitioning, and I've since learned that it has to use GPT partitioning if I want it to use UEFI. It seems like I want to use UEFI (that's new to me), so I'm trying to re-install, this time using GPT.

I've followed the "How to Install Windows 7 Using [UEFI]" tutorial, but something's going wrong for me. Step 8 says, "You will notice that the disk has now been formatted as GPT with 3 partitions." But that's exactly what I don't notice.

Because I had already installed using GPT, I've used 'diskpart' to convert both of the previously-partitioned hard drives to GPT. When I'm on the screen shown in step 6, I go off with Shift-F10 and use 'diskpart'. Long story short, before returning to installation, 'list disk' shows me '*' in the 'Gpt' column for both disks. It looks like they're GPT. If I come back to 'diskpart' immediately, they still look 'Gpt'.

Now if I click 'New' and create the partition I want for Windows (140GB of the 220GB available), I get 'To ensure that all Windows features work correctly, Windows might create additional partitions for system files", then it shows me two partitions: "Partition 1: System Reserved" (100MB) and "Partition 2" (140GB). If I now go back to diskpart and look at 'list disk', it shows this disk as no longer 'Gpt'.

I have noticed two gotchas on this subject, so let me address explicitly them right-off:
1. From the UEFI BIOS, I did choose the UEFI boot option for the installation DVD.
2. I am using a 64-bit installation DVD. Or at least, I am sure that the filename that I burned indicated it was such, so I feel about 95% on this. Not sure how I can confirm this besides re-installing and looking inside of Windows.

As a workaround, perhaps I should try installing Fedora first... Then I wouldn't have to ask Windows to create the partitions from scratch.

My System SpecsSystem Spec
08 Jun 2014   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, 64-bit

I think GPT disks also contain two hidden partitions called the ESP (EFI System Partition) and the MSR (Microsoft reserved) and they must be placed in this order and before the primary partitions.

Just curious: why are you going with UEFI?
My System SpecsSystem Spec
08 Jun 2014   #3
Microsoft MVP


What are the UEFI, CSM, Legacy BIOS and Legacy Boot or any other related settings in BIOS setup? Taking camera snaps of them with the settings choices expanded would be helpful - attach using paper clip in reply box.

You 'd want UEFI, CSM enabled, No Legacy BIOS, and booting the device as UEFI to install to UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Forums.

You should only need to delete the partitions and if the BIOS settings are correct it will create GPT partitioning for you. So the BIOS settings are likely wrong and it is trying to install as an MBR disk.

We see nothing but problems with UEFI here which are all resolved by deciding to Bypass UEFI to Install WIn7
My System SpecsSystem Spec

10 Jun 2014   #4

Windows 7 Ultimate x64

Thanks for the swift reply. I poked around in my BIOS and didn't see anything about legacy BIOS or CSM. I attached a couple of screen shots anyway, so you could roughly see what I've got to choose from- I only took screen shots of 'Boot' and 'Advanced'.

I don't have a knock-down reason to use UEFI, really. Supposedly it could help it to boot faster, which is something tangible that's important to me. Otherwise, I just wanted to be using up-to-date technology and not falling back on ancient stuff.

I'll reflect on whether to push forward with this UEFI attempt. It sounds like your recommendations would be not to.

Unable to install W7 Ultimate SP1 to a blank SSD using GPT-20140610_202710.jpg

Unable to install W7 Ultimate SP1 to a blank SSD using GPT-20140610_202748.jpg

My System SpecsSystem Spec
10 Jun 2014   #5

Windows 7 Ultimate x64

Classic. Having posted my screenshots, I returned to poke around a bit more... and found the CSM option. I had to disable the "Fast Boot" option which you can see in the 'Boot' screen shot. I'll go play around and report progress back, but wanted to update this real quick.
My System SpecsSystem Spec
10 Jun 2014   #6

Windows 7 Ultimate x64

That worked! The CSM sub-options were automatically adjusted when I tried to proceed with installation, and the GPT partitioning worked as expected. The installation seems to have succeeded.

My System SpecsSystem Spec
10 Jun 2014   #7
Microsoft MVP


Thanks for reporting back. The Fast Boot setting was not obvious that it was hiding CSM so you did good to detect that.

We get no good reports on UEFI here, though I watch for them. We see only problems, and no one bragging about faster boot. I get a 5 second boot on MBR with an SSD with Core i5. An SSD is the best upgrade we see here.
My System SpecsSystem Spec

 Unable to install W7 Ultimate SP1 to a blank SSD using GPT

Thread Tools

Similar help and support threads
Thread Forum
Unable to install windows 7 Ultimate x64 updates
I have been battling this problem for over a year now :mad: definitely have some corrupted files after running the sfc / scannow. Unable to install SURT as well. I attached the files requested. Thanks in advance! Bob
Windows Updates & Activation
Blank desktop at start up in Windows 7 Ultimate
PS: Please delete this thread if necessary. Hullo, I'm new here and a newbie when it comes to knowing what kind of graphics card, motherboard and very technical details, so please bear with me. This all started while I was using jv16 PowerTools and CCleaner to clean my computer when I...
General Discussion
Still unable to copy CD-ROM for Windows 7 Ultimate SP1 to blank DVD+R
Let's try this again. Below is the 1st thread, plus results of 3 attempts at the suggestions. So far, nothing has worked. I included the root directory list of the CD-ROM which I am trying to copy. Please read this again and give me more detailed instructions. It is appreciated - I am trying,...
General Discussion
Device Manager blank - Unable to install peripheral drivers
Hi, to start off, sorry if this question has been answered before, but after looking for quite some time I haven't come up with a solution to my problem. I just recently got a new keyboard and mouse, but when trying to install their software to my computer, it couldn't detect them, despite them...
General Discussion
Unable to boot after clean install Win7 Ultimate 64-bit
I recently got my pc up and running again with a new MB and CPU i had installed Ultimate 64 from my USB stick as usual installed fine booted to windows no problem untill i tried to do a chsk dsk on the main drive which then restarted my pc showed me the OS boot information but didn't show the...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:54.
Twitter Facebook Google+