Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Optiplex 780 no drive found during setup.

20 Jun 2014   #1

Win7 Ultimate 64bit
Optiplex 780 no drive found during setup.

The computer shipped with Windows 7 so I'm attempting to put Windows 7 back onto it. Setup can't see the hard drive. So I STFI and find that Win7 may need to load a driver during setup. WTH? I thought AHCI support was added to Vista and up so we wouldn't have to do this?!

So I find the Pre-OS install driver Product Support | Dell US and Win7 setup loads it... and still claims there is no hard drive.

I know the hard drive works. I connected it to another Win7 x64 computer and formatted it. BIOS setup in the Optiplex 780 detects it. Nothing wrong with the hard drive.

The drive was part of a four drive RAID5 array, but I've had no problems with the other drives from that array in other computers, or any drive from any other array. Just format and it works as a single.

But not with *this* Dell Optiplex 780 for some reason.

The BIOS is A04, latest is A15. Of course I have to get Windows installed to run the update, but if the BIOS needs updated to be able to install non-Dell-OEM Windows... excuse me while I go over to a corner and think evil thoughts in the directions of Plano, TX and Redmond, WA.

Edit: I tried every option for the drive controller mode, including Legacy, with and without loading the driver. Setup won't see the drive.

My System SpecsSystem Spec
21 Jun 2014   #2

Windows 10 64 bit

Try resetting the CMOS Memory (BIOS). With the PC powered off, remove the CR2032 CMOS backup battery for at least 10 minutes. Reinstall the battery, observing polarity, and see if that helps.
My System SpecsSystem Spec
21 Jun 2014   #3

Win7 Ultimate 64bit

I downloaded UBCD for Windows and used DBAN to wipe the drive, and was also able to use it to update the BIOS. Don't know which did the trick but Win7 x64 is now installing.

The really crazy thing about this issue (which many people have had) is that when browsing for the drivers *that* can see the already formatted hard drive which setup refuses to see.
My System SpecsSystem Spec

22 Jun 2014   #4


Normally the prompt for drivers during install means a bad installer, either ISO or burn/write.

But the single greatest cure for install failures has always been running Diskpart Clean Command which appears to have worked in another permutation from DBAN.

You can read what was contained in the BIOS update to see if it might have affected this as well.

Otherwise Troubleshoot Windows 7 Installation Failures
My System SpecsSystem Spec
27 Jul 2015   #5

Seven Ultimate 64 Bit.

Having spent a few hours trying to install the mass storage device driver for the Dell 780 only for the machine to not see it and tell me I needed a signed 64-bit driver, I found that both SATA 0 and Sata 1 need to be ticked in the BIOS, select Legacy mode and I could then see a drive. Then the install could see the drive and it was plain sailing from there.
My System SpecsSystem Spec
27 Jul 2015   #6


This means you have a UEFI BIOS' so that the Win7 installation media should be booted as a UEFI device, all partitions deleted during install to reset formatting to GPT. By instead changing to Legacy Mode you bypassed UEFI for this install so will not have the full functions of the new UEFI BIOS'

UEFI BIOS vs. Legacy BIOS - YouTube
UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Forums
UEFI Bootable USB Flash Drive - Create in Windows
My System SpecsSystem Spec

 Optiplex 780 no drive found during setup.

Thread Tools

Similar help and support threads
Thread Forum
Problems Cloning Hard Drive On A Dell 755 Optiplex Dt
Hello I have the Dell 755 OptiPlex large Tower. It had a small 250 Gb hard drive and I put a 1000 Gb hard drive in and loaded windows 7. The computer will not boot into the new hard drive, I have tried everything, including taking out the battery for a an hour or so, updating the bios to the A22...
Hardware & Devices
windows 7 setup cannot found the hard drive
Hello you! I want to thank you for the extraordinary work that you be trying to achieve. Congratulations. My question is: During the reinstallation of Windows 7, the operating system did not find the hdd. on some forum I visit they have to say download the drivers. but I do not know where to...
Installation & Setup
Network drive found but not found?
Hi I'm having a problem that is causing me to pull my hair out. I hope someone can help. I'm using a Vernatim media share 1 tb network drive on my LAN to store things like my iTunes library. Well yesterday it started not allowing me to login through windows. I deleted the mapped share and tried to...
Network & Sharing
No OS found - insert OS setup disk, then press any key
When computer is powered up, I get this message: "No OS found - insert OS setup disk, then press any key" I do nothing but press a key and Windows starts up. Can anyone tell me what's going on???
General Discussion
No HDD found during windows7 32 Bit setup
32bit RC No HDD found during install I'm attempting to install the Windows 7 RC on an acer aspire pc and I am getting the following error at the screen that asks "Where do you want to install Windows": "NO drives were found. Click Load Drivers to provide a mass storage driver for...
Installation & Setup
Trojan Found in Setup.exe on Build 16385 x86 ISO Image!
Well, maybe that LeBlanc fellow had a point about bogus ISO images. I just fired up setup.exe from an image of the x86 Build 7600.16385 leak under my current build 7264 installation and look what Microsoft Security Essentials found (see attached image). Note: The ISO in question has the...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App