Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't re-install printer

01 Jul 2014   #1

Windows 7 Enterprise 64
Can't re-install printer

The scanner in my Canon MP610 multifunction printer suddenly stopped working, giving an error message along the lines that it could not find the driver. To try and fix the problem I uninstalled the printer completely and now I can't re-install it at all. I have tried installing it from CD and on line following the instructions on the Canon support page to the letter, all to no avail.

After uninstalling all the Canon components, Devices and Printers shows an Inkjet Multifunction Printer that I cannot remove - see Attachment 1. If I then try and install the printer from CD with the printer off and disconnected everything appears to proceed satisfactorily but when I plug in the printer and turn it on it is not recognised. Right clicking on Inkjet Multifunction Printer in Devices and Printers, then Troubleshoot reports that the driver for the MP610 device is not installed and clicking on Apply this fix reports further unidentified problems. See Attachments 2 and 3.

I have tried doing this from a user login and administrator login, connected to the internet and not connected, all with the same result. The one difference is that when logged in as administrator I don't see the Inkjet Multifunction Printer in Devices and printers.

I have checked the printer by replacing the OS HDD (actually SSD) with another HDD with a bare bones OS and I had no trouble installing the printer from CD.

I can't restore from an earlier restore point as the backup has been corrupted. Luckily I have an early OS image and my user data on separate HDDs but it would take a fair bit of work to rebuild the system.

I'm running Window 7 Pro x64 on Intel i7, 3.4 GHz, 8GB RAM, 250 GB Samsung SSD for the OS, 1 TB HDD for user data.

Any suggestions?

Regards and thanks

Attached Thumbnails
Can't re-install printer-attachment-1.png  
Attached Images
Can't re-install printer-attachment-2.png Can't re-install printer-attachment-3.png 
My System SpecsSystem Spec
01 Jul 2014   #2


Have you rebooted after Removing Device in Devices and Printers?

Are you sure there's no remaining component in Programs and Features?

If you don't need to scan from glass then enable Automatically deliver drivers via Windows Update (Step 3) and install all Important and Optional Windows Updates as there may be multiple performance Updates needed to make it work correctly. Watch for a driver delivered via Updates or auto-loading from System Tray after you enable Hardware auto-updating.

This should give you basic functionality however if you need scanning from printer top to desktop or from desktop to printer then you'll need the full software package from the printer's Support Downloads webpage for your exact model and bit-version.

If this doesn't work I will connect via Teamviewer to do this for you as I've handled hundreds of them and learned all the tricks.
My System SpecsSystem Spec
03 Jul 2014   #3

Windows 7 Enterprise 64

Thanks for your reply. I have tried a few more things bearing in mind your comments but with no better result.

I do reboot after uninstalling all printer components and I can't find anything else in Programs and Features that looks remotely related, but I've attached the list here in case you can spot something.

Attachment 324015

Attachment 324016

When I try to install using the latest drivers from Canon support the system doesn't recognize the printer when I plug it in and turn it on. If I install from CD it also fails to recognise the printer but it also gives a choice to select the port manually. When I do the MP610 Printer device appears but no matter which port I select the printer still does not print. I can remove the MP610 Printer device but I can't remove the Inkjet Multifunction Printer device no matter what I try. Do you know what it is?

Attachment 324021

Unfortunately I do need the scanner function. That's what started the problem in the first place.

I have not had any problem installing the printer before when I've upgraded the system and even now the printer installs OK if I replace the OS HDD with an older one from before I replaced it with the SSD.

My System SpecsSystem Spec

03 Jul 2014   #4

Windows 10 Pro - 64 bit

Hello : Did you try and uninstall the printer from the control panel , re-boot then install drivers from HERE .

EDIT ( I should of read more ) Sorry -- I see you tried this above -

can you try another port for the usb and see if the computer detects the printer ?.
My System SpecsSystem Spec
03 Jul 2014   #5


Screenshots and Files - Upload and Post in Seven Forums - Windows 7 Forums

Check Device Manager>View>Show Hidden Devices and scour it for the possibly-virtual printer driver to Uninstall.

If that doesn't work try these steps from I want to remove/delete printer/driver from Windows 7, and - Microsoft Community:

Here's how I did it, step-by-step:
1. right-click on desktop, create a new shortcut with target as 'cmd.exe'.
2. right-click on the shortcut, "Run as Administrator"
3. Run the printui tool: printui /s /t2
4. Try deleting the printers. If that doesn't work...
5. CLick Start > Run > Services.msc
6. Locate the Print Spooler service, and right-click > Properties > stop service.
7. Open My Computer and browse to c:\Windows\System32\spool\Printers
(you will need to say "oK" to get access to the folder).
8. DELETE the contents of that folder.
9. Restart the Print Spooler service.
10. Go back into the printui utillity (might need to restart it using same method as above) and try removing printers again. This time it should work. If necessary, check the "Ports" tab and remove any TCP/IP ports that are associated with the old printer.
11. Last but not least, I checked other computers on my home network to see if any of those had mapped to the old printer, and I removed those mappings, as the date of spooled documents suggested it was printed to long after it was physically removed.
My System SpecsSystem Spec
04 Jul 2014   #6

Windows 7 Enterprise 64

Thanks for the help guys but no luck so far.

I have tried different USB ports, different software sources, you name it.

I can remove the MP610 Printer device with printui but not the XPS Writer, which I tried just in case. The print spooler is empty. Inkjet Multifunction Printer doesn't appear at all with printui.

What exactly is the Inkjet Multifunction Printer anyway? I installed the printer again with the bare bones OS just to check, and it does not appear there under Devices and Printers. Just the MP610 Printer. Which all makes me think it's the problem.

I thought my system was up to date but I've just checked the update history and there have been a bunch of failed updates starting with:

Security Update for Windows 7 for x64-based Systems (KB2965788)
Installation date: 12/06/2014 3:00 AM
Installation status: Failed
Error details: Code 80070005
Update type: Important

I've just tried to install 6 outstanding updates and that failed too.

I'm fast coming to the conclusion that I have a major problem and unless you can come up with a miracle I might have to do a total rebuild. Ouch!

My System SpecsSystem Spec
04 Jul 2014   #7


Work through the Troubleshooting Steps for Windows 7
starting with Clean Boot, all infection scans given, and SFC.

Use CCleaner "Run Cleaner" (disk) and Registry tab to "Check for Issues" and "Fix issues" found.

If forced to reinstall, you'll get and keep a perfect install following these same steps for Clean Reinstall - Factory OEM Windows 7
My System SpecsSystem Spec
04 Jul 2014   #8

Windows 7 Enterprise 64

Thanks very much. I'll start working through it but it may take me a while.
My System SpecsSystem Spec
04 Aug 2014   #9

Windows 7 Enterprise 64

Sorry for the long break. I have been out of town a bit so could not devote time to this problem and had to manage with my laptop.

Eventually I had to do a clean re-install as the system just started falling apart. First it got very slow booting, then the cursor stopped responding. Thanks to your excellent tutorials the re-install went smoothly. The system is running well and I'm slowly reinstalling my programs while keeping an eye on performance.

Thanks enormously for your help.
My System SpecsSystem Spec
04 Aug 2014   #10


Good work. Keep it up
My System SpecsSystem Spec

 Can't re-install printer

Thread Tools

Similar help and support threads
Thread Forum
Help!! trying to install hp printer
Im Having trouble installing a hp deskjet on my win7 laptop - when i plug the usb in to laptop bubble message in task bar reads: could not install drivers - When i install hp drivers and select wireless operation im asked to insert printer usb cable to laptop to complete setup - but laptop does...
How can I install a printer twice !
I use two types of paper, one ordinary (in the ordinary paper tray), one coloured (in the rear tray), hence with XP I installed my Canon MP560 printer twice, one with properties for the ordinary tray, one with properties for the rear tray. Then I can select which paper I want by selecting which...
Hardware & Devices
Re-install OKI printer as an ethernet connected printer
I recently bought an OKI C511 printer and installed it with a USB connection to my Win7 64-bit PC. Two other XP computers share it through the network but, obviously, the Win7 one has to be on to do that. With hindsight, maybe I should have connected it via Ethernet to my router. How much hassle...
Hardware & Devices
Unable to install printer drivers, uninstall old printer, update Windo
My Mom has an HP laptop. She recently purchased a new HP printer and I have been trying for the last 4 days to get it to install/connect. I've been in touch with HP but the links they provide aren't resolving the issues. First, using the CD that came with the printer: hangs up at around 85-90%....
Hardware & Devices
cant install printer driver when sharing HP printer
Hi, I have just installed W7 32 bit on a desktop PC which has a HP deskjet F2180 attached to it via USB. I downloaded the W7 32 bit full feature driver and installed it. I have also enabled the printer to be shared on the network. Now I have also just installed W732 bit on a Laptop. Both...
Hardware & Devices
Fresh 7 install (x64) network printer won't install's a good one. I know I'm missing one setting, one trick. Installed my new SSD yesterday, clean install 7 pro x64. I have two printers at home, both of which I used flawlessly before this new SSD and fresh install. I am the administrator of the machine and turn off UAC. I...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App