Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't install windows 7 on new asus laptop

04 Jun 2015   #31


Are you able to install to UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with
even if that's not your preference, just to see if it will install?

My System SpecsSystem Spec
04 Jun 2015   #32

W7x86 W8.1x64

Well, here's the deal.

I use Acronis Trueimage to create master images of W7 for deployment. I'd like to remove the hard drive, zero it and re-image then drop it back in.

Since this is one of the world's stupidest designs, I'd have to take it apart repeatedly if it doesn't work.

I promise you I will throw this dog into the trash if I have to do it from scratch. It's too slow and I'm too old.
My System SpecsSystem Spec
04 Jun 2015   #33


Then Legacy it is!

Make sure any CSM or Legacy BIOS modes are enabled, UEFI and UEFI boot disabled, no bootable devices are booted as UEFI devices.

If you have questions post back camera snaps of the BIOS settings choices. Screenshots and Files - Upload and Post in Seven Forums - Windows 7 Forums
My System SpecsSystem Spec

04 Jun 2015   #34

W7x86 W8.1x64

Ok. I'll flash back to the newest BIOS. At least I could enable CSM there. Not even an option with the stone age BIOS I've got in it right now.

The thing that made me concerned is the boot options. With secure boot disabled and CSM enabled I never got a non-EFI boot option in the BIOS. There is options to create a new boot definition but the only options presented require an EFI enabled device.

I don't know what the results will be but I will do as I described and pull the drive. Zero it and let 'er rip. Hopefully it will boot and that will be that.

I'm hoping this isn't a waste of time. Time is money and I'm a hired gun.

Thanks Greg. You do rock.

My System SpecsSystem Spec
04 Jun 2015   #35

W7x86 W8.1x64

I already had a drive prepared for this so this is the result:

Upgraded the BIOS to the latest version (515 as of this post.)


The OS option is back in this release!

Disabled Secure Boot, enabled CSM and set OS to Windows 7. Booted right up.

I use the old 9.7 server version of Acronis TI. With a little monkeying, it works fine on Win 7 except, as you'd expect, universal restore doesn't work. I create Win7 images sans the boot manager. These backup and restore without a hitch with TI 9.7 Echo Server. Even the scheduler works fine. Mounting an image as a drive letter works fine.

The key to making it work is to manually create the partition with Diskpart while doing the initial installation so as to avoid the boot manager. Skip entering a key and don't install any drivers you don't have to. I like to use an Intel machine with an ICH10R Southbridge. ACHI enabled. Install whatever common software you want and all the updates you can while avoiding drivers and then create the images. Deploy at will on any machine with a chipset that employs ACHI hard drive access and then change the windows installation key to whatever you've got. I'm not too crazy about the later versions of TI. My rocket-science and brain surgeon degrees are still lost in the mail and until I get it I'll just keep using the stuff that works.

I've left a few things out and I'm old and I don't always make sense but I'll answer anything anyone wants to know.

Using this method I can turn out any computer in an hour or two depending on how hard I have to chase after the drivers. Finding your data (pictures, word processing, spreadsheets, videos, music, etc) can take a while. As does zeroing out a hard drive. The Windows 7 part is pretty painless though.

I wish I hadn't gotten fooled by ASUS and their descriptions of their BIOS upgrades. The notes they provide make it appear that the OS selection was deleted by version 402. I deduced I should go back before that. I did. And before that. And before that. No help whatsoever. The new 515 version is the answer.

Thanks again Greg. Give me a holla if I can ever help you.

My System SpecsSystem Spec
06 Mar 2016   #36

Windows 7 x64 Ultimate
BIOS Firmware / Model Mismatch

I've noticed you all having success installing the 550.300 firmware on your 552 machines...
I have a 553 Machine and I'm not even able to see the 550.300 firmware when I'm in the Easy Flash utility.
I've got an Asus X553SA and there is NO " OS Selection " in the bios.
I was able to install Windows 7 from a known-good DVD after disabling secure boot, enabling CSM and cleaning the drive in diskpart. Unfortunately it does the usual " Loading Windows > Bluescreen > LOOP. " In "safe-mode", the last driver to load is disk.sys.

I've tried every BIOS firmware version on the asus driver / support section of this mode's page.
I'm currently running BIOS version 205, which is the latest offered on the support page.

If ANYONE has WINDOWS 7 64 ULTIMATE running on their X553SA, PLEASE let me know how you've done it!
Thank you so much in advance.
My System SpecsSystem Spec

 Can't install windows 7 on new asus laptop

Thread Tools

Similar help and support threads
Thread Forum
Can't install Windows 7 on my ASUS X751MD laptop , not ACPI compaint
Hello there guys, so i have a brand new ASUS X751MD laptop which had a Windows 8.1 Enterprise 64 bit Windows on it, i wiped all the data from the computer, updated the BIOS to the latest version for this laptop ( BIOS 206 ) but the laptop still gives me the "A problem has been detected and...
Installation & Setup
Asus LapTop won't install Windows7 X64 after full wipe Hardisk
Hi Guys i use to be on win7x32 but i bought new rams 8gb to my asus k52j laptop i tried to install windows 7 x64 via usb -dvd dont wark- but after booting from usb and load windows files when "start windows" logo apper the laptop restart and boot agien from harddisk so i did full wipe to the...
Installation & Setup
Installed Linux, now can't install windows -Asus Laptop
I have an Asus laptop 1025c. Atom processor, 2gb ram. It originally had windows 7 starter and i hated it so i decided to flash crunchbang linux. turns out linux isnt for me so i created a bootable usb of windows xp and when i boot to it the setup loads for a sec but then after "starting setup"...
Installation & Setup
Asus Laptop can't find startup entries for Asus Programs
Asus has some way of starting their programs that I can't find. In particular, I want to disable their Wireless Console 3 (wcourier.exe). There are other programs but I can't remember what they are right now. I can only tell you that is does not show up in msconfig or HJT. Does anybody know...
Performance & Maintenance
ASUS laptop trying and failing to install unneeded driver
I bought a refurbed Asus K50IJ-BBZ5 laptop this week. When I log into an administrator account after bootup, it will immediately give me a message about installing new device driver software, then in 20 seconds or so say that the install failed. The failure message specifically says: First,...
Asus Laptop Windows 7 Clean Install Help
Hey guys. I got my dell desktop to work after following all the instructions from you posters like greg and barefoot in my other thread. Today i tried to do the same thing for my laptop. Its an Asus u45jc laptop. I have the Windows 7 Recovery CD for it and the CD with the Driver and Utility...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App