Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Fresh Win 7 64 SP1 install on UEFI MX100 SSD won't reboot without F12

26 Sep 2014   #1

Win 7 Pro 64 SP1
Fresh Win 7 64 SP1 install on UEFI MX100 SSD won't reboot without F12

I purchased a new Dell E5540 laptop that came with Win 8.1 Pro and a 500GB HDD. I wanted to install an SSD so I cloned the HDD to a Crucial MX100 512GB SSD using a standalone dock cloner. Win 8.1 started fine on the SSD but I wanted to enable AHCI in the BIOS, which I could never get working. I tried all the registry tricks but it would not find any bootable devices unless I returned BIOS to RAID from AHCI.

Screw it I thought, I will just load Win 7 Pro fresh and it will pick up the AHCI BIOS setting. This led me down a rabbits hole. I wasn't aware of the issues related to Secure Boot and Legacy vs UEFI before I started, so by trial and error I had to disable Secure Boot and enable Legacy Option ROMs in BIOS. Interestingly, Windows Setup would not boot off the legacy DVD, do I had to select UEFI DVD from the F12 boot menu for setup to begin.

From within Windows setup, when I got to the part about where to install Windows, I deleted all the partitions and dropped out to Shift-F10 and ran DISKPART and issued the CLEAN command. I then returned to Windows Setup and followed instructions to create a new GPT partition (which was successful and actually created three partitions). Windows Setup proceeded successfully, but the first time it rebooted itself to complete the setup, I got an error "No bootable devices found".

After cursing a lot, I found that if I manually select Windows Boot Manager or "UEFI Crucial 512..." from the F12 UEFI boot menu, Windows will start. But if I just let the machine boot itself, it reports no bootable disk found.

In the Dell 5540 BIOS, the Boot Sequence option has two choices to list available boot devices: Legacy and UEFI. When I select Legacy, I see Diskette, Internal HDD, USB Storage Device, CD/DVD, and Onboard NIC. When I select UEFI, I see Windows Boot Manager and UEFI: Crucial_CT512MX... When I set the Boot Sequence to use the UEFI mode and restart the machine, I get a message about no bootable device found, and when I select Legacy and restart the machine, I also get the no bootable device message. Only when I restart the machine and press F12 and manually select Windows Boot Manager or UEFI: Crucial_CT512MX... will it start Windows properly.

What is going on here? I have never had this much trouble installing Windows. Windows seemed to install correctly after it created the GPT partitions, so Windows AHCI must be working. I can't seem to get the correct settings configured to point to the boot process to the SSD drive by default. Am I missing something simple?

Any and all help is greatly appreciated.

My System SpecsSystem Spec
26 Sep 2014   #2

Windows 7 x64, ultimate/pro/home, SLES x86 & ia64

it sounds like your problem lies within the bios, the difference being the newer EFI or UEFI (and gpt partition) versus the traditional BIOS that uses an MSDOS partition table.
the big difference is the old way with BIOS and MSDOS partition table, the bios cannot read a file system on the drive. it only knows or is programmed to read the first sector of the disk which is an msdos partition table, and in there is the disk address where the bootloader is for whatever the operating system. it's all hard coded or firmware that you never modify or had to worry about.
I think what's happening with your UEFI is, EFI can read a file system on the drive along with gpt partition tables and a whole bunch other stuff. When first power on and UEFI starts up, go in to its set up by hitting delete key, or F2 or whatever... look for a menu that says something like boot maintenance and add boot device. from there on a pc/laptop you are on your own. i'm familiar with linux and ELILO on large rack systems that uses EFI / ELILO. the "bios" on this system, using that word as slang it's really EFI, presents you with a startup menu which i have to tell it under boot maintenance menu - add boot device and i can have a boot order. whatever boot device you set is specific to a hard drive volume label and SCSI ID of that drive. change drives and whatever is in that EFI menu is then obsolete and wrong, you have to update it. hope that helps.
My System SpecsSystem Spec
26 Sep 2014   #3

Win 7 Pro 64 SP1

I am still working on this problem.

When AHCI is enabled and I install in UEFI mode, the install completes successfully, but fails to find a bootable disk upon the first restart.

When AHCI is enabled and I install in legacy BIOS/MBR mode, the install does not work at all, with Windows complaining it cannot create a system partition.

When SATA is set to RAID instead of AHCI, the setup works properly and reboots properly. So AHCI is the culprit, but I cannot understand why Windows can install successfully but not boot successfully afterwards. (Although I can manually select UEFI Windows Boot Manager via F12 during restart and get in.)

Note: I installed the F6 Intel AHCI drivers during setup and it didn't seem to make any difference.
My System SpecsSystem Spec

26 Sep 2014   #4

Win 7 Pro 64 SP1

Update: I double checked the Dell website for BIOS updates for my e5540. I found an A07 BIOS that was a few revs newer than the A04 it was shipped with. I hassled with creating a bootable USB thumb drive and copied the BIOS exe to it (just Google 'Rufus' for how to do this). I was able to reboot the e5540 and select the USB via F12 during reboot, and navigate to the BIOS .exe and install it.
After installing the updated BIOS I was able to do a couple things:

1) I was able to install Windows 7 via legacy mode. Previously, Windows couldn't create a System Partition in this mode. After the BIOS update, Windows successfully installed.

2) I was able to install Windows 7 via UEFI mode. Previously, after creating the GPT partition and installing, Windows 7 could not find a bootable device upon reboot.

I left the new machine in UEFI mode with a GPT partition. I guess I should have bothered to check for a BIOS update, but honestly - I have had probably 20 computers and rarely had to perform a BIOS update. This machine was produced less than 8 weeks ago. The applied BIOS went from A04 to A07 in that time. I appreciate the folks who addressed whatever the underlying issues were between A04 and A07, but I am not happy that I wasted a day and a half trying to figure out what the issue was.

I hope my time wasted will save others some time in a similar situation.

My System SpecsSystem Spec
26 Sep 2014   #5

Windows 7 Ultimate 32bit

My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Dual Boot - Windows 7x64 UEFI Install BSOD on Reboot 0x0000007e
Hi all, So I got a new laptop its a Lenovo Y700-15ISK, UEFI Bios. I am trying to get the machine to dual boot Windows 7 and Windows 10. I installed Windows 10 first, no problem. Windows 7x64 is just not working. My windows 10 was a fresh install, slipstreamed updates and drivers from Lenovo...
Installation & Setup
UEFI Fresh Windows 7 Install Issues
I am trying to instal Windows 7 Ultimate on a 4T HDD using UEFI. My HDD is already GPT it had 3 partitions 1 set at 150g another set at 750g and the other set at 2xxxg. The 750g and the 2xxxg both have data stored on their partitions, so I don't want to delete them. So, I deleted the first...
Installation & Setup
Screen goes blank each time I reboot (fresh Windows 7 install)
I just installed Windows 7 Home Premium 64 bit, fresh on a brand new PC build. Mobo is MSI Computer Corp. Motherboard ATX DDR3 1333 LGA 1150 Motherboards Z87-G41 PC MATE. Vid Card: EVGA 02G-P4-3751-KR G-SYNC Support GeForce GTX 750 Ti 2GB 128-Bit GDDR5 PCI Express 3.0 Video Card As 7 was...
Installation & Setup
Windows reboot at startup even after fresh install
A month ago, my Win8 PC got stuck while working, so I had to reboot. After I turn it on, Windows couldnt get started, even after it tried to repair itself, It said that it couldnt fix it. I waited a few hours, and It finally got past the Windows loading screen. It worked fine till a week ago, when...
General Discussion
Windows7 cannot reboot after fresh install
My platform is XP with Q6600 cpu and DFI infinity P965 MB, after fashly installed Windows7 either in 32bit or 64bit, the Win7 cannot reboot after the POST, can someone tell me what is wrong and any solution?
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:16.
Twitter Facebook