Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Moving W7 from RAID0 to SSD

02 Nov 2009   #1

Moving W7 from RAID0 to SSD

I'm depressed.
I need to move my Windows 7 from RAID 0 to my shiny new SSD drive.

Configuration before SSD:

Windows 7 RC
RAID 0 (nVidia chipset):
3x250GB on SATA ports 1, 2, 3
100GB free space (left by previous instalations)
100GB Windows 7 system partition (about 70GB used) (C)
rest is free now (I had some other partitions but deleted them)
Works fine, starts with no problems

Configuration during movement:
Same as above
160 GB clean SSD drive connected to SATA 4 (not being any raid member)
Windows starts normally

Desired configuration after:
No RAID drives
160 GB SSD on SATA port 1 with one 160GB partition (preferably C)
Controler either in IDE mode, or AHCI.

Available additional hardware:
160GB ATA HDD with approx. 95GB free

Tried sollutions:

Windows backup
Backup made on ATA drive connected either directly to mainboard or via USB (with use of external case). Approx. backup size 60GB.
Windows restore doesn't see SSD as destination drive.
Whatever I do, I get an error saying "no drive that can be used for restoring system could be found".
I tried with RAID drives connected, as well as with drives off and controller set to IDE or AHCI.

EASEUS Back up
17(!) DVDs with backup
EASEUS doesn't let me choose SSD drive as destination. It just doesn't appear there.

Seems that doesn't support RAID. On source page I can choose between 3 250GB drives, not one 750GB. Strange. it seems like clonezilla doesn't care about RAID controller, it works with drives directly.

Acronis Migrate easy
Seems to work, but migrating (cloning) takes 17 seconds, and nothing is copied to SSD drive. It says that process is complete, and successfull but apparently is not. SSD drive stays empty.

Any other (good) ideas how to deal with it?
Why 160GB free hard drive is not enough for windows bakcup to fit half empty 100GB partition?
What's wrong with Acronis? It seems very strange, that is tells me it's done and successfull and it does nothing.

Thanks for all help in advance. I'm on the edge of nervous breakdown (read: fresh instalation

My System SpecsSystem Spec
02 Nov 2009   #2

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

Welcome to Seven Forums.

Do you have a functional OS on this system now?

Did you connect the SSD to a functional system in your step "Configuration during movement:", then activate and partition the SSD?

How many backups out of all the attempts do you have stored somewhere (maybe on your external HD)?

Have you tried a fresh install of Win7?
Can it see your SSD?
If it can see it, put a fresh install of win7 on your SSD, then restore your backup on it.

If it doesn't see it run a boot CD/DVD to check that the SSD is available.

Another option, down load the free Partition Wizard, and get the Bootable CD. See if it will recognize it.

Let us know your progress.
My System SpecsSystem Spec
02 Nov 2009   #3


1. System installed on RAID is fully functional and works fine. No other systems were installed.

2. On first try I did connect SSD right after backing up Windows 7 partition from RAID disk. Then I tried to restore without touching SSD at all (it failed). I tried also to create unformatted active partition on SSD, NTFS partition, and 2 partitions (created by windows installation. 1st is system reserved type 100MB, and 2nd regular ntfs). None of those tries were successful.
SSD was visible by system with no problems at all.

3. I got 1 windows back up on additional PATA drive which i can connect either directly to controler, or via USB external case. Tried both solutions with no effect on windows back up thing. One DVD backup made with EASEUS.

4. Yes I tried fresh instalation on SSD. SSD is visible by system and it runs perfectly. Unfortunately it's fresh, not the one I want to use.
Note: RAID drives are disconnected in this case.
I will try to use it to restore tonight. Backup files are on additional PATA drive. Should I connect it via external USB case, or directly to controller (MB)? I'm affraid that connecting to main board might have effect on drive letters/partition names in windows.
My System SpecsSystem Spec

02 Nov 2009   #4

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

I would connect the external HD by USB first, if it works restore your backup.

If for some reason the external HD won't work via USB then connect it to the mother board, should be fine.

Let us know how it goes.
My System SpecsSystem Spec
02 Nov 2009   #5


Nothing has changed when I used fresh instalation to restore from backup.
Restoring from fresh instalation wasn't possible as back up tool didn't see any image to restore from (I can see those folders and files in explorer)

Windows restore from bootable CD sees image, but again gives me an error:
"No disk that can be used for recovering the system disk can be found. Try the following: [...] (0x80042412)"
My System SpecsSystem Spec
02 Nov 2009   #6


At some point (don't ask me how I got there , with PATA drive connected to USB, and booting with recovery CD, I got error:
"The system image restore failed.
Error details: The disk that is set as active in BIOS is too small to recover the original system disk. Replace the disk with a larger one and retry the restore operation. (0x80042407)".

Well... 160GB HDD doesn't seem to be too small for 100GB partition.
My System SpecsSystem Spec
02 Nov 2009   #7

Windows 7 Ult, Windows 8.1 Pro,

It can be done using the "clone" feature in Acronis true image.
My System SpecsSystem Spec
02 Nov 2009   #8


I'll try true image, but acronis migrate didn't work.
My System SpecsSystem Spec
02 Nov 2009   #9


Ok. Problem solved with Acronis true image. Clone feature looks exactly the same as Acronis migrate program, but it's more successful.

Anyway I couldn't do it with windows' restore feature. If you Dave, or anyone else want to investigate it further, I'll be more then happy to follow your advices. I won't delete RAID partition for couple more days if anyone feels like trying to find solution.

Thanks Dave and Chev for help. I wouldn't get it done without you. :)
My System SpecsSystem Spec
02 Nov 2009   #10

Windows 7 Ult, Windows 8.1 Pro,

Mpol, if you read further down the page I linked too there is a Rep from Acronis who describes the process using "Acronis universal restore" which is specifically made for the process but it can also dissasociate the old hardware from the image in case you need to more the image to a different machine.
Converting Vista raid0 to single drive - Wilders Security Forums

I read that many were successful moving RAID 0 images to single drives using Acronis true image "clone" so I figured it might work for you.
My System SpecsSystem Spec

 Moving W7 from RAID0 to SSD

Thread Tools

Similar help and support threads
Thread Forum
Moving files to external, formatting then moving back.
Hi everyone. I just bought a new SSD. I plan to whipe my old drive and put the OS onto the SSD. On my current drive I quite a few games. The question I have is about backing up games/moving the files. I have steam, origin and battlenet. I tried to use steam back up before, it stopped working...
General Discussion
RAID0 SSD Samsung 830
Today trying to setup RAID0 2 Samsung 830 128GB and 256GB SSD. When i try to create raid new volume why it only allow 226.6 GB only am i do something wrong?
Hardware & Devices
setting up a RAID0
Looking to set up a Raid0 with 2 x 1 TB drives. Only problem is the drives are from 2 different companies. 1 is a HITACHI Deskstar 1TB 7200 RPM SATA 3.0gb/s, the other is SAMSUNG Spinpoint F3 HD103SJ 1TB 7200 RPM SATA 3.0Gb/s. Am i able still able to combine these 2 drives to make Raid0 array?
Hardware & Devices
ssd in raid0 how do i do it?
I want to put 2 Mushkin Callisto Deluxe 60gb ssd in raido for awsome performance but never did a raid setup. How do u do this?
Installation & Setup
RAID0 Help!
Can anyone guide me through setting up RAID0 on the Gigabyte GA-MA790FXT-UD5P? I have 2 WDC640 Blacks and am having major trouble getting it to work" 'EDIT' Im using Windows7 x64 and it wont let me continue it is asking for 'signed' drivers and I am using the drivers from the disc that came with...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App