Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot install SP1 ERROR_NOT_FOUND 0x80070490 Please help

08 Oct 2014   #1

windows 7 home premium
Cannot install SP1 ERROR_NOT_FOUND 0x80070490 Please help


I have been trying to install sp1 but have been having much difficulty.

I have tried the sfc /scannow and the system update readiness tool.

I have uploaded the CheckSUR.log

Any help would be greatly appreciated

Thank you


Attached Files
File Type: log CheckSUR.log (10.3 KB, 9 views)
My System SpecsSystem Spec
08 Oct 2014   #2

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

Windows Update error 0x80070490 speaks to the issue.
My System SpecsSystem Spec
08 Oct 2014   #3

windows 7 home premium

Thank you for the response. I have done both steps described in the link but the problem persists. Any help would be appreciated
My System SpecsSystem Spec

12 Oct 2014   #4

Windows 7 Home Premium x64

If you haven't resolved this:

You would want to start by resolving your issues the CheckSur log.
You have it kinda easy; you have the same error from the same folder.

Repair methodology on: CSI Payload File Missing

CSI Payload File Missing means you are missing a payload file from your WinSxS folder. To resolve you'll need to identify, find and replace the files missing in their respective folder.
The error is (f) CSI Payload File Missing 0x00000000 <Payload File> <Payload Folder>

Payload Folder is the folder inside WinSXS, and the Payload File is the actual file missing.
In your case, all your CSI Payload File Missing errors are from same folder: amd64_microsoft-windows-minkernelapinamespace_31bf3856ad364e35_6.1.7600.17107_none_66ff46fd953e6c5c

So with first error, you'd need to find replace api-ms-win-core-util-l1-1-0.dll with a good copy into the c:\windows\winsxs\amd64_microsoft-windows-minkernelapinamespace_31bf3856ad364e35_6.1.7600.17107_none_66ff46fd953e6c5c\

6.1.7600 is Windows 7 Base image, so you'd need to get the replacement copy from: 1) Another working Windows 7 SP0 (Starter, HB, HP, Pro, Ult: doesn't matter), 2) from your recovery partition WIM if PC with recovery partition, or 3) the install.wim from base Windows 7 SP0 install disk (can download legally online).

Once you have your good source, you'd just go through and replace each file missing.
After that, I'd run CheckSUR again to ensure all errors are handled; then attempt SP1 install via Standalone again.

Now, I imagine that SP1 will still fail with same error code, 0x80070490; because that specific error has it's own repair method.

After you get CheckSUR fixed. Attempt SP1 again, wait for fail and post up the CBS.log and go from there.


To expand:
0x80070490 means ELEMENT_NOT_FOUND; which is simply stating that an element should exist that isn't found. That element could very well be the files in winsxs that CheckSUR reports as missing, it could be files missing in another Windows Update, or it could be a corrupted driver in driver store.

If we continue to have the element not found after fixing checksur; then we'd look in CBS.log for 490 to identify a KB# causing SP1 to fail. In that case, we'd simply uninstall that update.
If we don't find a KB# reported in CBS log, we'd look in the for 490 and uninstall that driver from driver store via pnputil -a
My System SpecsSystem Spec

 Cannot install SP1 ERROR_NOT_FOUND 0x80070490 Please help

Thread Tools

Similar help and support threads
Thread Forum
Sp1 - error_not_found 080070490
I know there is lots of issues about this error I think I tried them all and have got just just few errors now: The hardware: HP Compaq 7100 z Windows7 x64 Professional OA. My log CBS: SPI: (CheckForPendingFlag:90)Failed to open component hive at C:\Windows\System32\config\components er=0x0...
Windows Updates & Activation
Update KB2726535(x64), Error 0x80070490
For a few days I am trying to install the update KB2726535; I always get the Error 0x80070490. Tried everything to fix it, but nothing worked. You are my last hope! Thank you for helping me, 2press
Windows Updates & Activation
Problem using network troubleshooter: error 0x80070490
When attempting to use the network troubleshooter, I receive this error (0x80070490) "A problem is preventing the troubleshooter from starting". I have attached a jpg of the problem, hoping for some answers. Thanks!
Network & Sharing
How to fix error 0x80070490 so windows 7 sp1 will install
Have tried for several days to install SP1 on Windows 7 Ultimate. Ran/installed System update readiness tool, ran the CSC log, ran the windows update troubleshooter and still no luck. Last update received was at 8:42 pm (PST) for KB978821. Please help if you can.
Installation & Setup
Windows 7 SP1 x64 Install Error 0x80070490
Whenever I try to install Windows 7 Service Pack 1 for x64, either via Windows Update or the standalone installer (windows6.1-KB976932-X64.exe - 947,070,088 bytes), I get the following error message: Installation was not successful Element Not Found Error: ERROR_NOT_FOUND(0x80070490) ...
Windows Updates & Activation
Cannot Install Win 7 over XP Home~ERROR Code: 0x80070490
Greetings Friends. I have an unfortunate problem with Windows 7. I purchased it for installation on a PC on which I've long been happily running XP; it was time to update. The new Win 7 installed beautifully on my lapotp with Vista on-board. Here is what occurs: the first language I get...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:30.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App