Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to delete a file

11 Oct 2014   #1

W7 64 bit ultimate
Unable to delete a file

After advice have carried out full clean install of W7 64 bit

Profiles left in default location on C:\

The old profile was on E:\

I am unable to delete that folder .... went through it a subfolder at a time deleted all except one tmp file
This is blocking me from deleting the folder tree.

The permission for that file show I have full control ... yet when I try to delete it say I need permission from admin to do this .... I am admin on this PC.
In fact the account it say I need permission form is the account I am using.

Anyone able to help me delete this ?

My System SpecsSystem Spec
11 Oct 2014   #2

Windows 8

First take ownership of the file/folder, then try to delete it again.
Take Ownership of a File or Folder
Learn How to Take or Assign Ownership of Files and Folders

If this still doesn't work, you can follow this tutorial which describes how to delete without explorer:
Undeletable File - Delete
My System SpecsSystem Spec
11 Oct 2014   #3

W7 64 bit ultimate

option 1 & 2 made no difference - it showed I was alreday owner.
Had to use 3rd option - that worked.

My System SpecsSystem Spec


 Unable to delete a file

Thread Tools

Similar help and support threads
Thread Forum
Unable to delete file on my desktop
I recently decided to install cabal on my laptop again. I used internet download manager to install it. However, when I run the installer, explorer.exe becomes unresponsive and I have to kill it. Right clicking it gives the same result. I am unable to check the size of it. I've try defragmentation...
General Discussion
Unable to delete a file,can't delete it can't shred it,
I looked at my firewall events earlier and i saw a file had been trying to connect to the internet but had been blocked by my firewall. Whenever i install a program i am unsure of i block the exe file from connecting to the internet until i'm happy its a safe program. The file is...
General Discussion
Unable to delete file from desktop
So I have this file that doesn't have anything, not extention or file size at all. I tried to delete the icon from my desktop and Windows says "Could not find this item" "This is not longer located in C:/.... Verify the item's location and try again." I then saw on another post, about running...
General Discussion
Unable to delete file
Keep getting this error, no matter how many attempts I make to delete this file. I do not have video open at all. Please help
General Discussion
unable to delete a file (windows says its in use)
Well it happens to both of my video files (mkv) right after i've extracted the file. What puzzled me is that it says windows explorer is using it which i ddn't even play the video. I tried looking around in task manager trying to stop the process but stopping explorer.exe would end up closing...
General Discussion
Unable to delete a file in Win 7
Hello, I've seen it's a few other threads about how to delete un-deletable files but it doesn't seem to be the same problem as I have. About a week ago I downloaded a patch for a game. I was never able to open this patch because it says I don't have permission. And now I've realized I can't...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App