Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No drives were found Windows 7 Ultimate x64

13 Nov 2014   #1

Windows 7 Home Premium x64
No drives were found Windows 7 Ultimate x64

Hello there I am currently trying to install Windows 7 Ultimate 64 bit on my computer off of a USB and the setup loads up perfectly, but once I get to the In stallion part it tells me "No drives were found". I have my USB flash drive in my 2.0 port also. Whoever can help me solve this issue will get money via PayPal.

My System SpecsSystem Spec
13 Nov 2014   #2


My System SpecsSystem Spec
14 Nov 2014   #3

Windows 7 Pro x64 Windows 10 Pro x64

Is the hard drive showing properly in the bios ?
My System SpecsSystem Spec


 No drives were found Windows 7 Ultimate x64

Thread Tools

Similar help and support threads
Thread Forum
No drives were found...there are no fixed drives to show
I tried everything i could,nothing worked. i think that my hdd is dead few days ago it was working perfectly idk what happen please help me
Installation & Setup
No drives were found when installing windows 7
Hello, My hard drive was dead so I sent it away to "KnowHow" to get a replacement, when i got it back it was running extremely slow, so i decided to install windows 8 (because I had the CD laying around) to see if it would run any better, midway through the install I canceled and decided to...
Installation & Setup
Detecting drives; Done, No Drives Found - Error and Slow startup
Hey. When I start up my PC everything goes very slowly, things "chops" or lagged as most say. It comes up a menu that says: JMicron Technology Corp.. PCI Express to SATA1 HOST Controller ROM v1.02 Copyright 2005-2010. JMicron Technology Corp..
Hardware & Devices
No drives found when trying to reinstall/repair Windows
Hi all, I have a big problem: I have a netbook ASUS Eee PC 1005PXD. After only two days of use, i get a black screen at the beginning: "Reboot and select proper boot device or insert boot media in selected boot device and press a key". Pressing F9 on boot doesn't work and i'm still getting...
Installation & Setup
No drives were found while installing windows.
So, I was reinstalling Windows, and when it comes up to the bit that I choose the partition, it comes with nothing. At the bottom it says: . I am a newbie at computers and I dont want to open up my pc. Any suggestions? My specs: It's been fine when i was reinstalling windows few months...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App