Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!

01 Dec 2014   #1

Windows 7 Professional x64
Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!

I have come to the conclusion that it is impossible to configure this laptop to dual boot Windows 7 and 8.1, unless anyone knows better. The issue seems to be with the BIOS settings which appear to be mutually exclusive to booting either Windows 7 or Windows 8.x – but not both.
Whether opting for a MBR or GPT configuration, or installing Windows 8 from USB media or within Windows 7 the issue remains.

I ‘downgraded’ the pre-installed, bloatware ridden Windows 8.1 on this laptop to a clean install of Windows 7 Pro with no problems using default Windows 7 BIOS settings (Win 7 OS, load default settings) on a 500GB partition using DISKPART as per directions on this site. The problem occurs when trying to install Windows 8.1 on the remaining unallocated 500GB partition on my hard drive using these Windows 7 optimised BIOS settings. When booting 8.1 directly from USB (downloaded 8.1 – same version - using Windows media creation tool as I have OEM key in BIOS) the installation will freeze (no mouse pointer) on the initial ‘select keyboard layout’ screen. If I attempt an installation from within Windows 7 it’ll get as far as to when it reboots then hang.

Sure, I can load Windows 8 optimised settings in BIOS and then install 8.1. Problem is then when I select 7 from the bootloader, booting will freeze during the formation of the Windows logo with a BSD 0xA5 BIOS in system not fully ACPI compliant.. error – and there’s no ACPI settings in BIOS. If I then change back to Windows 7 optimised settings, I’ll get into a ‘Your PC ran into a problem and needs to restart...’ loop. I’ve updated BIOS from A7CN40WW to the latest A7CN43WW to no avail. I’ve also attempted an GPT/UEFI install and run into the same issue, and I’ve tried about ever permutation of BIOS settings available.

Any help here would be greatly appreciated as I’m tearing my hair out over this one.

My System SpecsSystem Spec
01 Dec 2014   #2
Microsoft MVP


What happens to UEFI and CSM when you choose Win7 optimized default? Can you wipe the HD to remove all code then boot Win7 as a UEFI device, install it to first partiiton, then boot Win8 as UEFI device and install to second partition? What exact error or failure do you get?

What if you set CSM enabled and first to boot, then try the above?

What if you set CSM enabled, first to boot, and then load Win7 optimized defaults?

Are there other choices besides Win8 and Win7 optimized defaults?

What are the exact CSM, Legacy BIOS, BIOS Boot order settings available after turning off Secure Boot. Pictures would help. Screenshots and Files - Upload and Post in Seven Forums - Windows 7 Forums
My System SpecsSystem Spec
10 Dec 2014   #3

Windows 7 Professional x64

OK geezer, thanks for your prompt response and apologies for my delay. Screen shots are below.

  • · When Windows 7 optimised is selected, legacy is enabled support (CSM is not available in this BIOS but I believe ‘legacy support’ is the equivalent) with UEFI configured to boot first. I change usb mode to 2.0 as per instructions and installed Windows 7, changed usb mode to 3.0 then installed all drivers including drivers for usb 3.0.
  • · Yes, I can perform a CLEAN or CLEAN ALL during DISKPART to remove all code from the hard drive.
  • · Yes I can then install Windows 7 on a first partition as a boot device either UEFI/GPT mode or legacy/MBR.
  • · The problem then arises when I try and install Windows 8 on a second partition. Using any combination of BIOS settings with Win 7 OS selected on (either UEFI/GPT mode or legacy/MBR) causes Windows 8 to freeze on the language select screen with no mouse pointer.
  • · I could then select Win 8 OS optimised defaults in BIOS, disable secure and successfully install Windows 8. Trouble is when I select Windows 7 to boot from the bootloader it will hang at the formation of the Windows logo while booting with an 0xA5 BSD STOP ERROR (illustrated in screen shots).
  • · Yes there is another choice in BIOS – other OS – but similarly I cannot boot Windows 7 using this despite attempting numerous other BIOS settings.
And just when I thought I was getting nowhere, now I can’t even enter the BIOS settings, either with the novo button or by using Fn + F2. All I get now is a static cursor in the upper right corner of the screen although Windows 7 still boots (bootblock must be OK). I’ve somehow managed to semi-brick it and corrupt BIOS by over use of the novo button. Oh joy. I’m thinking of bring a hammer to this darn thing unless anyone can persuade me to do otherwise.

Attached Thumbnails
Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-bios_exit_-selection.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-boot_legacy-support.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-boot_uefi.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-boot_uefi_legacy_select.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-configuration_usb2_3.jpg  

Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-configuration_w7_usb3.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-configuration_w8.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-exit_w7_optimised.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-secure.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-security.jpg  

Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-os_select.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-w7_boot_hang.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-acpi.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-w8_install_hang_no_pointer.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-w8_install_-with_pointer.jpg  

Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-your_pc_ran.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-w8_after_boot_attempt_hang.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-w8_install_partition_select.jpg   Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!-w8_clean_install.jpg  
My System SpecsSystem Spec

11 Dec 2014   #4
Microsoft MVP


There's a BIOS update from November. Did you install it? It may be the fix for this: Laptops and netbooks :: Lenovo G Series laptops :: G50 30 Notebook Lenovo - Lenovo Support (CA)

I see Secure Boot still set to Enabled. It must be completely disabled.

You have tried to install both 7 and 8 at both 8- and 7-optimized defaults in both UEFI GPT and Legacy MBR mode?

Have you tried both OS's using flash stick install method, formatting flash stick using Rufus? UEFI Bootable USB Flash Drive - Create in Windows

If BIOS will not respond to hotkeys or Lenovo button and you don't have easy access to CMOS battery to reset the BIOS to defaults, then I'd install Windows 8 to UEFI if its available presently then enter BIOS setup using How to enter Setup Utility (F1) or Boot Menu (F12) on a Microsoft Windows 8/8.1 preloaded PC - Lenovo Support (US)

The model's Win7 downgrade issues have been aired here since last summer in Lenovo G50 Win7 Install Problem - Windows 7 Help Forums with regular updating from those struggling with it. The latest which might apply is this checklist:
Quote   Quote: Originally Posted by Miteto View Post
Here some info I found about that matter in a blog - click. It's written in bulgarian but it says the following:
1. OS Optimized Defaults - select "Win7 OS".
2. Load Default Settings - Hit Enter
3. Load Optimized Defaults - choose Yes! - this is the key point!
4. Then go to Configuration -> USB Mode - choose USB 2.0
5. Next go to Boot -> Boot Mode - switch to Legacy Support
6. Boot -> Boot Priority - switch to Legacy First
7. Exit -> Exit Saving Changes -> Yes

That's it.
I also recall on my G500 that to Dual Boot with 7 I had to choose it as the Optimized OS while at the same time loading Optimized Defaults. It's tricky.
My System SpecsSystem Spec
16 Dec 2014   #5

Windows 7 Professional x64

Tricky is an understatement – it’s more like an exercise in frustration.

  • Yes, I have installed the latest BIOS update, A7CN43WW, released in November (I wish I hadn’t as you’ll soon read) but this hasn’t overcome the issue (the laptop had version A7CN40WW when purchased).
  • Yes, I have installed with secure boot disabled. The enabled options are just displayed here for illustration.
  • Yes, I have tried to install both 7 and 8 at both 8- and 7-optimized defaults in both UEFI GPT and Legacy MBR mode.
  • Yes, I have tried to install both OS's using flash stick install method, formatting flash stick using Rufus.

  • I’ve already disassembled and desoldered one leg of the RTC battery to clear CMOS BIOS settings to no avail – the problem is with the BIOS integrity itself, and as it seems to be locked on windows 7 optimised settings, I can’t install Windows 8 and modify BIOS settings from there.
  • I am aware of the G50-30 downgrade issues and this was never a problem. I used similar instructions to install Windows 7.
Now, another issue with this bloody laptop is that the BIOS update tool by default does not allow the flashing of current or legacy BIOS. It seems Lenovo and their non-existent customer support, doesn’t like people actually using their computers. I even extracted the self-extracting executable and modified the platforms.ini [Bios_Version_Check] flag to enable flashing of the current BIOS to restore functionality. However, this doesn’t work as platform.ini is created by the tool itself, InsydeFlash.exe, so immediately over-writes any modded flags when it is run.

I read that it is also possible to restore BIOS from a USB stick while booting if the extracted bioss.fd is renamed to a default name, using Fn+B while booting. The trouble here is that to find this default name the tool used doesn’t work as this BIOS is RSA signed and modding just one byte will result in a brick.

So it looks as though (unless anyone knows better), I’ll have to wait for a BIOS update to even have the privilege of accessing BIOS settings again.

A real shower of sh** this one, as we say in the UK.
My System SpecsSystem Spec
16 Dec 2014   #6
Microsoft MVP


Is it still covered by the one-year tech support and parts warranty? If so ask for a supervisor to arrange an RMA or get elevated support. Let them know the issue is being aired in the top tech forums and is already the top Google search result for the model so their support (or not) will be on display for the world to see.

Remember if you get non-helpful Support you can keep calling back in. I'd insist the elevate this to a supervisor and if necessary management. If they want you to pay for extended Support then ask what they can offer exactly.
My System SpecsSystem Spec
17 Dec 2014   #7

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Can you rollback BIOS to the previous version?

Lenovo solders the RTC battery? I often wonder about OEMs - one mfgr seals the main laptop battery, you cannot remove it - sheesh!

You might still try giving support a call - some Mobos are being replaced by Lenovo after even the warranty expires. As Greg mentioned - call and if the results are not satisfactory, call again and escalate the issue.

Here are some things I came across while searching.

As the system comes up, Shift + F2 or tapping esc might get you into BIOS

Reset CMOS: remove AC power, remove DC power, press and hold the power button for 2 full minutes to drain residual charge.
Boot using AC only - any luck getting into BIOS?

If that doesn't work, try: remove battery and AC power, wait 5 minutes
connect AC power ONLY - leave the battery out
press and hold the insert key, then while holding the insert key, press the power button
a popup should appear asking for the boot device - do not select anything
press the TAB key and the BIOS menu should appear.

There are a couple of settings that you might want to check
Fast or rapid boot should be disabled.
Signed drivers should be disabled.

I think you and Greg went over the other settings (Secure Boot=disabled, UEFI | Legacy=UEFI)

and the last thing I can think of is: software and hardware SHOULD be backward compatible, but they are never fully forward compatible (updates and patches MIGHT get over the hurdle, but it's still bubble gum and rubber bands).

You might have already tried this, if so I missed it.
Win8 should be the initial install and dual boot Win7 after that is stable - it shouldn't matter to the end user which OS was installed first, they can boot to either one. It might matter to Windows7 since some of the BIOS changes and hardware advances were geared to Win8. Anyway, that's how I would approach a Win8 / Win7 dual boot.

Good luck,

My System SpecsSystem Spec
10 Mar 2015   #8

windows 7 unlimate 32bit

i install win7 32bit on g50-30 i made allmost all what i need then i update bios to a7cn43ww and stuck on bsod cd with win7 can;t boot or usb with win7 too i made bios reflash back using usb pen and this: after reflash i load win7 settings (boot mode legacy and boot first EFI) and win7 boot again if you need fix just downgrade bios back to a7cn40ww
i attached bios if they will erase it from pdf file

Attached Files
File Type: zip (3.22 MB, 97 views)
My System SpecsSystem Spec
10 Mar 2015   #9
Microsoft MVP


Confirm BIOS flash then change BIOS settings to Boot Mode Legacy, but First Boot UEFI (which seems contradictory)??

This results in UEFI install? Any other needed settings? What about Reset to Defaults? Which choice there?
My System SpecsSystem Spec
11 Mar 2015   #10

windows 7 unlimate 32bit

Bios a7cn43ww will not allow CD/usb with win7 installation or installed win7 (before bios upgrade) - BIOS is LOCKED to win8 (or badly updated) You must downgrade bios from a7cn43ww to a7cn40ww (tutorial and files up)m then in Bios setup sellect OS type to Win7 and press laod defaults this will set boot to legacy but boot order to EFI this will allow you to install or boot installed win7 to make downgrade you have to set BIOS BACK FLASH = Enable in a7cn43ww without this downgrade is not possible.
My System SpecsSystem Spec

 Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!

Thread Tools

Similar help and support threads
Thread Forum
Win7 PRO dual boot with Linux Mint on a new Lenovo E540
I have a new Lenovo E540 preloaded with OEM Win7 PRO 64 bit ... and no discs - (other than an upgrade to Win8.1 PRO ... no thanks) Q1: How do I make a recovery disc of the current Win7 PRO 64bit ? - I have never done it before .. a recovery virgin. So far ... when the Lenovo was started...
Installation & Setup
Bsod on startup, impossible to boot.
When I boot into windows 7 I see this: STOP:0x0000007b (0x80786b50,0xc0000034,0x00000000,0x00000000) and safe modes do not work. I do not have a disk drive but I do have f3 recovery (don't know if you need the disk of recovery) and I do have access to another pc. I can only go to startup repair...
BSOD Help and Support
windows 7 and linux fedora dual boot with dual drives
hello, i have some questions regarding dual booting windows 7 home premium x64 with linux fedora 14 on dual independantly dedicated drives. i am a college student with moderate computer (windows) knowledge but am doing software development and would like to play around with some linux for a class....
General Discussion
dual boot , reinstall the windows and lost dual boot
Hello Everyone , i was wondering if anyone could help me in this matter : i have windows7 and Redhat on my Laptop , i have removed and reinstalled the Windows7 last night and after that lost the Dual boot option , in fact the system is booting on windows7 and there is no option to chose...
Installation & Setup
Lenovo laptop dual boot problem
I am trying to install a windows 7 / XP dual boot on a Lenovo 550P I recently purchased. I have had no problems setting up a new partition and formatting it, but whenever I try and install XP on it, I get partway through the installation process and always get a blue screen of death. It tells me...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:04.
Twitter Facebook Google+