Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: A couple of issues - Windows Update / Repair install 'canceled' long

04 Dec 2014   #1

Windows 7 64 bit Professional SP1
A couple of issues - Windows Update / Repair install 'canceled' long


It all started pretty innocently. I first noticed a problem when the Windows update flag had a red marker on it. So I dug a little deeper to find out that Windows update was failing. It seems it could not do the check for updates any longer for some reason. This did happen suddenly and no recent changes were made to my system before this happened. I searched this forum and googled until the cows came home and ended up trying a few solutions that seemed reasonable - Deleting the contents of Software distribution, running CHKDSK. Neither of these helped. I tried another suggestion - sfc /scannow which could not run so I tried running it from a command prompt boot up. That did not work either. So, I kept going with the suggestions I have seen. I did find one suggestion to download the latest Windows Update readiness thingy from Microsoft which made the red splat on the windows update flag go away but still could not run windows update. Always comes back with the same error 80070002.

My last resort before contacting the forum was to try a windows upgrade from the original DVD that I got when I bought the system about 2 yrs ago. Well this did not help either as it fails after going through a bunch of preliminaries and then states 'The upgrade was canceled' 'setup can't continue'. Not sure if that spelling error on the 'canceled' is a clue to something bad?

If anyone can help me sort out this fine mess, I will really appreciate it. Of note, everything else seems to be working normally on the system, which is the one on my profile - Win 7 Pro 64-bit SP1.


My System SpecsSystem Spec
04 Dec 2014   #2

7 x64 Ultimate

Have you read this thread?

troubleshooter error code 0x80070002
My System SpecsSystem Spec
04 Dec 2014   #3

Windows 7 64 bit Professional SP1

Quote   Quote: Originally Posted by RogerR View Post
Have you read this thread?

troubleshooter error code 0x80070002

Thanks RogerR. I'll look through and try out some of those tomorrow.

My System SpecsSystem Spec

05 Dec 2014   #4

Windows 7 64 bit Professional SP1

Tried all the suggestions in that link, RogerR. Reinstalled .NET even though I already had the latest one. Rebooted after that and the powrshell commands also. Tried running Windows update and still getting the same 80070002 error. Running sfc /scannow from elevated prompt still giving me the same error:

Windows Resource Protection could not perform the requested operation.

My System SpecsSystem Spec
05 Dec 2014   #5

Windows 7 64 bit Professional SP1
- tried to fix registry entry but no luck with psexec, any tricks?

I found some seemingly sound advice about how to fix part of my problems which is that sfc won't run which may also be directly related to why windows update also fails. I found that in this thread:
Windows 7 update error 80070002 - the story of a fix.

After reading that thread, I tried running sfc /scannow and located the source of my 80070002 error. In the CBS.log, it shows that it can not find the value of this registry key:

HKEY_LOCAL_MACHINE\COMPONENTS\DerivedData\VersionedIndex\6.1.7601.17592 (win7sp1_gdr.110408-1631)\ComponentFamilies\amd64_microsoFt-windows-p..-localspl-licensing_31bf386ad364e5_none_05bb766c7c3a33fa\v!6.17600.1685

Sure, enough when I try to view the key or delete it or anything else to it, it gives this error:
Error Opening Key.

I have tried to edit the registry by running PSTools from an elevated prompt but it gets the same errors. Something very odd about that whole branch:
HKEY_LOCAL_MACHINE\COMPONENTS\DerivedData\VersionedIndex\6.1.7601.17592 (win7sp1_gdr.110408-1631)\ComponentFamilies

There are literally thousands, if not tens of thousands of similar named keys and they all get the same error when trying to expand them.

Any thoughts or helpful ideas are needed. I am hoping I can find a way to kill these bad reg entries so that I don't need to rebuild this system yet.


p.s. if there is a better forum topic that deals with bad registry stuff, let me know.
My System SpecsSystem Spec
05 Dec 2014   #6

Windows 7 64 bit Professional SP1

additional notes

I have tried renaming, deleting the registry keys with numerous tools, such as psexec, registrar registry manager, runassystem and no joy. All get errors trying to rename or delete these keys. I am about to throw this box somewhere soon. Also tried PC Hunter.

My System SpecsSystem Spec
05 Dec 2014   #7
Layback Bear

Windows 7 Pro. 64/SP-1

Irw I would suggest completing this tutorial by Brink.
Their is a good chance it will shine some light on your problem.

Windows Genuine and Activation Issue Posting Instructions
My System SpecsSystem Spec
05 Dec 2014   #8

Windows 7 64 bit Professional SP1

Quote   Quote: Originally Posted by Layback Bear View Post
Irw I would suggest completing this tutorial by Brink.
Their is a good chance it will shine some light on your problem.

Windows Genuine and Activation Issue Posting Instructions

OK, I think you meant for me to post this? If not, I may need a further nudge:
Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-JJQ72-Q8RGQ-XKV8Y
Windows Product Key Hash: pwdZxCW8yZfiH+hjyg3/ortIi60=
Windows Product ID: 00371-OEM-9044803-84585
Windows Product ID Type: 3
Windows License Type: OEM System Builder
Windows OS version: 6.1.7601.2.00010100.1.0.048
ID: {1DB9519E-97A5-41CA-B2FD-FA330BA361CF}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Professional
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.140303-2144
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{1DB9519E-97A5-41CA-B2FD-FA330BA361CF}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-XKV8Y</PKey><PID>00371-OEM-9044803-84585</PID><PIDType>3</PIDType><SID>S-1-5-21-1780786339-1757879575-927286815</SID><SYSTEM><Manufacturer>System manufacturer</Manufacturer><Model>System Product Name</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>0602</Version><SMBIOSVersion major="2" minor="6"/><Date>20110913000000.000000+000</Date></BIOS><HWID>06793307018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>  

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Professional edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_NSLP channel
Activation ID: e120e868-3df2-464a-95a0-b52fa5ada4bf
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00371-00180-448-084585-02-1033-7601.0000-0122012
Installation ID: 014262808046009896425984695264204006244022618670260172
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: XKV8Y
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 12/5/2014 4:42:47 PM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information: 
  ACPI Table Name    OEMID Value    OEMTableID Value
  APIC            ALASKA        A M I
  FACP            ALASKA        A M I
  HPET            ALASKA        A M I
  MCFG            ALASKA        A M I
  SSDT            AMICPU        PROC
Same details of problem - currently can run windows update or sfc /scannow. Both show errors in CBS.log which point to a very bizarre issue with my registry l- missing file, which I can see but it won't let me rename/delete it no matter which super tools I have tried.

My System SpecsSystem Spec
05 Dec 2014   #9
Layback Bear

Windows 7 Pro. 64/SP-1

I have went back to the ranch and requested for more help analyzing your log.
Sometimes it takes a little time so just hang in there.
My System SpecsSystem Spec
07 Dec 2014   #10

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

There's no problem in the MGADiag report.

I need to have a look at your COMPONENTS registry hive

Please copy the C:\Windows\System32\config\COMPONENTS file (no extension) to your desktop and then compress it - upload the compressed file to your favoured fileshare site (preferably Dropbox or OneDrive) and post a link.
My System SpecsSystem Spec

 A couple of issues - Windows Update / Repair install 'canceled' long

Thread Tools

Similar help and support threads
Thread Forum
Stuck in startup repair. How long is too long?
Hello, Windows explorer was not responding yesterday so I had no choice but to hard reboot. Since then life has ceased to exist as i knew it. I cannot get into safe mode. Pretty much I can't do anything but linger here in startup repair land. Going on 11 hours now. blue screen for about 4-5 hours...
BSOD Help and Support
Windows Update Install Issues - error 0x80070057
I have been having issues getting all Windows Updates to install and I've tried a number of things to correct. Nothing seems to solve the problem. I ran the Update Readiness Tool with no problems. I am now trying to do a manual install of SP 1 - KB947821 and it's failing too with error...
Windows Updates & Activation
Windows 7 - Genuine Issues Leading to Unable to Update/Install Windows
Hi, I am a tech idiot and I need help. I appreciate anything anyone can do. For several months I have been getting messages that our windows may not be genuine. It came installed on our Dell and we bought directly from Dell so I basically ignored it. Recently we got a message that it is not...
Windows Updates & Activation
Windows update fails to install IE10 after repair install
I did a repair install of W7 Ult. x64 SP1. Applied all updates, but if fails to install IE10 update : (as you see it is a dutch version). If have run sure & sfc /scannow. Both report no problems. CBS files are attached. Please help ?
Windows Updates & Activation
Windows 7 repair install failed; error when trying to run Update
Hello, I've been have several issues with my laptop ever since I swapped over my faulty C drive by Ghosting it onto another HDD. My troubleshooters all fail to run when I try to start them and Windows Update will not work despite the fact that I've checked and re-checked that the service is...
Installation & Setup
Remove canceled update from review your update history list.
...Yes I knew that is what someone would reply, however the question is not 'Why?' but rather 'How?' Just a method to clear out the failed or unsucceeded updates, and have a clean only successfully installed updates log...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App