Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Acer Aspire XC-603 Boot problems

08 Feb 2015   #1

Windows 7 Ultimate x64
Acer Aspire XC-603 Boot problems

Well I've got this problem and couldn't find any solution in here that helped me.

I've formatted the C disk where windows 8 was on and then tried to install windows 7 from with a boot USB.
Did didn't work. I've tried literally everything.

1. I've the right boot order.
2. I've turned of secure boot.
3. I've tried it with a DVD.
4. The USB and DVD boot both work on my laptop.

It looks like whatever I do I always get this text in my screen:

"Reboot and Select proper Boot Device or Insert Boot Media in selected device and press a key"

Has anyone any idea what this can be? It gets really frustrating that this PC is unresponsive to any change and will not boot anything. Much thanks for the help in advance.

My System SpecsSystem Spec
08 Feb 2015   #2


Work through these steps to Troubleshoot Windows 7 Installation Failures - Windows 7 Help Forums

It sounds like your boot media is not formatted correctly. If you have UEFI BIOS then flash stick must be formatted using only Option 1 of UEFI Bootable USB Flash Drive - Create in Windows
and must then be booted only as a UEFI device. Delete all partitions to clear formatting and install.

If problems persist report back any BIOS settings related to UEFI, CSM, Legacy BIOS, Secure Boot, and BIOS Boot Priority order. Pictures will help. Screenshots and Files - Upload and Post in Seven Forums - Windows 7 Forums
My System SpecsSystem Spec
10 Feb 2015   #3

Windows 7 Ultimate x64

First of all I want to thank you for your input this helped a lot.
The PC now boots from the USB. Only now the installation fails when it is trying to start up.
It keep hanging on: "Starting Windows". What can this be? A corrupt hard-drive or something?
Much thanks.
My System SpecsSystem Spec

10 Feb 2015   #4


I gave you very specific steps to follow above if the installation failed. That you asked back for more help while completely ignoring them makes me wonder what else you're skipping? This work requires absolute attention to detail and skipping no steps.

Where did you get the ISO from? Did it download completely, how is it written to stick?
My System SpecsSystem Spec
10 Feb 2015   #5

Windows 7 Ultimate x64

The installation ISO is a Windows 7 64Bit version an has bin used for other computers and laptops so the ISO is good.
I've written it to the stick with GPT partition with a FAT32 filesystem.
The PC starts the boot from the USB stick but doesn't go further than "Starting Windows".
If I go to the BIOS Screen it recognizes the USB as a UEFI Boot device.

I've also tried MBR Parition for UEFI Computers but the same happens.
I think I tried every different option with RUFUS but the same keeps happening.

I can't take a screenshot right now.
But the boot order is:
- UEFI drive.
- LAN.

Safety boot is off.
My System SpecsSystem Spec
10 Feb 2015   #6


Did you follow exactly Option One of UEFI Bootable USB Flash Drive - Create in Windows?

There are pictures there showing exactly how each setting must be set to write the stick to UEFI with GPT. These settings can sometimes change when you adjust them if you don't double-check before formatting the stick that they stayed the same. This happened to me just yesterday.

Then boot the stick by rebooting the PC and tapping the Acer F12 one-time BIOS Boot menu key at boot until you get a Boot menu. Choose UEFI flash stick to boot. What happens?

If UEFI Flash stick doesn't show up to boot then it isn't written correctly, or the BIOS settings are not correct. This is why I asked you boot into BIOS setup to report back the settings choices for UEFI, CSM, Legacy BIOS, and BIOS Boot Priority order. These may be on the Advanced, Boot or another tab in BIOS setup. If you can snap pictures with your phone it will help. Attach the files in reply box using paper clip icon.

I will be online from 1100 hours til midnight PST tomorrow.
My System SpecsSystem Spec
10 Feb 2015   #7

Windows 7 Ultimate x64

Ok I'll try this again to the letter and if it doesn't work I'll put some foto's online. Thanks for the help.
My System SpecsSystem Spec
10 Feb 2015   #8

Windows 7 Ultimate x64

I've put a rar file with all the settings from the bootscreen in a attachment.
It still doesn't work. Is't possible that a formatted the Hard drive wrong and now the system doesn't recognize it anymore? I formatted it to NTFS but didn't set it as a GPT partition.


Attached Files
File Type: rar Windows7Boot.rar (2.84 MB, 45 views)
My System SpecsSystem Spec
10 Feb 2015   #9


I could not have been more specific about how to attach the pictures.
My System SpecsSystem Spec
11 Feb 2015   #10

Windows 7 Ultimate x64

Acer Aspire XC-603 Boot problems-rufus.png
By the way, NTFS is FAT32.
Acer Aspire XC-603 Boot problems-20150210_110401.jpg
Acer Aspire XC-603 Boot problems-20150210_110441.jpg
Acer Aspire XC-603 Boot problems-20150210_110350.jpg
Acer Aspire XC-603 Boot problems-20150210_110829.jpg
Acer Aspire XC-603 Boot problems-20150210_110012.jpg
Acer Aspire XC-603 Boot problems-20150210_104952.jpg

My System SpecsSystem Spec

 Acer Aspire XC-603 Boot problems

Thread Tools

Similar help and support threads
Thread Forum
Bios Update Acer Aspire Help Problems
Sorry guys i need help i wanted to update the Bios of my Acer Aspire 5745G becouse of some problems.. i downloaded the last version 1.19 on the Acer website i installed it. It was easy to install it had an exe file for installing. After the reboot i got the problems, my Nvidia doesn't work (it...
Lag/Boot Problems on my Acer Aspire Machine
Basically my Desktop used to BSOD a fair amount about 2 months ago and for some reason it stopped after i applied new thermal paste and hoovered the insides of the case Anyhow - as of late , my pc has started having "random lag" what i mean by that is that my computer will be running fine at...
General Discussion
Acer Aspire M3970 LAN and Wireless Problems
Hey Guys, Had my desktop PC (Acer Aspire M3970) for about 11 months now, 2 days ago the LAN and wireless network adapters have stopped working. When i troubleshoot the problem it says the network adapters are having problems with their drivers, so I updated them from the Acer website. Still they...
Network & Sharing
Problems recover or installing Win 7 on Acer Aspire
Hi everyone I got a new Acer Aspire 5820TG with 4GB RAM with preinstalled Win 7 Home Premium yesterday. It worked fine for about 1 hour. I installed Google Chrome and Windows Live Messenger. I Burned 3 DVD's (Acer Factory Default Recovery), and thought I was safe. After a while the screen turned...
Installation & Setup
Acer Aspire 6935G Problems
Hi, just recently installed windows 7, love it by the way, but i didnt think about the drivers. Basically i have bio-protections fingerprint software on my computer. However i cannot find the drivers. I have downloaded the software as i have found that however when i go to scan my fingers it cannot...
General Discussion
Acer Aspire 6290 Audio Problems
It seems as though the sound on my Acer Aspire 6290 is not working. I've been encountering the same problem in ubuntu 9.04. Windows 7 registers an unknown device. Unfortunately, I don't remember the specifications on the sound card, but here's what windows says about the unkown device: ...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App