Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HDD not detected during re-install, but operates fine on boot

16 Feb 2015   #1

Windows 7 Professional 64bit
HDD not detected during re-install, but operates fine on boot


During Windows 7 re-install the installation process does not detect the new, larger hard drive and claims I should "load drivers" in order to find it. The hard drive manufacturer and PC manufacturer don't appear to offer HDD drivers (or SATA controller drivers) that I have been able to find so far.


Long Version:

I had to locate a valid windows iso file since one was not provided with my refurbished OEM machine. After locating one, based on the advice of this thread, I checked SHA1 hash from the image and compared it against the hash values on this site to make sure my iso was valid (I actually found and discarded 2 other images that had been modified before finding one that matched).

After finding a valid iso, I started up the install and ran into the new-hdd-not-found problem. The existing smaller hard drive that has my current install of windows on it is detected. The new hdd is also showing up fine in the BIOS, and if I allow the current Windows install to boot up the drive shows up and I can use it normally (move files to/from it, reformat, etc).

According to this page from the HDD manufacturer, I actually need SATA controller drivers instead of hdd drivers for this step. I know that's a Seagate page. Apparently these Samsung drives are manufactured by Seagate? The closest I've come to finding SATA drivers is from this page although it seems as though its for a completely different machine, but I was going to try the drivers out anyway since I'm so tired of working on this problem. But for some reason they made it mandatory to copy the files directly to a FLOPPY disk. I wasn't able to pry the files out, so I scrapped the idea.


I hadn't identified the exact model motherboard I have yet. The computer is a small form-factor case and I'm not excited about pulling the whole thing apart to find out. Am I able to see the motherboard model from device manager instead? I didn't see it there but maybe I'm looking at the wrong spot.

I don't know if I mentioned this already, but the install process DOES recognize the existing smaller hdd... but not the newer one.

I'm starting the install from a bootable iso image on USB.

The product page for my PC is here but there don't seem to be any SATA drivers or firmware updates that I can find. The hdd drivers here are for the existing drive, and not the new one I've installed.



I just need the windows install to recognize the larger drive so I can reinstall Windows onto that disk. Either manufacture drivers or generic drivers are fine... I don't care... for whichever will allow the install to see the disk which I am fairly sure will probably be the SATA drivers (although the fact the install process sees one drive but not the other is a little confusing).

Ok, hopefully that was enough information. I'll try and clarify any points if something was unclear. Thanks all.

My System SpecsSystem Spec
16 Feb 2015   #2
Microsoft MVP


Unplug the other hard drive, boot the installer to see if the HD is seen now. Confirm it still remains seen in BIOS setup.

How was the confirmed ISO burned to disk or stick? Try a new disk using Windows 7 USB-DVD Download Tool

Win7 has the SATA drivers in the disk so the prompt for them is almost always due to a bad installer. If you are trying a DVD install, try instead a flash stick using tool above. If you have a UEFI BIOS use Option One of UEFI Bootable USB Flash Drive - Create in Windows
My System SpecsSystem Spec
18 Feb 2015   #3

Windows 7 Professional 64bit

@gregrocker - Thanks for the response. I haven't much time to spend working on that machine this week (work has been SUPER crazy) but I was finally able to try your suggestions out. I removed the existing windows hdd and left only the new hdd (and cdrom) drives plugged in (actually moved them to 1st and 2nd ports). BIOS updated and reflected the new drive order correctly and removed the drive no longer attached, but the installation still did not see anything.

I'm booting/installing from a usb bootable image that was created using UltraISO (I referenced this page here). Also, I don't have a UEFI BIOS on the machine, just a standard BIOS so I didn't create a new bootable USB using the tools you linked, but maybe I should still try and create a new one? This article recommended using Rufus instead.

I also did end up stumbling accross this page but I'm just not sure what manufacturer (maybe none of these) is right for my SATA controller.
My System SpecsSystem Spec

18 Feb 2015   #4

Microsoft Windows 10 Home Build 15036

In the meantime, to ID the motherboard, as well as the HDD and other hardware, download and run Speccy . Post the info. Thanx
My System SpecsSystem Spec
18 Feb 2015   #5
Microsoft MVP


Can you use DVD? ImgBurn at 4x speed.

Try Windows Download tool (can be fussy which ISO it uses) or Rufus from here to create USB Windows 7 Installation Key Drive - Create - Windows 7 Help Forums.

If these fail test the HD with Seagate Seatools.

I cannot remember a SATA driver not being present in Win7 installer.
My System SpecsSystem Spec
23 Feb 2015   #6

Windows 7 Professional 64bit

I appreciate the replies guys, and am SUPER sorry about taking so long in working on this machine and responding back.

I ran speccy and it returned the model of the motherboard as Hewlett-Packard 3047h (XU1 PROCESSOR). I've attached the full output as a txt doc to this post. I haven't tried any searches for SATA drivers yet, but am going to do that next.

I downloaded the Seagate Seatools and the drive successfully passed all of the basic tests. I did not run any of the advanced tests. The long generic actually hasn't finished yet, but it's been running for a while and no problems so far. Will confirm that it passed that test in my next update.

I am currently creating a new bootable usb drive using this thread that gregrocker provided. I will report my results hopefully in the next hour or two.

Attached Files
File Type: txt specs.txt (79.2 KB, 1 views)
My System SpecsSystem Spec
24 Feb 2015   #7

Windows 7 Professional 64bit

The long generic test passed fine.

I burned a bootdisk using imgBurn, rebooted and started the installation, same result.

Created a new bootable usb drive using Rufus, rebooted and started install, same result.

Booted again just to check in the BIOS and the drive still shows up correctly in there. I did not remove the existing windows HDD during either attempt, and the installation saw the existing drive and all the partitions on it (there are 3 partitions + 1 block of unallocated space... fyi) but just didn't see the Seagate drive.

Maybe I'll try and find a new ISO to try these steps with, although as I said in my initial post I did verify the SHA1 hash was a match so I'm a little skeptical about that as the problem... but I'll probably try it anyway. Also now that I have the make/model of the motherboard, I might spend some more time searching for SATA drivers again (will probably do that first, before spending the time to find another good ISO).

Any other suggestions (or anything I accidentally missed from above), I'm open to whatever you guys can come up with.
My System SpecsSystem Spec
24 Feb 2015   #8
Anshad Edavana

Windows 7 Ultimate x64

Hi relic180

The "Speccy" report you uploaded contains the product key of your OS. I would suggest editing the report to remove the key immediately.

The driver download page for HP Compaq 6005 Pro has a SATA controller driver - Drivers & Software - HP Support Center.

But the page specifically states that ;


This package only supports RAID mode.
Use native Microsoft Windows 7 support if running in AHCI mode.
Which clearly means there is no special SATA driver is required for your computer. As Greg already suggested, i would also recommend disconnecting the old HDD, connecting the new 1 TB HDD to the first SATA port and trying again.
My System SpecsSystem Spec
24 Feb 2015   #9

Windows 7 Professional 64bit

Wow, oops. Thank you for the heads up about the serial number Anshad. Removed that.
My System SpecsSystem Spec
26 Feb 2015   #10

Windows 7 Professional 64bit

Removed the old hardrive, moved the 1TB to first SATA port and tried again, both with the USB boot and DVD boot and same result except the drive selection window is empty.

I went into the BIOS and everything in there looks correct. It lists SATA0 as 1TB SAMSUNG HE103UJ in the device configuration screen.


The one thing that could possibly be interesting after reading Anshad's response, is that under storage options the SATA emulation is set to "legacy mode IDE" (I have no idea what that means) but among other options I can change that setting to be either RAID or AHCI (I assume that means it's set to neither of those when using the legacy IDE mode). Obviously I don't have a RAID but perhaps I should change that to use AHCI? I'm hesitant to try it out because I received a warning when changing the option that it could "damage a partition" (maybe it doesn't matter since I'll be reformatting anyway) and I don't actually know what the difference is between IDEmode and AHCI.

Outside of that possibility, I think my next step is to locate a new ISO and create a new bootable USB and/or DVD using that.

I was also thinking I would try setting my 1TB up as a bootable install partition, even though I won't be able to complete the installation if I did that but I'm curious to see if the install would at least identify the HDD if I did that.


Some additional info from my BIOS (while I was screwing around in there):

Device Configuration:
--Emulation Type:
----Hard Disk (selected)
--Translation Type:
----Automatic (selected)
----LBA Assisted
----User (manual)

Storage Options:
--eSATA Port:
----None (selected)
--SATA Emulation:
----Legacy Mode IDE (selected)
----Native Mode IDE
My System SpecsSystem Spec

 HDD not detected during re-install, but operates fine on boot

Thread Tools

Similar help and support threads
Thread Forum
No bootable device detected on first startup, second will be fine.
I have a problem with my pc setup. Mind you i tried everything i read on every forum available before posting this. My problem started when I was playing Skyrim on a CRT Monitor. Why? because our 32inch LED TV is now being used for watching so I am stuck with a 17inch CRT Monitor from my...
General Discussion
Video Card Help Not Being Detected Everything Else seems to work fine
Hey All, Just trying to see if anybody had any suggestions or advice, I'm trying to complete this build and the only thing not working is the Graphics card. Specs Below: i5-2500k Biostar H61 Motherboard Kingston 8GB Ram Kingston 2x64GB SSD (128GB Total) Galaxy GTX 460 GC 768mb Antec...
Graphic Cards
very slow boot but running fine, new install
Hi, I am running a P5N-D motherboard ( bios 1401) with an intel core 2 quad Q9300, Rad HD3800 series and I have some problems since last week. It started with an error 0cx00000e9 someting About USB being disconnected. Since I couldn't figure out the problem I reinstalled windows 7 64bit. The...
Performance & Maintenance
Window 7 operates fine...lost all data....can you help?
A day or two ago, upon startup, what appeared to be Windows 7 recovery window popped up and wouldn't let me close out of it. It kept saying hard drive sectors failed and it needed to do a scan and fix problems. Even after I let it scan, I still couldn't close this window nor use any other...
BSOD Help and Support
My LAN card in XP(fine), but win7(Not Detected)
my lan card is Realtek RT8029AS i have Win XP and Win 7 in my PC in xp, the driver detected automatically without install any driver, and works fine but when in Win 7, the driver is not detected and in "Device Manager" found Unknown device for Ethernet controller i can't find correct driver...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:52.
Twitter Facebook Google+