Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 auto logoff and shutdown after completed clean install

16 Mar 2015   #1

Windows 7 64-bit
Win7 auto logoff and shutdown after completed clean install

Not saying I am a Pro, but I've built many custom PCs over the years, more than a couple dozen for myself, my wife, and other family members. But this is one of the weirdest problem I've ever come across: after doing a "fresh install" of Windows 7 64-bit, everything goes fine. For those familiar with the install, the final steps of setup are to ask for a login name and machine name. I enter that information, then specify passwords on the next part of the setup, then lastly the timezone selection. Then Windows prepares the desktop, and the install looks complete.

THEN, within 30 seconds, Windows automatically logs out and shuts down (i.e. clears the desktop and shows "Windows is shutting down" {or similar} message). It's sort of like when pressing the power button on some setups (for like 1 second, not the 5 seconds hard shutdown), which induces the shutdown procedure for Windows (depending on the setup, bios settings, etc). I believe there are some other conditions which might cause Windows to auto-shutdown, perhaps like overheat detection? Or perhaps over-the-network shutdowns, except I've intentionally not plugged in the Ethernet during the installation.

Just installing Windows alone is fairly hardware intensive, how can it make it all the way thru the entire installation, then only stay afloat for 30 seconds after the first login? This problem is so consistent. I've re-installed more times then I can remember now (with a few variations, which I'll explain shortly), same result every time. My first thought was there was something funny with the motherboard. So I returned the ASUS H97I PLUS board the next day, and exchanged it for a Gigabyte GA-Z97X-UD3H (wanted more SATA ports anyway). And to my amazement, the exact same problem with this 2nd quite different motherboard.

So, memory? The memory I went with for this new build is Corsair Vengeance DDR3 2x8GB (CMZ16GX3M2A1600C10). But then I borrowed a 8GB Patriot DDR3 from my file server which has been running for over a year. Same result. I put the Corsair Vengeance DDR3 RAM into the file server just mentioned; works fine. Don't think RAM is a problem here (and the exact same incompatibility with both an Asus and Gigabyte seems unlikely).

Hard drive? I've tried a 120GB Corsair SSD, an old 400GB Samsung drive, and a new 4TB HGST drive. All native SATA. All same results.

Install media? I have my own OEM retail Win7 Pro, and my friend also has MSDN. We've tried both my DVD media and his ISO put on a USB drive (obviously not at the same time). Same result either way. And just to verify, we used both media to setup a Windows 64-bit installation in a VM under VMware. Both work fine there. Don't think media is a problem here (but I have had install media go bad after years of many installs, so I know it can happen). The DVD drive is a LG SATA basic drive, nothing out of the ordinary (but it's not new either). When doing the install via USB ISO, we unplug the DVD drive just to have it out of the way, and use a USB 2.0 port on the back of the motherboard.

Video card? I didn't intend to put any exotic video cards in this system. So, I'm just using the onboard video. I have assumed on these modern LGA 1150 boards, the motherboard external video connectors are driven directly by the integrated video card of the CPU? This is what the motherboard manual implies also (Onboard Graphics, Integrated Graphics Processor). But before I talk about the processor: I've tried both the onboard and PCIe video card. The only spare PCIe video card I have anymore is an old GALAXY nVidia GeForce 7200GS 256MB DDR2 (old school, but fanless!). I suspect it's not even as good as the integrated GPU. I've tried both the DVI and VGA video connectors (of both the motherboard with the PCIe not installed, and on the PCIe while it was installed). And that was the only suggestion I came across when trying to search for this problem: to try a VGA cable, since sometimes during install some systems freak out about going into "HD" video modes and the VGA cable might prevent that. At least I tried it; but it was all the same result.

So finally, the CPU: to keep power consumption down, I went with a Pentium G3440 3.3Ghz, 3MB cache. This is the first time I've tried one of these G-series, having gone with i7's for awhile. And this is where I have a confession: when I first put the system together, when I did my first Power-On, I was amazed at how quiet the system was. First things first, I went into the BIOS to gloss over available settings. Poking around, it came to my attention that the CPU fan speed said "0 rpm". Then I indeed noticed the stock-Intel fan power cable had got wrapped up with the fan. So it had the heatsink, but the fan was not spinning. I figured with POST and inspecting the BIOS, it maybe went about as long as 90 seconds at most (probably less, but it certainly wasn't left like that for minutes). First time I've had that problem. I shut the power supply power off immediately, unplugged it, wait 30 seconds or so. Then adjusted the CPU fan cables accordingly, it hasn't repeated the problem since. And since then, I've monitored the BIOS reported CPU temp holding at 39degC with the ran around 1500rpm. Again, this was on a brand new CPU, initial power on. All the install attempts mentioned above were after this.

If the CPU is healthy enough to install Windows completely, clear up to the initial "Preparing your desktop" and logging in, without blue screening or any other ill effect, it would seem to me the CPU is fine (since it at least had the heatsink and wasn't on long enough to actually do anything stressful other than run the BIOS). But still, something is triggering the auto-logoff and shutdown (Windows says both within 30 seconds after finishing the install: "Logging off" followed by "Shutting down"). And after the shutdown, it restarts and doesn't boot anymore. Note, I've also disabled any temp warnings and such, as far as I can tell, in the BIOS.

So to summarize:

- Intel G3440 3.3Ghz CPU in a Gigabyte GA-Z97X-UD3H LGA1150 board, 8GB Corsair DDR3 (have 16GB, but used one stick to minimize hardware involved; have swapped sticks and tried different slots). Antec 550W power supply. New (<5 days) components.

- Two different Win7 Pro 64-bit media (my original OEM DVD and a MSDN ISO). With OEM DVD install, I have a SATA DVD drive attached. With USB ISO, I remove/detach the DVD drive (just because; minimize necessary H/W) and use a USB2.0 port on the back of the motherboard itself.

- Windows 7 installs completely (via USB ISO or DVD media), get to final step of entering time zone and preparing desktop. If I am quick, I can Win-R, do CMD.exe and do "dir" (so the install IS working). But each time, within 30 seconds after the install, windows logs off and shutdown the PC.

- The PC doesn't actually shutdown, but instead restarts. It then gets in an infinite loop of restarting even before POST messages appear (but yet if I hold DEL, eventually I can get back into the BIOS; so not the entire POST is aborted).

- Tried with onboard video only, tried with basic 7200GS nvidia PCIe 256MB DDR2 video card.

- Tried DVI (normally white) video connection and VGA (normally blue) video connection (same monitor).

- Tried other RAM from a working system. Verified the RAM that I want to use works fine in the other working system.

- Tried 3 different hard drives (did a Corsair low level format on the SSD using their tools, not sure if the 400GB hard drive ever had an OS on it {but I always at least erase all the partitions during the install}, and the 4TB never had anything installed on it before for sure). Same result on all of them.

- No ethernet connected during install or at any time. No USB devices, except when doing the install by USB ISO.

- Tried two different motherboards (described above). BIOS updated the Asus, same result. The Gigabyte is already at BIOS ver F7 (there is a newer F8e, but it says Beta BIOS so I'll avoid that for now). Neither motherboard has BT or Wifi capability, so no updates sneaking in that way.

So, what am I missing here? Never had a problem with a Win7 install. Or at least, not with a completely stock system (i.e. no clock adjustments). And I've never had a bad Intel chip (nor have I had owned one long enough for it to go bad). I haven't tried replacing the PSU. But as mentioned, I make it through the entire fresh install on a blank drive, clear past login and initial desktop setup. It's golden for 30 seconds, then shuts down, reboots itself, and power cycles indefinately thereafter (or some kind of reboot).

Can some win7 media have some kind of self-destruct in them, to not work after a certain year? I suppose I could try Win8. I'll add that I did try my old dusty Vista 64-bit Ultimate, and it doesn't work either. I do the install, do SP1 and SP2, then do the auto-updates -- then something goes bad with the auto-update and it gets stuck in some cycle of installing updates and reverting failed updates (left it going all night). Gave up on Vista after two nights. The motherboard doesn't technically support Vista, but I found suitable Intel ethernet drivers. Still, as the vendor doesn't support Vista, I gave up on that route. I could go FreeNAS, but I'm really baffled about this Win7 issue.

Suggestions welcomed, but I suspect next thing I'm going to try is replacing the CPU. Is there something particular about newer 2015 boards, trying to make Win7 obsolete? I could try a Win8 install I suppose; not opposed to it (use it on my laptop), but just Win7 has always been so reliable for me...


My System SpecsSystem Spec
16 Mar 2015   #2
Microsoft MVP


It would not be in the media at all if it's post-install, so let's look at hardware and specifically the BIOS settings first. As it's a new mobo you'll have EFI firmware. What are the exact settings offered and set now for CSM, Legacy BIOS, UEFI, EFI, Secure Boot and BIOS Boot Priority order? Pictures will help: Screenshots and Files - Upload and Post in Seven Forums - Windows 7 Forums

In addition study all of the BIOS settings by reading the help caption for each on the right as you highlight each. Refer to the Manual on the mobo's Support Downloads webpage as well.

Is only one HD plugged in and has it been wiped first of all code? If not work through the steps to Troubleshoot Windows 7 Installation Failures - Windows 7 Help Forums.

After install, unplug the flash stick and DVD drive to eliminate it as suspect.

Try install with only one RAM stick, the if problem persists power down to swap RAM sticks to the other. Reconfirm these RAM sticks are spec'd precisely via the mobo Manual.

Since you already ruled out the mobo most likely, withdraw each other piece of hardware to test without it.

I don't think you can ignore having a CPU which ran for any time without its fan and then finding the fan cable entwined in its blades. This should be swapped out to test it if nothing else helps.
My System SpecsSystem Spec
17 Mar 2015   #3

Windows 7 64-bit

- Have only been attempting the install with one hard drive at a time.
(1) I first tried with the 120GB SSD (which has had a working Win7 on it before for a prior system), even updated its firmware; did use Corsair SSD Toolbox to perform the Secure Wipe on that ("zero-ize" the drive, I presume equivalent to a low level format?). Smart Status is all green. (2) the Samsung 400GB is just some old mechanical laying around, for when a flash drive just isn't large enough (large astrophotography image files); the Samsung specific SeaTools utilities locks up the (other) machine when scanning for ATA devices, so I've given up on that. (3) the 4TB HGST is brand new, which doesn't mean it is without any faults, but should mean it is quite cleared of any prior OS. I have two of these. On the one I attempted the win7 install on (just to try it), the windows installer offer it in two partitions (2TB and ~1.6TB), which I understand all that (i.e. it doesn't have the drivers available to access the full capacity in a single partition, and there is overhead in a drive where you never literally get the full capacity). What I didn't understand is I couldn't pick the 1.6TB partition and had to select the 2.0TB partition (basically seems the install was limited to the LSB of the drive, I guess -- which is maybe fair without specific drivers).

- I certainly understand about heat on these CPUs. I was once cruel to an AMD (a K6 I believe) and booted it without even a heatsink -- and it did fry fairly quickly (with a noticeable exterior burn mark on the bottom). The motherboard was still fine though.

- Poking around in Gigabyte BIOS again, I understand most BIOS show "CPU temp" and really mean the external temp sensor that is provided by the motherboard. I found in the Gigabyte BIOS a "M.I.T." section that shows more stats on the CPU invidividual cores. Those were indicating both 42-44degC, which seem reasonable to me (CPUs, in my experience, are fairly OK up to 55-60degC, after that then they start to get cranky).

- I haven't tried removing the USB after the install (but that did come to mind, since I think Win7 is kind of sensitive on boot drive letter assignments; and inverting those during an install could be confusing) -- at what point should I do that? After the "100%" on the "expanding windows files" near the beginning of the install? After the first reboot? Certainly by the time it starts asking for initial login name and machine name? I'm using a generic Memorex TRAVEL 8GB stick. I have others 4-64GB, but the Memorex seemed the most expendable as a booter.

- One other BIOS setting that did stand out was "Power Loading" which described inducing a low during low power consumption (and suggest changing to Enable if you notice any shutdowns). Perhaps by NOT having any crazy video cards in a motherboard that supports 3-way SLI, it thinks something is wrong? Also, this: The big Haswell PSU compatibility list - The Tech Report - Page 1

Will try again shortly...
My System SpecsSystem Spec

17 Mar 2015   #4
Microsoft MVP


You didn't answer most importantly about what your UEFI settings are. With that large of a hard drive, you'd want to install to UEFI with GPT formatting to use all the space and manage the drives better. This requires special formatting of the flash stick using only Option One of UEFI Bootable USB Flash Drive - Create in Windows then booting it as a EFI device. But the settings have to be precise.
My System SpecsSystem Spec
17 Mar 2015   #5

Windows 7 64-bit

I'm using Antec EDGE 550W. While it has a "Intel Haswell System Ready" logo on the box, it is not listed in the link in my previous post (which I see now is from mid-2013, so... need an update there). Great: e-mail Gigabyte to see if they have any known PSU compatibility issues with that model, and e-mail Antec to see if they have any known Gigabyte motherboard compatibility issues.... Would stink if this is a PSU issue, since it was actually some work to get that PSU to fit this case (and still fit the vibration noise dampening wrap).
My System SpecsSystem Spec
17 Mar 2015   #6

Windows 7 64-bit

Quote   Quote: Originally Posted by gregrocker View Post
You didn't answer most importantly about what your UEFI settings are. With that large of a hard drive, you'd want to install to UEFI with GPT formatting to use all the space and manage the drives better. This requires special formatting of the flash stick using only Option One of UEFI Bootable USB Flash Drive - Create in Windows then booting it as a EFI device. But the settings have to be precise.
Oops, I actually did write down notes on that, but forgot to type them.

I wouldn't want a 4TB boot drive, of course; even if it were partitioned down to 100-200GB and the remainder as another drive. I only tried the 4TB just to see if it worked at all (as far as getting the Win7 install to "keep").

I'll concentrate back on using the 120GB SSD, as I don't think the SSD itself is the cause of the problem.

And apologies for lack of screenshots, just late and tired and everyone is asleep. But notes are:
Win 8 Features: Other OS (BIOS notes imply this should be correct for anything other than Win8)
Boot Mode Selection (UEFI + Legacy)
other options: Legacy Only, UEFI Only
Storage Boot Option: (Legacy only)
other options: Disabled, UEFI Only, Legacy First, UEFI First

Other PCI Device Rom Priority: (UEFI OpROM) other option: Legacy OpROM

There is another setting that appears to specify how the USB is to be emulated (Auto, CD-ROM, FDD, or some other choices; I have that at Auto). In the boot selection, the USB Memorex is being listed twice (UEFI and non-UEFI entries).

All that aside, I get this same issue when installing from the actual DVD drive and OEM media. This particular machine was going to be a backup file server, and didn't need a DVD drive. We thought the USB install would go smoothly, and when it didn't, we borrowed a SATA DVD drive pulled from another machine -- which then we noticed we got the same "shutdown 30 seconds after finish installed and logged in for the first time" problem.
My System SpecsSystem Spec
17 Mar 2015   #7
Microsoft MVP


Please post back a screenshot of Disk Management - Post a Screen Capture Image so we can see if you have an EFI install since apparently you don't know.

I asked what the settings are for Secure Boot, which is normally on the Security tab.
My System SpecsSystem Spec
18 Mar 2015   #8

Windows 7 64-bit

Took me awhile to realize you meant screenshot it from another working machine, as the machine with the problem won't login and stay logged in long enough to complete the Disk Management screenshot.

But, I can say already it is not an EFI installer on the USB stick (Rufus indicates this already, as it won't let me pick "MBR partition scheme for UEFI computer" since when doing so it says "When using UEFI Target Type, only EFI bootable ISO images are supported."; Rufus also requires me to pick NTFS file system). When installing, the BIOS shows two entries for the USB, one prefixed with UEFI and another without (since it has Legacy and UEFI options enabled). I pick the Legacy entry (without the UEFI prefix).

I'll punt on the USB installer, since it was only borrowed to try to see if there was any problem with my own DVD install media. We don't think there is, so I'll stick with that. I wiped the 120GB SSD again, attached the SATA DVD drive, and re-installed again. I've also changed the Boot Mode Selection to Legacy only this time.

Secure Boot is disabled by "Win 8 Option" being set to "Other OS" (because the description of that BIOS setting explicitly says "Pick Windows 8 to enable features such as Secure Boot", this Gigabyte board doesn't have a separate Security tab {as you're right, many others typically do}; this board DOES have a line item option called "Security Setting", but it refers to having a password for bootup + BIOS or only one or the other).

I do still want to try another PSU (which is a stretch; I think the Load setting was referring to the PSU shutting itself down due to low usage), but I'm holding off on the temptation to tear apart a working PC to get a suitable one to try. The install is going now, but I have to take my daughter to class. Results pending :)
My System SpecsSystem Spec
18 Mar 2015   #9
Microsoft MVP


I recommend installing to UEFI to sample the BIOS improvements which come with it. Only when it won't install to UEFI - after confirming installation media (yes, DVD is best) and deleting all partitions during install, confirming the settings are correct - would I install to Legacy. This has not been necessary for a good long time here.
My System SpecsSystem Spec
19 Mar 2015   #10

Windows 7 64-bit

Same result, whether I set the BIOS to full Legacy only or UEFI only (installing from the OEM DVD). After the last attempt (with full UEFI selected), after the final "preparing desktop" and initial login, I was able to open cmd.exe and cd to the windows folder, "dir" a few subfolders... But ultimately, it was the same result: automatic "Logging out" and "shutting down" after about 30-40 seconds of being able to use Start menu and enjoy a brief tour with a console window.

But, another thought I just had: could it be the keyboard? Don't some of those have shutdown buttons? It's an old programmable keyboard. It's unlikely to be a cause, but it's an easy enough thing to try to swap out.

HOWEVER, I've booted up with FreeNAS and it's humming away just fine (removed the SSD and DVD, booting directly from a USB after installing this OS from another USB, re-attached the two 4TB drives and got a NAS going with a remote web interface in under 20minutes). But, Windows7 would still be preferred since it doesn't have to be a 100% dedicated file server.

Antec is asking about C4 states and whether the power light is blinking or not. I'll answer their questions and see if they offer any other suggestions regarding the Win7 install -- and may give the Win7 install a few more tries (just unplug the FreeNAS USB, swap the 2x4TB sata cables over to the SSD and DVD).

Thanks for the suggestions, UEFI is new territory for me.
My System SpecsSystem Spec

 Win7 auto logoff and shutdown after completed clean install

Thread Tools

Similar help and support threads
Thread Forum
win7 pro login screen auto shutdown after 55 second
super strange, this problem has come back... faced it about 1.5 years ago, and it fixed itself... just ran the latest set of windows updates (4 total i think)... and now my computer keeps rebooting at the login screen... after exactly 55 seconds after i see my login wallpaper. i have disabled auto...
BSOD Help and Support
Windows 7 : auto logoff permantly after login
My university has an application that students must run it to do test (midterm, final,...). It really annoy to all students. It will close all file it can close on computer. (system file too...). So, users must turn account control to default level so... this app cannot auto close it. I don't know...
General Discussion
Clean Install of Win7 - Wipe Hard Drive Clean
Hi Folks, I just did a clean install of Win7 and must have done something wrong. I found a file called Windows.old.:confused: I would like to wipe my hard drive completely clean and then install a fresh copy of Windows 7 Home Premium. How do I accomplish this task? It's a good time to...
Installation & Setup
auto shutdown when i try to install W7
I try to install W7 on acer aspire 5536 but when i get windows loading files or when i need to press any key to start up the windows install it just shutdown. Now it has vista installed. What could be the problem? On acer website it says that it's compatible with W7
General Discussion
Need help fixing auto logoff(virus?) or uninstalling Windows 7
Hi, Last night I downloaded a file which contained a virus(the source told me it was a false positive), that time it was all good. This morning I went on the computer and from multi boot I choose Windows 7(other was Vista) and when it prompted me to account screen I chose my account and logged in....
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:15.
Twitter Facebook