Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BIOS not ACPI compliant during installation, Windows 7, Asus X751MA

10 Sep 2015   #21

Windows 7 Home Premium 32 bits


Nope. The merchant didn't accept to refund me even after all my explanations and irritation. I'm still shocked by this. I didn't want to bother me with this situation, I've other things to do... So finally I found someone who was interested in this "Win 8 only" computer and the problem disappeared with the laptop.

The last BIOS update doesn't seem to solve the problem...

My System SpecsSystem Spec
10 Sep 2015   #22

Win 7 Ultimate 32 bit

Wow... sorry to know that didn't turn well. So I guess it's better for me to avoid that road completely. Actually I've already taken down the path of simulating the windows 7 look and feel by using a free software called Classic Shell, which does exactly that. I guess it would be the best thing to do.

Thank you for updating the thread so quickly.

Best regards!
My System SpecsSystem Spec
01 Jan 2016   #23

win7 64bit
asus x751ma

im buy this Notebook 1 month ago and have the same Problem have anybody solve this to intall win7?
i found this update in a russian Forum but i cant install the Flash Software i it Show me not asus compilant...??
sorry for ma bad english
nick - X751MAAS.404.rar
My System SpecsSystem Spec

01 Mar 2016   #24

Windows 7 Ultimate x64

Kind of the same issue OTTO is having.. My ASUS R515M is doing the same thing except I got to where it let me format the HARD DISK but will not let me install after formatting.

"Windows cannot be installed to DISK 0 Partition 2" Show details

"Windows cannot be installed to this disk. The computer hardware may not be supporting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS"

The problem is I have two primary partitions and it wont install on either one
Primary partition 1 contains 186.GB
Primary partition 2 contains 279.GB
Here is what I am trying..
Fast Boot CSM *DIS*
Launch CSM *DIS*
SATA Mode *AHCI Mode*
Secure Boot *DIS*
OS Selection *Windows 7* (interesting it gives this option if the BIOS is not compatible)

I changed it to run IDE and I got this
"Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information."

Any thoughts?
My System SpecsSystem Spec
05 Mar 2016   #25

Windows 8.1 x64
Same Problem !

I am waiting since 2014 for a bios update which is compatible with Windows 7. I don't think that Asus will release a bios Update
My System SpecsSystem Spec
01 Apr 2016   #26

Windows 7 64bit
A little difficulty...

Hello. I have an Asus K55n that's giving me some problems. After reading a few posts on this site, I think I have a much greater understanding of how to install Windows 7 on to this computer. Once I get home, I'll deploy this new knowledge.... My question right now is why I'm having to install Windows 7 AGAIN on this laptop and why I'm having such a hard time doing it. I did a clean install of Windows 7 Ultimate x64 about a month ago. It was tricky at first, but after reading about having to turn on CSM and and whatnot, I managed to get it installed from the laptop's DVD drive. Then a few days ago, the computer simply wouldn't boot anymore. When I turn it on, there is no Asus splash screen and it goes straight to the first page of the BIOS set-up screen. Eventually I noticed that I could not change the boot order. There wasn't even really a boot order listed at all. That's when I thought that the hard drive must have died. So I replaced the the drive, but I'm still getting the same problem: I can't create a boot order. The HDD is listed on the SATA page along with the optical drive, but when I go into the Create Boot Order section of the BIOS, I don't see much of anything that relates to ANY drive at all. Plus, it wants a path specified where I presume boot files can be found. This is highly unconventional not to mention frustrating. Installing Windows has always been a bitch, but not to this extent! I tried resetting the CMOS, but that didn't change anything. I'm really wondering why it was so easy installing the OS a month ago, compared to now. The boot order was there and I was able to switch it over to the optical drive and the installation went off without a hitch. And then, it all begs the overall question of why did the computer quit working to begin with? I'm wondering if maybe perhaps the BIOS got corrupted somehow, but I know that it's burned into a chip so it's not very likely.
Does anyone have any ideas on this?

My System SpecsSystem Spec
03 Apr 2016   #27

Windows 7 64-bit

Hey Guys,

I was having the same issue and was able to install windows 7 64bit on a ASUS X553M by doing the following.

I wanted to remove windows 8 and install windows 7 on the machine but after seeing this post i wasn't sure how it would go so i first shrunk the partition with the factory OS(win 8) so that I could have another partition that I could use to at least dual boot.

Anyways after shrinking the partition I made a flash drive of the windows 7 OS and restarted the machine.

After the restart i went into the BIOS and changed the following:

In Advance I changed the OS to windows 7, In Boot i made the flash drive the 1st boot device then instead of ACHI i changed it to IDE.

Saved and exited to restart the machine.

When it restarted it loaded from the flash drive and proceeded to do its thing. I got to the window to install the OS but i couldn't click on next.

I formated the partition and then clicked New. This gave me the "Windows cannot be installed to this disk the selected disk is of the gpt partition style" dialog box.

I did a Shift + F10 and ran diskpart and cleaned that disk.

Once out of diskpart i had one partition so i did a format again and waited to see if I saw the new button appear.

Clicked new and the Windows 7 OS began to install.
My System SpecsSystem Spec
21 Jul 2016   #28

Windows 7 Professional 32bit

Hey guys, I have the same problem this morning, and now i had fixed it

The problem is just in the BIOS, if your bios is updated to newest version, in advanced there must be OS Selection, then you should choose Windows 7. And your windows 7 will start normally.

Hopes this help ^^
My System SpecsSystem Spec

 BIOS not ACPI compliant during installation, Windows 7, Asus X751MA

Thread Tools

Similar help and support threads
Thread Forum
Win 8.1 to 7 downgrade bios not fully acpi compliant
I am trying to downgrade a dell inspiron 3531 from 8.1 to 7 by using a memory stick but when booting from from the usb stick it loads files and just comes up with bios not fully acpi compliant error. Have been told to install with a dvd but havn't tried this yet. Read a few threads about this error...
Hardware & Devices
I purchased a new ASUS laptop with Win8. I wanted to replace it with Win7. I wiped, formatted and partitioned the HD. I changed the BIOS so it boots from the DVD. I put my 7 disc in and started. A message says it is loading files. In a minute or so I get the Blue Death Screen with the...
Installation & Setup
bios not fully acpi compliant stop error
Before I get into the details of the issue I want to point out that this computer was running Windows 7 fine without any bsod or other errors for about 6 months. 6 months ago I performed a wipe/ restore of my system drive to clean out the crud that windows/programs build up over time. windows 7 had...
BSOD Help and Support
This bios is not Acpi compliant
For about 5 weeks my pc would not boot up properly and i eventually discovered that one of my ram chips was faulty so i replaced it and now works only upto 3 gig with windows 64 bit but when i install the 4th chip i get a Bsod with the message this bios is not Acpi compliant so i went to the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:09.
Twitter Facebook