Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New Custom Build -- "No drives were found"

26 Jul 2010   #21

Windows 7 Enterprise
Some details on how to install Windows 7 on an Acer Aspire (no drives)

Trying to install Windows 7 Enterprise x86 (official Eval) on a ACER Aspire T650 (Specifications:

As more people discovered, the setup will not find your sata drive(s) during setup. BIOS shows the drives without problems. Formatting / partitioning the disk does not work. I formatted the disk with VistaPE boot-dvd to be sure. Assigning a drive-letter does not work, still no drives found!

So you have to install the SATA driver. I used this extraced archive: To download, Google for M5287 (for other machines, try: M5288, and M5289, they are all aLi SATA sys drivers), put the extraced archive(s) on a USB stick, and load the driver during setup.

Currently, will give you the download for M5288. More details here: ULi SATA Controller (M5287) software download - Windows - VersionTracker .

General discussion that I used for this thread: Help me in installing windows7 !!! [Archive] - My Digital Life Forums .

Peace and enjoy : )


~~~ ~~~

Cuisvis hominis est errare, nullius nisi insipientis in errore persevare
All spelling mistakes are my own and may only be distributed under the GNU General Public License! - ( 95-1 by Coredump; 2-10 by DevNullius)

My System SpecsSystem Spec
26 Jul 2010   #22

Microsoft Community Contributor Award Recipient


How to load Sata Controller Drivers.
SATA Driver - Load in Windows 7 or Vista Setup

You can find Sata Controller Drivers here.
My System SpecsSystem Spec

 New Custom Build -- "No drives were found"

Thread Tools

Similar help and support threads
Thread Forum
"No drives were found." Win7 Installation - HELP
So i installed windows 8 on my HP DV6t-7000 and it regularly gave me BSOD until eventually it stopped booting all together. I have tried doing a fresh install of both win8 and win7 but both provide me with the error that "no drives were found. click load driver to provide a mass storage for...
Installation & Setup
Multiple drives cause "no active partition found" error
I have had my system up and running with Win7 for at least four or five months. I have four drives in an mATX case. Yesterday, while it was idle, I saw it flash a BSOD and then rebooted. when it restated it displayed the following Error: "No active partition found. Reboot your computer." Which...
Hardware & Devices
Error message "No drives found" on boot up after new build & install
Just completed my first build. I have two error messages during the boot sequence that I cannot resolve. The first screen shot during boot is the Asus logo. Next is a black screen that reads: "JMicron Technologies, PCI Express to SATA Host Controller ROM V1.07.23 Detecting drives; Done; No...
Installation & Setup
Win7 "No Drives found" SATA drive
I have a custom built HTPC with a Seagate SATA drive. Media Center halted, and Win7 would not reboot. When I attempt to reinstall Win7 it cannot find the drive (C) - "No drives were found. Click Load Driver to provide a mass storage driver for installation." My research tells me SATA drives...
Installation & Setup
Error Message "No Drives Were Found"!
Hey everybody :) A few days ago a friend of mine gave me a notebook, he had no use for anymore. It is a "Fujitsu Siemens AMILO Xi 2528" and he had Windows XP on it. So he gave it to me and I wanted to install Windows 7 on it. When I came to the part of the installation when the system asks to...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App