Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: win 7 install error while completing setup on my 840 pro SSD

21 Apr 2015   #1

Windows 7 Ultimate x64
win 7 install error while completing setup on my 840 pro SSD

Asrock ION 330HT 2 x 1gb ram 800mhz
Samsung 840 Pro
Bios v P1.10 --- Bios defaults set

Windows 7 x64 installation gets almost to the end then at some point after saying updating registry settings i get an error ''setup cannot configure windows to run on this computers hardware''. Restarting will kick up another error advising to restart setup.

I have been previously able to install xp and win7 32 to the 840pro in ide/auto mode as i was dual booting with win xp at that time. Now I get the above error when trying to install win7x64 in AHCI OR IDE mode. I have a new 60GB patriot blaze and I can install windows 7x64 on this drive no problem.
Seller says they tested the drive on a z87 mobo and installation completed ok. Not sure what to try now as it used to work.

I also have a second Asrock ion 330Ht and get similar error on that machine. It either gives the same error or freezes during installation and the pc has to be restarted then advises to restart setup.

Recently had a new zotac zbox IQ01 with 16gb ram and installed win7x64 and x32 on that pc but the pc had a fault and I got a refund in the end due to not great experience with seller. So now trying to install this SSD back into the same pc it was working in not 4 months earlier and I am unable to install windows. The drive was stored in a anti static HDD bag while not in use.

Any advice would be much appreciated - I have worked in a PC hardware support role previously for 3 years.

My System SpecsSystem Spec
21 Apr 2015   #2


Work through these steps to Troubleshoot Windows 7 Installation Failures - Windows 7 Help Forums.

Report back results as requested in tutorial.

In addition if it fails, report back any settings in BIOS setup for UEFI, EFI, CSM, Legacy BIOS, Secure Boot and BIOS Boot Priority listings.
My System SpecsSystem Spec

 win 7 install error while completing setup on my 840 pro SSD

Thread Tools

Similar help and support threads
Thread Forum
Can't install Battlefield 3, DirectX Setup error: An internal error oc
I am trying to install Battlefield 3 and I get a "DirectX Setup error: An internal error occurred." I tried using DirectX End-User Runtime Web Installer and I get a second error "An internal system error occurred. Please refer to DXError.log and DirecX.log in your Windows folder to determine...
setup error on windows install
There are no partitions and the space is all unallocated yet every time I try to get windows 7 to install I get" setup was unable to create a new system partition or locate an existing system partition. See the set up log files for more info. I tried to talk to dell and they won't help. And I...
Installation & Setup
Can't Install Win 7 - BSOD on Completing Installation
Having problems installing Win 7 on to my computer (Abit IP35-E mobo and on to a new 1TB HDD, which I partition to 50gig for the Windows drive). It can get as far as the completing installation part (which takes ages), and then it will quickly flash a blue screen for a second and then reboot with...
Installation & Setup
install hangs at completing installation
I attempted a windows 7 install on an x64 and x32 system several times with the same result. The Upgrade runs until the last stage and then hangs. I looked at the logs but didn't see any errors. All my systems are custom built using Vista ultimate OEM additions. I was successful installing the...
Installation & Setup
Win 7 stuck on completing install
Hey guys, since my school let us download any version of Win7 for free I thought I would try and install Win7 RC Ultimate (x64) onto my desktop. The problem is that when it goes to completing install it stops and wont progress. At first I thought it was just taking a long time but I let it run over...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App