Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Reinstallation causing No bootable device, Acer Laptop

18 Jun 2015   #1

windows 8
Reinstallation causing No bootable device, Acer Laptop

I have just reinstalled the OS on 2 of my computers but am having a very difficult time with my old acer laptop. I have already read many guides and spent many hours trying to resolve this. I really don't know much and should have taken some notes before but felt over confident. There doesn't seem to be many options in the BIOS.

Product Name: Aspire 5742Z
System BIOS Version: V1.07

I am booting from a USB flash drive I have tried many different variations to get it to show the installation but nothing. I can't figure out or understand what a UEFI but since I do not see any mode for CMS I assume it must be UEFI. I have made a bootable fat32 usb and followed directions from here but cannot fix the problem.

UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with

I'd also like to install windows 8.1 on the machine but am confused with how UEFI can only read fat32. fat32 only allows 4gb image size but my windows 8 image is larger. This is why I am trying windows 7,

All help be very appreciated!!

EDIT: I took the hdd out of my laptop and plugged it into my desktop. From there I was able to install windows 8.1 and boot from desktop. However upon plugging back into the laptop it gave the same problem. I am not sure what I did wrong but when I had began was able to get the bootable usb to start windows 8 installation on the laptop. But it was failing at about 33%. Now neither windows 7 or 8 will.

My System SpecsSystem Spec
18 Jun 2015   #2
Microsoft MVP


I see no evidence you have UEFI and if you did you would need to boot the stick as a UEFI device to install it.

So format the stick normally, Set hard drive as first to boot in BIOS set up, Then trigger the stick to boot using the one–time BIOS boot menu key.

Everything is here to get and keep a perfect Clean Reinstall - Factory OEM Windows 7. Step one shows you how to confirm your installation media and correctly format the stick.
My System SpecsSystem Spec
18 Jun 2015   #3

windows 8

I fixed my problem by formatting my USB drive back to NTFS. Not sure why couldn't get it earlier, Idk why I was trying fat32 I'm just illiterate but I was having trouble reading my USB which is how I got all thinking it was a UEFI system when I don't know anything.

Got the windows 8.1 installation screen up now, converting the hdd to mbr from gpt. Hope all goes well.

EDIT: So I began installation of Win 8.1 but gave me error 0x80070570 at around 33%, which I believe I was encountering this problem when I first started. I have follow the steps here
Windows 7 Installation Failure - Overcome

Now for some reason I am not able to get the win 8 installation screen error 0xc000000f. This is what led me on the track to believe it couldn't read the USB unless it was fat32. Will try reformat USB incase something went wrong during the failed installation. But idk why it was just showing windows 8.1 installation and now it's not. OK I GOT IT TO WIN 8 INSTAL SCREEN AFTER FORMATING USB AGAIN.

After trying again I got the error 0x80070570 at around 70% this time. The hdd and win 8.1 work fine on my desktop.

With a different copy of win 8.1 I got this error 0x8007025D.

I am not sure why my other 2 computers were able to install win 8.1 but I tried win 7 and it worked.

Got win 8.1 working with a different install.
My System SpecsSystem Spec

27 Jan 2017   #4

windows 10 X64

the best thing to do at this point is get a new windows install :sad:
My System SpecsSystem Spec

 Reinstallation causing No bootable device, Acer Laptop

Thread Tools

Similar help and support threads
Thread Forum
Samsung SSD causing Acer laptop to reboot at Splash Sceen
- Acer laptop had a mechanical HDD which was slowing down - purchased a SAMSUNG 850 evo HDD - upgraded windows 7 to Windows 10 on laptop - cloned from old disk to new SSD - rebooted and it boots great - stopped working about 2 days later and now keeps rebooting at Acer splash screen - put...
Installation & Setup
Acer Laptop, Error: "No Bootable Device" After installing OEM Win7
Hi, I was asked by someone to install Windows 7 on their Acer Aspire E1-570 running windows 8.1. I have since formatted the drive and installed Windows 7, but now I get an error stating the above, No Bootable Device, Hit Any Key. I think I'll need to reinstall whatever partitions etc. Acer...
Installation & Setup
Acer laptop, uefi, no bootable devices found
So, got a new laptop, and it started to rain in problems : 1) uefi - what kind of crap is this ?? it cannot detect anything - i have ssd, i have pluged bootable win7 installation usb flash, but it just gives "no bootable device found". Had to turn off uefi and enable legacy mode. Is uefi usable...
General Discussion
Hard Drive Disk is not detected in laptop - No bootable Device Found
Hi, My friend's laptop (Acer Aspire One 722 - Windows 7 x64) has been shut down after opening an email and Windows never started up again. When you attempt to start up the windows, it stays the black screen and says "No bootable Device Found"! 1- I inserted Windows Live Disk and loaded it...
Hardware & Devices
Compaq C700 laptop: No bootable device
I have a Compaq Presario C700 which is giving me the following error: No bootable device -- insert boot disk and press any key. I'm a technical user and have been able to fix just about anything, until now. I've done some research, and I've found that this Compaq C700 is a terrible computer...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:28.
Twitter Facebook Google+