Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installation hangs on black screen

10 Nov 2009   #1
cusimar9

Vista
 
 
Installation hangs on black screen

I thought I'd move with the times and picked up a copy of Windows 7 Ultimate. I had Vista installed before.

Booted from CD, delete/recreate partition and did a clean install.

The installer hangs on a black screen after the first reboot. Even left it overnight without progress. Forcing a reboot and going into Safe Mode the setup tries to continue, then comes up with a prompt saying 'Setup cannot run in Safe mode, rebooting your computer', whereupon it hangs again.

These are my specs:

1 x Seagate ST3500320AS 500GB Hard Drive SATA II 7200rpm *32MB Cache* -
1 x MSI P35 Neo2-FR iP35 Socket 775 8 channel audio ATX Motherboard
1 x Intel Pentium Dual Core E2160 Socket 775 (1.8GHz) 1MB L2 Cache OEM
4 x OCZ 1GB DDR2 800MHz/PC2-6400 Platinum XTC Memory Kit CL4 2.1V
1 x Sapphire HD 2400PRO 256MB DDR2 VGA DVI HDTV out PCI-E Graphics Card
1 x Sony AD-7200S 20X DVD±RW/DL/RAM Internal SATA Bare Black Drive - OEM
1 x LiteOn 20x DVD±RW Dual Layer & Ram SATA Black Bare Drive - OEM

My 500GB hard drive is split into 2 partitions, 100GB boot partition and the rest (350GB or so) as storage.

This is the sequence I tried:
1. Boot from CD, delete boot partition, new partition, clean install (HUNG)
2. Disconnect router, then as 1. (HANG)
3. Reset BIOS to factory defaults, then as 1. (HANG)
4. Disconnect external hard drive and printer, then as 1. (HANG)
5. Disabled on-board chips like sound, legacy USB etc, then as 1. (HANG)

I've tried booting to the CD and doing a 'repair windows' but that comes back without problems.

The only other thing I could think of is that the graphics card is incompatible... but I don't have onboard VGA and I don't have another card just lying around.

I've never had a problem doing a clean Windows install. I'm really disappointed they're making it so difficult. Does anyone have any suggestions? I might have to just go back to Vista...


My System SpecsSystem Spec
.
10 Nov 2009   #2
cusimar9

Vista
 
 

Actually I've just checked and it seems my graphics card is compatible so I'm out of ideas...
My System SpecsSystem Spec
10 Nov 2009   #3
Tews

64-bit Windows 8.1 Pro
 
 

Try removing one of your ram sticks and then install.. This is often the cause of system hangs during installation...
My System SpecsSystem Spec
.

10 Nov 2009   #4
cusimar9

Vista
 
 

Really? How come? I've got 4 x 1GB in at the moment, do you suggest I go to 2GB?

Sounds crazy to me. Should I try and install the x64 version? I've been trying the x86 build up to now...
My System SpecsSystem Spec
10 Nov 2009   #5
Tews

64-bit Windows 8.1 Pro
 
 

Your specs show 2 x OCZ 2GB (2x1GB) DDR2 800MHz/PC2-6400 Platinum XTC Memory Kit CL4 2.1V... now you say that you haved 4 1gb sticks... remove all but one stick of ram and reinstall... also.. have you overclocked anything?? If so, return everything to default values before installing..
My System SpecsSystem Spec
10 Nov 2009   #6
cusimar9

Vista
 
 

Quote   Quote: Originally Posted by Tews View Post
Your specs show 2 x OCZ 2GB (2x1GB) DDR2 800MHz/PC2-6400 Platinum XTC Memory Kit CL4 2.1V... now you say that you haved 4 1gb sticks... remove all but one stick of ram and reinstall... also.. have you overclocked anything?? If so, return everything to default values before installing..
Sorry, I just copied that from an invoice, I bought 2 x 2 GB Packs, each made up of 2 x 1GB sticks I've amended the spec above to make more sense.

I did over clock but I've restored the factory settings now...
My System SpecsSystem Spec
10 Nov 2009   #7
Dave76

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64
 
 

Welcome to Seven Forums.

First try Tews suggestion, taking out all of the RAM cards except one, if overclocking CPU, GPU or RAM return all to defaults, try the installation.

If it still doesn't work, tell us if your computer is an OEM or custom build. The model and manufacturer if OEM. If custom build then what mother board are you using.
My System SpecsSystem Spec
10 Nov 2009   #8
cusimar9

Vista
 
 

Quote   Quote: Originally Posted by Dave76 View Post
Welcome to Seven Forums.

First try Tews suggestion, taking out all of the RAM cards except one, if overclocking CPU, GPU or RAM return all to defaults, try the installation.

If it still doesn't work, tell us if your computer is an OEM or custom build. The model and manufacturer if OEM. If custom build then what mother board are you using.
Hi there,

Its a custom build, the motherboard is a MSI P35 Neo2-FR iP35 Socket 775

Out of interest, why could there be a problem with the RAM? Vista ran fine with the same config...
My System SpecsSystem Spec
10 Nov 2009   #9
Tews

64-bit Windows 8.1 Pro
 
 

Friend, just try what has been suggestged, if you choose not to then Im 10-7..
My System SpecsSystem Spec
10 Nov 2009   #10
cusimar9

Vista
 
 

Removed all memory but a single 1GB stick with the same results. Tried both x86 and x64 versions.

I'm installing XP at the moment and I'll see there are any BIOS updates for my motherboard, can't think of anything else
My System SpecsSystem Spec
Reply

 Installation hangs on black screen




Thread Tools




Similar help and support threads
Thread Forum
Re-Installing Win7 / Process hangs in a black screen with cursor
Hi all, I have been trying multiple times to install Windows 7 to my hp pavilion g6-1007 laptop from an installation DVD but with no success so far. The problem is that I can't proceed with the installation. Every time I put the DVD and boot from there, first I see that black screen with the bar...
Installation & Setup
BSOD each run PC, PC Hangs on black screen before login, 1000009f
Hi, As in title, for last days i had BSOD problem, all the time i was starting my PC it was hanging on black screen, that one after Windows logo and before login screen. I was nervous about that, so i've reinstalled whole stuff, BUT it's back here with same BSOD code. Also i've got problem with...
BSOD Help and Support
laptop hangs when during sleep or hibernation with black screen
when ever i sleep or hibernate my dell inspiron pc it hangs black screen with very little hdd activity and remains so until i forcibly shutdown by pressing power button.Ater reboot i am able to go to sleep or hibernation but after a continuous operation of more than 30mins this error occurs.I...
General Discussion
Windows 7 installation hangs/black screen
Hello I have a problem with installing Windows 7 on my pc. I get either black screen or the installation hangs completly and the only thing I can do is restarting my pc. The black screen usually appears before reaching the very first window where you choose your OS language or right before the...
Installation & Setup
Screen hangs, sometimes going black, feedback from speakers.
As per title, screen will hang, sometimes going black. I get feedback from the speakers. Keyboard and mouse are both unresponsive. Has happened with games both online and offline. Attached SF Diag tool files.
General Discussion
Install hangs with black screen and watermark only
As the title explains, I have a new HTPC I built with the following equipment. Motherboard: Intel DG45ID Socket 775 Motherboard CPU: Intel Pentium Dual Core E2200 2.2Gh Memory: Kingston 4096MB PC6400 DDR2 800MHz (2x2048) ...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App