Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot complete installation of W7 with M/B 990FXA-GD80

20 Jul 2015   #1

Windows 7 Home Premium, installer won't finish
Cannot complete installation of W7 with M/B 990FXA-GD80


I have read this thread about same problem:
Still Cant Complete Install, new build (Stripped to essentials) :'(
The guy there has exactly same board. I read and followed the steps which helped him, but for me it did not help. There is Click BIOS II on the board from MSI. UEFI should be updated because there is graphical software which is not in the manual (in manual book there is different screen than I have). The manual is very short and does not say anything how to install W7 Home Premium with this board.

First of all I want to say, I can install Windows XP SP3 without problem and M/B does not look to be faulty. It looks perfectly fine. I tried to install W7 and W8 and both experienced same problems. I even installed Linux Magaia 4.1 x86 64bit to test. W7 and W8 restarts to finish installation, but they will never complete because it restarts suddenly. Looks like they restarted when they tried to load some driver or server. Magaia has different instalator, which succeeds to install Magaia, but after it is installed you have to restart PC. During start of system it will also restart sudenly, but I found I can start the PC with linux when I choose different settings for grub boot manager. So I choosed no ACPI and got there. I logged and started KDE (windows). Then I found that if I disable APIC on the start of linux, NO RESTARTED HAPPENED. So I solved this issue on linux and I believe this could be some evidence to help me to solve the problem with instalation of Windows 7. I followed the steps adviced at the thread linked above. So after the installer first time restarted, I went to save mode (shift+F8) and they wait to load the windows environment. When the message saying "Cannot install Windows 7 in safe mode" appeared I pressed shift+f10 and got the command line window opened. I typed "compmgmtlauncher" and the manager opened. I disabled all devices which had the yellow exclamation and restarted PC but the problem stayed, so it restarted when the installation should be completed.

Do you have any advices how to complete the installation? I read something about APIC and interruption controller. Some guys (many year ago) solving some problem and advicing to turn of plug n play in BIOS. Note: I did not find any option to turn of APIC in the BIOS or in the Device Manager.

I can add logs, but not sure if they are what you need.

Attached Files
File Type: txt ntbtlog.txt (632.5 KB, 0 views)
File Type: log Local_LLU.log (50 Bytes, 0 views)
File Type: log InstallPackage_ETW.Log (29.1 KB, 0 views)
File Type: log Network_LLU.log (40 Bytes, 0 views)
File Type: log LocalGroupAdminAdd.log (15 Bytes, 0 views)
My System SpecsSystem Spec
20 Jul 2015   #2


Can you run the installer from XP to complete install?

You do not want to have anything on the drive, especially GRUB, to get the cleanest possible slate for install. So after booting from the installer be sure to delete all partitions during install, create and format New as desired, or just click Next to let the installer do it for you. Pictures here: Clean Install Windows 7

Try entering Device Manager - Access During Windows 7 Installation to disable erroring drivers shown by a ! to see if install will complete so these can be updated from desktop.

Otherwise Troubleshoot Windows 7 Installation Failures - Windows 7 Help Forums
which overcome all installations failure, unless your mobo is one of the very few that are not at all compatible.
My System SpecsSystem Spec
20 Jul 2015   #3

Windows 7 Home Premium, installer won't finish

Yes, I can install Windows XP any time without problem and the installer will complete without problem.

I followed the steps exactly how you said.
My System SpecsSystem Spec

20 Jul 2015   #4


What steps did you follow? If you even read the troubleshooting steps you would have posted back by now the exact failure step and behavior as it requests. Did you miss that?

Exactly how was disk wiped?

Did you get the installation media?
My System SpecsSystem Spec
20 Jul 2015   #5

Windows 7 Home Premium, installer won't finish

Yes but I could not follow the steps from command line. You did not write from which directory should I start DISKPART. Also man, I do not remember every message, but as far as I remember the path where I was when I hit shift+F10 was c:\services or something like that. Because of that I did manual installation, cleaned partitions, created new. I could not follow "no ESP" tutorial because it does not work for me. So I always have the ESP there. It's also not clear for me how to disable UEFI. I think it is not possible to do that in my BIOS.

And I still believe there is conflict with ACPI devices ACPI/PNP0200 (DMA controller), and
ACPI/PNP0A08 and ACPI/PNP0103. Because their addresses of resources are in conflict. Windows XP does not have conflict with them simply because Windows XP does not install
ACPI/PNP0A08 and ACPI/PNP0103 as I did not find them in Device manager of Windows XP, but in Device Manager of W7 yes. I also would like to disable them or uninstall, but it is not possible. I tried to uninstall them but they are back after restart.

Thanks for your advice.
My System SpecsSystem Spec
20 Jul 2015   #6


Of all the thousands of people we have helped run Diskpart commands here, not one has ever had a problem with it opening to the wrong directory when run as it must be from Win7 installation disk Command Line. And you could have easily asked back if you were the first.

Now start at the top of the tutorials you ignored now and ask for any help needed in completing each step, which always leads to the solution. Those who make the effort will never fail. We will not allow them to fail. But you must do the work
My System SpecsSystem Spec
21 Jul 2015   #7

Windows 7 Home Premium, installer won't finish

I followed all steps. I did exactly same steps as described by your first link Clean install. Then I restarted PC, booted to safe mode, pressed shift+F10, typed compmgmtlauncher, waited, clicked on Device manager and disabled all devices which have exclamation mark in yellow triangle. I restarted PC, select start Windows normally and then it restarted before the system was fully loaded.

Next time I installed using AHCI and same steps and same problem.

In the last link there is:

6. At first installer screen Press Shift + F10, or enter System Recovery Options to open a Command Box, type:


I booted from installation DVD Windows 7 Home Premium. What is the "first installer screen" is it the blue page with "Install now (>)" button? This is the page where I was when I pressed shift+F10.

PS: I did not ignored the tutorials
My System SpecsSystem Spec
21 Jul 2015   #8


Try again. If you can't access it via Shift+F10 then enter System Recovery Options.

Wiping the disk is the #1 solution to these failures. If you can't use Diskpart then download Seagate Seatools
and burn to CD using Windows Image Burner. First run a full disk test of your hard drive, if it passes wipe the hard drive from Seatools. But you need to test your hard drive anyway.
My System SpecsSystem Spec
22 Jul 2015   #9

Windows 7 Home Premium, installer won't finish

I have run diskpart and finished the steps to clean disk. Created and activated the partition. Started install, reset, reboot, safe mode, shift+F10. compmgmtlauchner, disabled problematic devices. PC still auto-restarts during Windows 7 loading drivers. AHCI or IDE mode no help. Disk is 100% good and no problems with it. I also tried to install the W7 on different disk 500GB SATA II.

How you can find out what causes the problem. There must be logs which a pro would read and find out the problem. However I told you already, there are conflicts in devices with ACPI APIC (id=acpiapic) but you ignore this important message.
My System SpecsSystem Spec
22 Jul 2015   #10


Now that the basics were covered we will look at other possibilities.

What are the ACPI power settings in BIOS?

Is there no disable for those in Dev Mgr?
My System SpecsSystem Spec

 Cannot complete installation of W7 with M/B 990FXA-GD80

Thread Tools

Similar help and support threads
Thread Forum
Windows could not complete the installation.
will you please help with that i got same problem but i keep to press alt f10 but nothing is happen tell me bro what should i do and one more thing when the error message coming i press shift f10 show me command prompt but it right Arabic how can i change it to English
Installation & Setup
Problem in installing (HD6770) on (990FXA-UD7)
Hello, I've just bought a new PC, I'm sure i placed everything right problem is i don't see nothing on the monitor, I tried to mount my GPU (Vapor-X HD6770) on every PCI-E slot (Gigabyte-990FXA-UD7) i got and still not working, Is there anything i'm missing? PS: my graphic card is working fine on...
Hardware & Devices
Gigabyte GA-990FXA-UD7
Just ordered.. Gigabyte GA-990FXA-UD7 Motherboard - $279.00 : PC Case Gear Gigabyte GA-990FXA-UD5 Motherboard - $229.00 : PC Case Gear Comparison
Hardware & Devices
Windows 7 Cannot complete installation.
I own a Dell Studio 1558 Laptop, my keyboard broke so contacted them and they sent over a tech to replace my keyboard, ram, and mobo. After this i was getting a lot of BSOD while runing the laptop for a good amount of time, then i would have to leave it off for a while and it would boot up again,...
Installation & Setup
ITunes 9.0.2 Will Not Complete Installation
Hello Everyone, Hopefully someone can help me here. I Just upgraded to Windows 7 Prof 32bit. I split my hard drive into partitions so one is XP and one is Windows 7 so it is a clean copy of windows 7. I am running into an issue where ITunes gets about 3/4 of the way through installing then pops...
windows 7 cannot complete installation
Hi, been trying this for 2 days with no result... Really hope I can get some help. I installed Windows 7 on my machine using CD, HDD is blank (formatted). Once the system prepare to startup, it will go blank. When I go to safe mode, it says I cannot go to safe mode without complete installation...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App