Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 10 Upgrade Failing in "Safe_OS" phase...

07 Aug 2015   #1

Multi-Boot - Windows 8.1 Professional x64 / Windows 7 Ultimate x64 / Other
Windows 10 Upgrade Failing in "Safe_OS" phase...

I am in charge of 2 Compaq CQ2815EA from PCWorld (*spits*) for my companies social club.

They came installed with Windows 7 Home Premium, and being a social club they were reluctant to pay to upgrade to Pro (I may have some swing with that this time). As such, and due to the environment the machines are being used in, I used some registry hacks to prevent users messing with the system where possible. (Unfortunately I cannot remember exactly what tweaks I employed).

Now it's come for the Windows 10 upgrade.

I have used the Media Creation Tool, both directly on the machine in question and to create installation media (USB).

The install starts off OK (under the administrative logon).

Then we get the first reboot, I get the black screen with the grey progress bar "Loading Files" and then nothing.

The monitors built in error message reports "Out of Range" (It would normally report "Cable Not Connected" when there is no signal).

It goes like this for ages, and as I can't leave the machine unattended I reset the machine, I got the same error and then eventually the windows 7 login.

Logging in gives me an error message as to why Windows could not install.

So far I have received 2 different messages

The installation failed in the SAFE_OS phase with an error during APPLY_IMAGE operation

The installation failed in the SAFE_OS phase with an error during INSTALL_RECOVERY_ENVIRONMENT operation

I just checked my Win 7 updates and there are 2 failures...

Intel Corporation - Graphics Adapter WDDM1.1, Graphics Adapter WDDM1.2 - Intel(R) HD Graphics

Installation date: ‎07/‎08/‎2015 12:51

Installation status: Failed

Error details: Code 80070103

Update type: Optional

Intel Corporation Graphics Adapter WDDM1.1, Graphics Adapter WDDM1.2 software update released in December, 2012

Intel Corporation - Storage Controller - Intel(R) Desktop/Workstation/Server Express Chipset SATA AHCI Controller

Installation date: ‎07/‎08/‎2015 12:51

Installation status: Failed

Error details: Code 80070103

Update type: Optional

Intel Corporation Storage Controller software update released in September, 2012
I've also just noticed that I have a DVI connector on the back of the machine too, but I am connecting via VGA.

I am going to try bringing in a DVI to VGA adapter to see if that gives me any display at all, but I am wondering if between the 2 error messages it would have installed if I had just left it.

But in the mean time, can anyone else cast any opinions on this?

Attached Thumbnails
Windows 10 Upgrade Failing in "Safe_OS" phase...-failed-updates.png   Windows 10 Upgrade Failing in "Safe_OS" phase...-system.png  
Attached Images
Windows 10 Upgrade Failing in "Safe_OS" phase...-win10-0xc1900101-0x20004.png 
My System SpecsSystem Spec
07 Aug 2015   #2

Win 10 Pro 64

You can extract the ISO and run it from a folder in the machines? Did you remove all AV programs before the upgrade?

You may get better results if you post your question at the Windowsten forum.

Windows 10 Forums
My System SpecsSystem Spec
14 Aug 2015   #3

Windows 7 Home Premium 64bit

I experienced this issue and attempted it 4 times and only got it up the 5th time. After reading up advices from multiple forums, this was what I did to make it work.

1) Uninstall all 3rd party software, especially any software on CD/DVD burning, Defragmenter, Optimizer & Tuning; Hard Disk utility / benchmarking and disk encryption software.

2) On my 1TB hard disk. I repartition my C drive so that it has about 200GB with 100GB available; 500GB to D drive with about 300GB available, and the remaining 300GB unformatted. In one of the forum, somebody stated the failure can be caused by the win10 installer trying to setup a hidden recovery partition which needs about 60GB of space. In another forum, somebody stated that the C drive must have enough space for it to store the old Win7 files and also to install Win10.
Also make sure you do not encrypt your disk.

3) Changed my disk partitions from dynamic disk to basic disk.

4) Download the media tool for Win10, ran it to 100% and choose to 'Keep Nothing' (Of course, I have backed up all my files already).

5) Unplug all external USB and also removed my add-on WiFi adapter card, and connect my pc to the internet via a LAN port.

6) Once the win10 downloads finished at 100% and the OS is in the process of rebooting the PC, I unplug the LAN cable from the PC as soon as possible.

That is it! Succeed on the 5th time.
My System SpecsSystem Spec


 Windows 10 Upgrade Failing in "Safe_OS" phase...

Thread Tools

Similar help and support threads
Thread Forum
"Startup repair" failing - hard disk space issue?
I'm hoping this is a simple fix. I'm trying to fix my elderly uncle's Asus laptop. System Repair pops up and fails. I booted to command prompt and found out it may be hard disk space. 400+ GB Hard drive (only one drive) and there's only 1024kb Free. I'm thinking that could be the issue. Hardware...
General Discussion
"Windows Updates Cleanup" failing after reboot
Hello, it is the first time that I can't fix a windows error myself (by googling I mean), so I followed the guide here 1) SURT run, no problem reported 2) SFC all clear (no problem reported) ...
Windows Updates & Activation
KB2852386 - "Windows Updates Cleanup" failing after reboot ! :(
Hi, I finally heard of this KB and ran like mad to install it and get some gigs off my ssd. Installing went fine. I ran the clean up wizard and lo and behold, it found 3.5 gigs of windows updates leftovers. I selected it and let it do it's thing... then a reboot occured and when it's time to...
Windows Updates & Activation
Overdubbing - 2nd recording sounds "phase shifted"
On my old Xp, using a cheapy microphone (plugged into sound card), I successfully overdubbed one guitar part onto another with no perceived loss in quality. I had a SB card and used "record what u hear" which I assumed took it directly from the card BEFORE it hit the speaker (i.e. it's recording...
Sound & Audio
Install time difference between "Upgrade" and "Custom"
Is the time to "Upgrade from vista to 7 supposed to be wayyy longer then it would to do jsut a clean install? (For example, hanging at 18% for a while while installing during upgrade) (posting this since i cant get any replies to a previous topic)
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:15.
Twitter Facebook Google+