Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 Installation via USB failing on UEFI and Legacy

08 Aug 2015   #1
fluffymitten

Windows 7 Pro x64
 
 
Win7 Installation via USB failing on UEFI and Legacy

I have read the tutorials and the many posts on this topic so apologise for creating another post on an old topic. I am hoping I am being an idiot and have just missed something really simple.

Scenario 1: Created UEFI bootable USB, using Rufus, configured BIOS with CMS disabled and Secure Boot enabled. USB drive is recognised in BIOS as UEFI and selectable as a boot option. Windows files show as loading and then it sits with the Windows logo doing nothing.

Scenario 2: Created 'normal' bootable USB, using the Windows Download Tool, configured BIOS with CMS enabled and Secure Boot disabled. USB drive is recognised in BIOS but not as a boot option. Get a message prompting to insert boot media.

I don't have a DVD drive so USB is my only boot option. The system is a 3XS Scan custom build but the OS stopped recognising mouse and keyboard even in safe mode so I opted to wipe the hard drive and start with a fresh build. The OS was being unstable anyway and it was time for a clean install.

This is the first time I've tried a build since UEFI has started rolling out and it's nowhere near as straight forward as it used to be... Just used to pop a USB or (remember these...) a floppy to a basic command line to set up the partitions and load up the OS. So, what I am really saying is that I am utterly clueless in this new world order and will need handholding...

Thank you for any help and suggestions.


My System SpecsSystem Spec
.
08 Aug 2015   #2
genet

Windows 8.1/10 x64
 
 

Asus motherboard with UEFI firmware. How to install Windows 7/8/10 64-bit in UEFI Boot Mode. -> link
My System SpecsSystem Spec
08 Aug 2015   #3
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64
 
 

@ genet
May I suggest posting this. One knows where this is going to send them.

UEFI settings for ASUS z77 prior to Clean install

Instead of this -> link

One is never sure where -> link is going to send them.
My System SpecsSystem Spec
.

09 Aug 2015   #4
fluffymitten

Windows 7 Pro x64
 
 

Thanks for the suggestions but still gets stuck on the Windows Logo. I either have three faulty USB drives (but I can boot from all on non-UEFI mobos) or something is up somewhere.

A friend kindly removed their SATA DVD drive to lend me and I was able to successfully boot from DVD and install Windows.

I guess I will have to try and resolve this issue another day, probably when I next urgently need to rebuild my PC.

Is there any reason why it's so hard to use USB with UEFI, or am I just unlucky?
My System SpecsSystem Spec
09 Aug 2015   #5
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Yea I haven't tried yet on a asus x99 board the bios settings are so complicated
But setting boot/ secure boot and to Other OS is 1 option to try ?

Then you get into CSM compatibility support module stuff is where the fun starts
The default is uefi and legacy oprom so in theory it should work no telling what oprom is

I'd guess switching Launch CSM will disable secure boot but I'm too chicken to try it yet :)
My System SpecsSystem Spec
Reply

 Win7 Installation via USB failing on UEFI and Legacy




Thread Tools




Similar help and support threads
Thread Forum
Difference with UEFI or Legacy BIOS in Win7 64bit
Well, I have 3 questions before I proceed with new clean Win7 installation 1. Action before Win7 UEFI install "Disable secure boot", but after installation, should user "Enable secure boot" or will this lower security continue and give a vulnerable system ? 2. Is it really a big difference...
Installation & Setup
Installation of Windows 7 SP1 UEFI failing
Hello, A while ago my boss told me I needed a laptop, so I bought a nice second hand one, and bought a fresh new copy of Win7 SP1. It always worked fine, until the laptop died. My boss bought me a nice new laptop, but we found out that some programs don't run well on Win10. We also have an...
Installation & Setup
Windows 7 Installation CD - Can boot in Legacy mode but not in UEFI
When i try and boot my Windows 7 x64 DVD in UEFI mode my computer completely skips it and boots my hard drive. However when I boot in legacy mode i can boot the CD but i get the error 'Windows cannot be installed to this disk. The selected disk is of the GPT partition style'. I'm assuming i get...
Installation & Setup
Install Win7 w/Legacy Oprom enabled for installation - then disable?
Hi I have a brand new Dell Inspiron 15 7548 series that I want to quad boot with 8.1 (as main OS; will be using the OEM OS it came with) , 7 Ultimate, 10 Tech preview and Fedora 21. Because I can ;) I have figured out that i CAN install windows 7 in UEFI / GPT mode, but the "legacy Oprom" needs...
Installation & Setup
Boot UEFI from wake on lan, or convert UEFI MBR to legacy.
Hi all, Currently having a wake on lan issue with a certain computer. The machine is setup correctly but the windows boot information is stored in a 100mb UEFI partition, and when the computer wakes on lan, it will not boot windows, just sit at a blank screen. When it wakes on lan it is...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:18.
Twitter Facebook Google+