Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot Install Win7 on GPT drive with UEFI?

19 Oct 2015   #1

Windos 7 Ultimate x64
Cannot Install Win7 on GPT drive with UEFI?

Hello everyone,

I made a post about this over on the Tom's Hardware forum also, but I think this might be a better place to ask.

I'm trying to install Windows 7 from a USB stick onto a small partition (100GB) of a 4TB HDD for an HTPC. When I first tried to create a partition during the windows install, it made the 100GB partition I wanted, but it also split the remaining HDD space into 2 different drives. After some reading, It seemed like the problem was that the drive needed to be formatted/partitioned in the GPT style rather than MBR (in order for windows to accurately see the full 4TB drive).

So, I created a boot disk with the program Parted Magic, formatted the whole drive with the GPT format, and created my 100GB partition in NTFS. Now when I try to install Windows 7 on the partition, it says, "Windows cannot be installed to this disk. The selected disk is of the GPT partition style." And this is essentially where I'm stuck...

I've tried updating my UEFI firmware, and playing with various settings (turning safe boot off/on, changing legacy support options, etc...) but nothing seems to work and/or I just create new issues.

At this point, I'm in way over my head. Does anyone have any idea how I can fix my issue? Any help will be greatly appreciated!


After a lot of hair pulling, I figured out what the problem was. The issue I was having is that the USB Windows 7 boot drive I made using the Windows 7 to USB/DVD download tool was not correctly formatted for GPT. So, when I was booting from the USB, it wasn't using the UEFI USB boot option, it was just using USB. I used Rufus to create a new boot USB, made sure it was formatted correctly for GPT (and in FAT32), and voila. For some reason, the Windows install still didn't like my GPT formatted partition, so I had to delete it and make a new one within the install, but that was a minor issue. Windows is now installed on my 100gb partition, and the OS sees the rest of the remaining 4TB partition as its own drive. Problem solved.

My System SpecsSystem Spec
19 Oct 2015   #2

Windows 10 Pro X64

My System SpecsSystem Spec

 Cannot Install Win7 on GPT drive with UEFI?

Thread Tools

Similar help and support threads
Thread Forum
Clevo Probook w651sf | Cant install win7 in uefi mode
Hello , i cant install win 7 in uefi mode , getting this error > Some1 can help me ?
Installation & Setup
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
cannot install win7 64 on uefi system
Hello guys 1st post but i think this site may be able to help me out. I have been in IT for 17 years but i must admit this has me stumped. I have tried with Windows dvd and also I created a 64bit usb. Same issue with both, I have followed the steps for fresh install on uefi. It will load the 1st...
Installation & Setup
UEFI boot keeps changing; UEFI/Win7 handshaking confusion
Trying to understand handshaking between UEFI & Win 7. Have Win7 Pro sp1 64 installed on SSD, mb=Asus F2A85-V Pro. Example: boot to flashdrive to do Acronis backup of SSD; remove SDD, insert spinner; boot again to flashdrive to do Acronis restore to spinner (to test backup); remove flashdrive, boot...
Installation & Setup
Windows 7 + UEFI Based Install + SD Card/USB Drive = Fail?
I want to install Windows 7 to a UEFI-compatible netbook that only has a SD Card slot and a single USB Port (the netbook I'm refering to is the CR-48 if anyone is curious) I know this computer supports UEFI (I was able to start the Fedora 14 EFI and Win7 x64 EFI installers) but my assumption is...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:31.
Twitter Facebook Google+