Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows won't install on new computer, error 0x8007045d

18 Jan 2016   #1

Win 7 64bit Ultimate
Windows won't install on new computer, error 0x8007045d


I recently bought my Husband a new computer setup of the following:

Asus X99-A Mobo, Intel i7-5820K CPU, Corsair Vengeance LPX 16GB 4x4GB Ram and a Samsung 850 Evo SSD

My husband, being an IT by trade, went through the BIOS menus and started to attempt to install Windows 7 Ultimate 64bit. He has since then been plagued by errors, majority of them being the error code 0x8007045d.

We have tried the following:

Removed all unnecessary parts (barebones minimum) to do the steps below.

Set the BIOS to Legacy, Used DVD-ROM as first in booting order, and used both the Win 7 CD as well as a USB install to no avail. We use DrivePART to format the partition/drive between each attempt, and get the error code above.

Set the BIOS to UEFI, used Rufus to create a bootable Win 7 install drive with UEFI enabled. With this we either cannot find the drive, or sometimes it'll give us the same error.

With UEFI, we were successful in installing Windows -once-, however upon loading drivers for the motherboard, windows crashed and since then was unstable, sending us back to redoing the process all over again.

Thinking that it may be the SSD, we put the new SSD in my computer with Samsung Magician. It said the drive was in good health. We did a secure erase on it to attempt again. We attempted to use DrivePart again to partition the drive, and same error code (using Legacy USB/DVD again)

We ran chkdisk on the SSD with no errors. The SSD allows windows 7 to install on my computer (older 5 year old computer) but still has the same errors on the new computer.

We also ran memtest for 5 passes on the ram incase that was faulty, and it had no errors.

We have tried different SATA ports (which coincidently worked with the 1 successful install, but has since then been unsuccessful) and different SATA cables. We've reset the BIOS countless times, including removing the battery.

I am now coming to the forums in hope someone can shed some light on what else to do. I believe the SSD is functional as it does allow Windows to install on my 5 year old computer. My husband and I are almost convinced it's the motherboard or that we're missing some obscure setting somewhere.

Does anyone else have any suggestions before we go through the hassle of RMA'ing the motherboard? Thanks.

My System SpecsSystem Spec
18 Jan 2016   #2
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Welcome to our forum namnomm.

Well now that is a long list of things you folks have tried.

Did you by chance make sure Secure Boot is disabled in the bios?

Their are members that do more installs in a week than I do in years. Just hang in there for more help.
My System SpecsSystem Spec
19 Jan 2016   #3

Win 7 64bit Ultimate

Yes, Secure Boot is disabled in the BIOS.

We ended up getting a copy of Windows installed after another 6 hours today put into it. I think it's purely sheer luck. However after successfully installing the essential drivers for the motherboard, video card, ssd, and all that comes with it, we are now reaching a total impasse.

We cannot Windows update. We have a direct connection to the internet, no firewall, nothing. Internet works fine. However Windows update cannot seem to download any of the updates. It will hang at 0% downloading regardless which update or how many updates we decide to check.

Never had this issue before and unsure where to continue, or if this windows installation is botched and we'd have to try again from the beginning...
My System SpecsSystem Spec

19 Jan 2016   #4
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Every sense W-10 came out Windows 7 Update will take forever.

Reports are from 6 hours to over 24 hours. You just have to wait.
You can try this if your system is in the search mode. Not in the Download or Install mode.

Reboot you system again and try the Windows Updates again.
If your luck runs good you will get another Microsoft server that isn't so busy.
Then leave your computer running Searching for how ever long it takes.

I think this is Microsoft tell us we didn't play nice and update to W-10.
My System SpecsSystem Spec

 Windows won't install on new computer, error 0x8007045d

Thread Tools

Similar help and support threads
Thread Forum
Error code 0x8007045D when doing fresh install
So I launched my PC the other day and was greeted with a BSOD. System repair didn't work so I decided now would be a good time to install the Samsumg 840 EVO SSD that has just been sitting in my room for a while. So I unplugged the harddrive and then plugged in the SSD, but when installing I was...
Installation & Setup
Windows 7 Ultimate 64 bit install ERROR 0x8007045D
Ok I have been over this forum with a fine tooth comb the past few days trying to troubleshoot my problem that I am having. I have attempted to install every iteration of windows 7 on my brand new build. I don't have any blank DVD's so I have been attempting to install from USB. Every time it...
Installation & Setup
0x8007045D error when re-installing windows 7.
Hello guys, I have a Dell inspiron 15r special edition and lately I've been getting problems. My laptop today decided to crash today and encounter an infinite start up repair loop. I've decided to use the dell DataSafe restore and emergency backup to format and re-install the OS but I keep...
General Discussion
Windows 7 error code 0x8007045d during clean install.
Hi i am trying to help my friend out he bought his son a emachines em350 netbook with windows 7 installed. For some reason it got messesd up and he tried to do a system restore. Since then when you try to boot up its saying input a password to unlock the harddrive which we dont know. After you...
Installation & Setup
0x8007045D - Windows Won't install
Hi, Today I decide to make a clean install of Windows. Boot from DVD and try to install ... when goes to 25 - 50% give me this error: 0x8007045D Telling me that are broken files (whatever). I try with a different DVD but the result is the same. I need to work and I can't install Windows.
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:04.
Twitter Facebook Google+