Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 UEFI install motherboard ASUS Sabertooth Z170 Mark 1

23 Jan 2016   #1

Windows 7 64-bit
Windows 7 UEFI install motherboard ASUS Sabertooth Z170 Mark 1

Hi all,

I have new mobo Asus Sabertooth Z170 Mark 1. I want to install Windows 7 Home in UEFI mode, but I'm still not successful.
Bios settings - SATA Mode Selection - Raid - 2 SSD disks set up in Intel RST as Raid 1
Newest Bios update from 7.1.2016
Boot settings:
Launch CSM - Enabled
Device Control - UEFI and Legacy OPROM (UEFI only can be chosen as well, but without any changes)
Boot from Storage Devices - UEFI driver first

Secure Boot:
OS Type - Windows UEFI mode

When I boot in UEFI mode I get to Win install through language settings, then Install and then it get stuck with message:

"A required CD/DVD drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB fhlash drive, please insert it now.

Note: If the Windows installation media is in the CD/DVD drive, you can safely remove it for this step."

I use original OEM DVD Win 7 Home 64-bit that is surely good as when I boot in Legacy mode everything goes well and when I change SATA mode selection to AHCI instead of RAID and UEFI is enabled it goes well, too.
When I also tried Win 8.1 in UEFI mode everything went well and system was installed correctly.

But I want RAID, UEFI, Windows 7. Probably I need to get RAID drivers into Windows 7 install, but have actually no clue how to do it.

As I was not successful with DVD (I expect the home edition is not suitable for install in UEFI mode, but I was not successful with Pro version either and that version contains efi/boot directori with bootx64.efi file) I did a USB flash drive from that DVD and also created UEFI bootable USB (e.g. as is written here - UEFI Bootable USB Flash Drive - Create in Windows)

I can boot from Flash drive, but it does the same, so I ended up with the message: "A required CD/DVD drive....."
I did't use USB 3, only USB 2 ports and more of them, but without any success.

As I mentioned, Bios is the newest, UEFI settings are probably correct (if it was not, Windows 8 will not be installed)

During the message "A required CD/DVD drive....." I have a possibility to pick something from Browse, but I only get this choice:
- BOOT ( X: )
- - Program Files
- - sources
- - Users
- - Windows

When I plug a Flash drive it is not recognized nor DVD. Firstly I thought I need RAID drivers or other drivers, but no Flash drive is able to choose in this step (that Flash drive can be seen in Bios, so the USB Flash drive is surely ok)

In Boot menu I choose "UEFI: USB Flash Drive" (before I chose UEFI: HL-DT-ST.. as DVD-ROM). Even if i choose only USB Flash Drive (without UEFI in Boot menu) the result is the same.

I also tried to download new image with built UEFI that is considered by other users as helpful, but the same result. Also tried original Windows 7 Pro OEM DVD (image written to USB flash drive) - the same issue and also tried external DVD drive - no success.

Any suggestions how to solve this? Will appreciate that.

My System SpecsSystem Spec
23 Jan 2016   #2

Windows 10 Pro x64

PM me if you want to talk, I`ll let you know how to get it done.

But, you can`t install Windows 7 through usb on a Z170

It is now a picnic to install Windows 7 on a Z170 using the 3.0 USB ports by setting up a usb installer using Asus`s EZ Installer program, but the Z170 has usb 2.0 ports, so no issue anyway.
My System SpecsSystem Spec
24 Jan 2016   #3

Windows 7 64-bit

Thanks for posting, but I'm unable to send you PM and I don't have this possibility by default. Maybe the reason is that I'm new and administrator must enable this feature for me. Quite strange, but I can't help myself. Is there any way to contact you?

Meanwhile I tried to change Secure Boot to "Other OS", run the install process as UEFI, but no success - the same result.

I also tried Method 2 in this document: No success again.
My System SpecsSystem Spec

26 Jan 2016   #4

Win-7-Pro64bit 7-H-Prem-64bit

Do you have another machine to start the install on ?

FWIW you might of gotten nice easy x99

But anyway AddRam once said he didn't do anything special he must of been fibbing :/

Anyway seems you might need to start the install on another machine and when you get to the first restart just hold down the power button to shut down
Then swap out the ssd or hdd into the new rig then power up and the installer will continue where it left off
My System SpecsSystem Spec
03 Feb 2016   #5

Windows 7 64-bit

Hi guys, sorry for my late reply :).

TrashZone, Thank for your advice, but I think it is the issue of motherboard and Win 7, so I'm not sure, if I install it on another machine if it will accept another UEFI BIOS settings on another machine.

But I will share results of my investigation during last days. Hopefully it may help to someone.

Note: There are 2 ways of booting - UEFI and none UEFI

USB flash
UEFI mode

If Uefi is on (Legacy off) in Bios, then UEFI boot is unable to run. If I run non UEFI boot install process of W7 continues until it comes to screen where drives are shown. In this window I'm able to load the driver (I prepared USB Boot stick with USB drivers from mobo DVD). It found following items:

Compatible: intel usb 3
and also
MTT Host Controller USB 2.0
Host Controller USB 2.0
Host Controller USB 3.0
USB Host Controller

with this driver file: iusb3hub.inf

In all cases driver loading was not succesful (USB stick was inserted into USB 2.0). If I clicked Next nothing happened.

I also loaded RAID drivers (from mobo dvd) to that USB stick in case it is needed as I want to have RAID 1

It showed compatible driver for Intel Chipset SATA Raid Controller with this driver file: iaStorAC.inf

and also other (incompatible) drivers:
Intel 100 Series / C230 Chipset Family AHCI Controller iaAHCIC.inf
Intel 6th Generation Core Processor Family Paltform I/O SATA AHCI Controller
Intel 8 Series Chipset Family SATA AHCI Controller
Intel 8 Series / C220 Chipset Family SATA AHCI Controller
Intel 9 Series Chipset Family SATA AHCI Controller

It has found the hard drive (only one size is shown, but it is probably due to RAID 1) But this drive I was not able to format and continue with install.

Following message appeared:

Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure the disk's controller is enabled in the computer's BIOS menu.

Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information

So the result is that I was not able to install Windows 7 under UEFI.

Legacy mode - UEFI booting is not able to launch

in non UEFI booting installation process is correct and it created 2 partitions
1. System with 100 MB total
2. Primary with 476,8 GB size (Raid 1)

If I took a look at the file C:\Windows\Panther\setupact.log

I could see BIOS under Detected boot environment

This makes sense as it was launched in Legacy mode (even if Windows UEFI mode was selected under Secure Boot option).


UEFI mode

If i run it as UEFI (not Legacy mode set up in Bios) it makes the same as USB stick did with one difference that I'm able to run the install DVD also with UEFI booting. It means I was not able to install Windows 7 in case UEFI mode was on in Bios.

Legacy mode
UEFI boot

In this case install process goes well. I came to drive screen and already have 3 partitions

1. Partition 1 100 MB System
2. Partition 2 128 MB MSR (Reserved)
3. Partition 3 476,7 GB Primary

Installation process was succesful and if I took a look at the file C:\Windows\Panther\setupact.log

I could see EFI under Detected boot environment

This doesn't make a sense as it was launched in Legacy mode, but as UEFI boot. There was also option Windows UEFI mode under Secure Boot, but I realized that in this case it does not matter if there is Windows UEFI mode or Other OS selected.

I'm confused of this as the BIOS was set to Legacy, boot was UEFI and Windows shows that boot environment is EFI. Does it make a sense to someone?

In case I installed Windows 8 everything was set to UEFI, no Legacy and it was also EFI (setupact.log), but there is still the difference, so I'm not sure if I can be satisfied that I'm UEFI or not. In this case it is not UEFI like UEFI (in comparison W7 vs. W8)

All mentioned cases were in CSM enabled mode.

If CSM is disabled and Secure Boot is set to Windows UEFI mode DVD does not launch it always do the restart.

If CSM is disabled and Secure Boot is set to Other OS DVD with UEFI boot always froze.
If CSM is disabled and Secure Boot is set to Other OS DVD with non UEFI boot continues installation process further (but as BIOS, not EFI in setupact.log), but this was not my case as I wanted UEFI. But this also make sense.

My conclusion is that only way how to install Windows 7 UEFI was to set Legacy in BIOS and run UEFI boot (Secure Boot was Windows UEFI mode, too, but when I try to launch it as Other OS, I did not realized a difference). Original DVD is all you need. So in this case setupact.log is showing EFI Boot detected environment.

But I'm still a bit confused if this is the proper solution of Windows 7 UEFI for Sabertooth Z170 Mark 1.
Is it the only way how to get W7 UEFI in this case or am I doing something wrong?
Can anyone confirm or deny this?
My System SpecsSystem Spec
03 Feb 2016   #6

Win-7-Pro64bit 7-H-Prem-64bit

Seems a lot easier to use a dvd install disk instead of all of that :)
My System SpecsSystem Spec
04 Feb 2016   #7

Windows 7 64-bit

That is true, but nobody wrote me the solution and answer my question. And the question is still unanswered, because I'm not sure if I'm real EFI even if I chose Legacy mode in Bios :). I'm probably UEFI, but not full UEFI, but with no chance to be fully UEFI (because of W7 or Sabertooth Z170 respectively). But still not 100 % sure about this conclusion. To find it out, I did all that investigation, so I probably answered to my question myself and help someone who will ask something about install Windows 7 on Sabertooth Z170

Anyway I also tried to contact Asus support, but the answer was that I don't need to set up anything, but Windows 7 may be not work properly with UEFI, because UEFI is full compatible with higher versions of Windows. This is what I knew even without Asus Support :)
My System SpecsSystem Spec
04 Feb 2016   #8

Win-7-Pro64bit 7-H-Prem-64bit

Yea I didn't know at the time he was secretive then,
But yea dvd install was what AddRam did

I don't know why people get so freaky about uefi installs it serves little other than Bitlocker junkware

If you have a 100mb system reserved partition you have as close as it gets in win-7
I personally like it best with nothing but C drive
My System SpecsSystem Spec
04 Feb 2016   #9

Windows 10 Pro x64

Post a shot/snip of your install drive (the entire drive) from Disk Management, we should be able to tell from there.
My System SpecsSystem Spec
05 Feb 2016   #10

Windows 7 64-bit

Thanks, just quick reply.

I have it similar like here -
but another 10 MB unallocated. From this point of view it seems all like UEFI, my doubt is about settings in Bios, where I had to set Legacy mode in order to install W7. This was not necessary while installing W8. I would say: it is UEFI (like Windows shows), but not UEFI (like Windows 8 UEFI is) so what is it?
If it is UEFI (what it really shows) what is the UEFI difference between installing Windows 8 in UEFI mode with UEFI boot and installing Windows 7 in Legacy mode with UEFI Boot
My System SpecsSystem Spec

 Windows 7 UEFI install motherboard ASUS Sabertooth Z170 Mark 1

Thread Tools

Similar help and support threads
Thread Forum
No sound z170 sabertooth and realtek
I have been going round in circles for 24 hours to fix this issue to no avail so was hoping somone with more knowledge and experience can light the way. This is a new build and the sound has never worked. Symptoms: Red cross next to speaker icon-no audio output device is installed Control...
Sound & Audio
Asus Z170-A Motherboard not showing external hard drives
I have a new custom build which I have built and have installed Windows on. The issue I'm having is that when I plug in an external drive, they are not appearing on the PC. They work on other laptops which I've tested and all the USB ports work on the new PC which I tested with the keyboard and...
PC Custom Builds and Overclocking
Asus Exhibits Glorious TUF Sabertooth Z170 Symbol 1 Motherboard
Together with its Z170 lineup, Asus unveiled its TUF Sabertooth Z170 Symbol 1 motherboard. Asus's TUF lineup of motherboards are built to be as tough as they can. "TUF" is a play to the word "tough, " but it surely actually stands for "The Quintessential Force, " with the plan behind the boards...
Hardware & Devices
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
Video Corruption after Installing Sabertooth Mark 1
I recently had to upgrade my processor and motherboard since they both decided to die. I'm now on a z97 Sabertooth mark 1 and i7-4790k(currently at stock till I can get my system stable). I had a problem with my drivers at first(and this might be more of the same) which I documented here...
PC Custom Builds and Overclocking

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:30.
Twitter Facebook