Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installation of Windows 7 SP1 UEFI failing

10 Apr 2016   #1

Windows 7 Professional 64
Installation of Windows 7 SP1 UEFI failing


A while ago my boss told me I needed a laptop, so I bought a nice second hand one, and bought a fresh new copy of Win7 SP1. It always worked fine, until the laptop died.
My boss bought me a nice new laptop, but we found out that some programs don't run well on Win10. We also have an outdated server setup, and Win10 seems to have some problems with it.

So we decided that I need to go back to Win7 64bit. And I decided to start reading up on that UEFI thing. I double checked that my Acer E5-721 has UEFI activated.

Via the tutorials on this forum I found out that I need a UEFI compatible ISO from Windows. The one I have is not. Apparantly I need BOOTx64.EFI in the EFI folder. Which I don't have.

So I unpacked the ISO, and unpacked INSTALL.WIM to find the BOOTMFGR.EFI file, and copied it to the EFI folder. I then used IMGBURN to turn it all back into an ISO and Rufuc to create me a bootable USB.

But it just don't work. I don't get the Win7 install screen. The laptop either goes to Win10 or gives me a screen that says: "Windows failed to start. A recent hardware or software change might be the cause. Status: 0xc000000f."

I also tried to put the required EFI files into the BOOT folder (seeing as some tutorial I found via Google suggested it). But nothing seems to work.

Can somebody help me to fix this??

I've read:
UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with
Clean Install Windows 7
UEFI boot from Windows 7 Install ISOs :: Easy2Boot
How to make windows 7 dvd SL (4.7gb) uefi bootable
Cannot use USB drives to install Windows 7 OR 8.1 in UEFI mode - windows 8.1 - Laptop Tech Support

But nothing works.

My System SpecsSystem Spec
10 Apr 2016   #2

Windows 7 Pro x64 Windows 10 Pro x64

Disable Secure boot in the bios

Enable Legacy Boot in the bios

Make sure the drive is initialized as MBR, not GPT

Install Windows 7 from a normal non UEFI dvd
My System SpecsSystem Spec
10 Apr 2016   #3

Windows 7 Professional 64

Disable Secure boot = check
Enable Legacy mode = really don't want to, I would prefer to get it working on UEFI (partly just because I know it is possible)
The drive as MBR not GPT = do you mean the hard drive or the USB/DVD?
Install Win7 as non-UEFI = As above, I'd prefer to get it working with UEFI. I know it is possible, and I want to get all the benefits that it brings (even if they are small).

Yesterday I tried a different Bootx64.EFI that I downloaded. And it gave me a very weird Shell command screen. With yellow, gray and white letters. If I didn't press any key, it would auto start startup.nsh? Didn't know what it was, so I turned off the laptop again.
The other Bootx64.EFI I downloaded seems to work to an extend. I get the "Starting Windows" screen, but it freezes at loading the Windows logo....
My System SpecsSystem Spec

10 Apr 2016   #4

Windows 7 Pro x64 Windows 10 Pro x64

The drive as MBR not GPT = do you mean the hard drive or the USB/DVD? Are you serious ?

There are no benefits to UEFI, if it were so easy, you would not be having such trouble.

You could be enjoying windows 7 instead of battling to install it.
My System SpecsSystem Spec
11 Apr 2016   #5

Windows 7 Pro x64 Windows 10 Pro x64

If you really want to use UEFI then,

Use a regular unmodified Windows 7 install dvd

Disable secure boot

Initialize the drive as GPT

Reading this should help you solve all your problems.

Clean install of Windows 7 Pro 64-bit on a UEFI laptop with GPT partition? - Super User
My System SpecsSystem Spec
11 Apr 2016   #6

Windows 7 Professional 64

Thank you for the advice. I'll give this a read and then try it out.

Having said that, I should add that I might not have time to do it until Saturday. But I'll report back.
My System SpecsSystem Spec
17 Apr 2016   #7

Win7 64bit

Does your BIOS has CSM setting? If so, try to enable it.

If no CSM setting found, then you have to use WinPE8 + WinNTSetup + Integrated Graphic Card Driver slipstream method. I have posted the method explanation here.
My System SpecsSystem Spec

 Installation of Windows 7 SP1 UEFI failing

Thread Tools

Similar help and support threads
Thread Forum
Windows 10 UEFI Installation
Hi people, I have some problem with installation Windows 10 UEFI on Samsung 850 EVO SSD. Actually I installed everything only my problem is because I could boot only if in BIOS is set option with Windows Boot Manager P1 Windows Boot Manager Samsung 850 EVO P1 Samsung 850 EVO Before I had...
Installation & Setup
Win7 Installation via USB failing on UEFI and Legacy
I have read the tutorials and the many posts on this topic so apologise for creating another post on an old topic. I am hoping I am being an idiot and have just missed something really simple. Scenario 1: Created UEFI bootable USB, using Rufus, configured BIOS with CMS disabled and Secure Boot...
Installation & Setup
Windows 7 installation on Toshiba UEFI
Hey all, I bought a new Toshiba L70-BST2NX1 laptop and I am trying to install Windows 7 (Home Premium 64-bit) on it using UEFI method, not dual boot with Windows 8.1, just Windows 7 all by itself. I got stuck early in the installation process. Here is what I did: Disabled Secure Boot in...
Installation & Setup
windows seve x64 uefi installation issue
Hi im having some issues installing a win seven x64 version onuefi mode. I create a usb gpt and i set everything on uefi in the bios and i can see correcly the raid volume active.ok I begin the windows instalation and when it cames the part to chosse the partition to install there is empty twher...
Installation & Setup
Windows 7 Ultimate SP1 UEFI Installation with DVD DL
Hi, I've build a custom installation of WINDOWS 7 Ultimate x64 SP1. My installation is about 8,3GB and I had to burn it to a DVD Double Layer. I want to install it to a UEFI system. I went to BIOS and in the UEFI menu I see the Drive of DVD with the EUFI enabled, but when select this...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:30.
Twitter Facebook Google+