Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Starter Install (Digital River),CANNOT UPDATE wucitux.dll

12 May 2016   #1

Windows 7 32 or 64 Bit
Windows 7 Starter Install (Digital River),CANNOT UPDATE wucitux.dll

I have been trying to figure this problem out for month's, but basically I cannot get the digital river ISO to install so that I can receive updates from Windows Update. I burned the ISO to a flash drive with Rufus by itself, and cannot get it to install onto my netbook without crippling windows update service. Is there another tool that I can use to install this from a flash drive successfully or no? Win 7 Starter did install, and activate just fine, but I found out when I had gone to re-register the DLL's with "regsvr32" that the wucitux.dll was missing. I have downloaded the ISO more than once from Digital River, and do have the correct architecture which is the 32-Bit version. To add to the info I have multiple netbooks that I have tested this on, and basically does the same thing. Also from the freshly installed OS from a flash drive I get this from windows update even with wuauvserv running (Windows Update Service) "Windows update cannot currently check for updates because the service is not running"

I will also note I cannot remember if it was with the OEM Restore partition, and or from an External DVD Drive, but I do remember when I had installed Win 7 Starter on more than one my netbooks through one of these means that I was still getting updates, but then I had gotten to a certain point, and I still could not install all of the windows updates.

I would appreciate it if Someone would help me out here I am not really an amateur, but I still cannot figure this one out myself.

My System SpecsSystem Spec
12 May 2016   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi FoF,
follow the instructions in this link, then we can progress.

Windows Genuine and Activation Issue Posting Instructions

My System SpecsSystem Spec
12 May 2016   #3

Windows 7 32 or 64 Bit

OK here is my Report:

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: N/A, hr = 0xc004f012
Windows Product Key: *****-*****-866GW-86TRK-HGRKB
Windows Product Key Hash: 1LUC1Vg/vipkocHQ6iREczqh7dc=
Windows Product ID: 00342-OEM-9549825-71483
Windows Product ID Type: 8
Windows License Type: COA SLP
Windows OS version: 6.1.7601.2.00010300.1.0.011
ID: {AA83824E-0DA9-49A5-9DB0-70511666C296}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Starter
Architecture: 0x00000000
Build lab: 7601.win7sp1_rtm.101119-1850
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->
File Mismatch: C:\Windows\system32\wat\watadminsvc.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\npwatweb.dll[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watux.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watweb.dll[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\sppobjs.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppc.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppcext.dll[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppwinob.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\slc.dll[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\slcext.dll[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppuinotify.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\slui.exe[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppcomapi.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppcommdlg.dll[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\sppsvc.exe[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\drivers\spsys.sys[6.1.7127.0], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\systemcpl.dll[6.1.7601.17514], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\user32.dll[6.1.7601.17514], Hr = 0x800b0100

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{AA83824E-0DA9-49A5-9DB0-70511666C296}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.011</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-HGRKB</PKey><PID>00342-OEM-9549825-71483</PID><PIDType>8</PIDType><SID>S-1-5-21-4279829112-3078207059-2640205848</SID><SYSTEM><Manufacturer>Acer</Manufacturer><Model>AOD255</Model></SYSTEM><BIOS><Manufacturer>Acer</Manufacturer><Version>V3.16(DDR3)</Version><SMBIOSVersion major="2" minor="6"/><Date>20110422000000.000000+000</Date></BIOS><HWID>84CF0000018400F4</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>ACRSYS</OEMID><OEMTableID>ACRPRDCT</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Starter edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_SLP channel
Activation ID: 1d90c7cc-f3cc-4c2f-9650-7ac451fc73eb
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00342-00190-498-271483-02-1033-7601.0000-1332016
Installation ID: 011441073554854494669145921503013020570625279741755596
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: HGRKB
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 5/12/2016 6:22:47 PM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
ActiveX: Not Registered - 0x80040154
Admin Service: Not Registered - 0x80040154
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT PmRef CpuPm
My System SpecsSystem Spec

12 May 2016   #4

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi FoF,
Youve got a bad set of intel drivers,
follow the link below and install the 4th blue box drivers, enu version.

reboot rerun the Mgadiag and all those file mismatches shoul be gone, and away you go.

My System SpecsSystem Spec
12 May 2016   #5

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

missed 1,
If the activeX, is still returned as not registered run KB971033.

My System SpecsSystem Spec
12 May 2016   #6

Windows 7 32 or 64 Bit

I just tried to install with the Intel Update Manager, but I cannot seem to get anywhere with it that way even though it seemed to have downloaded the updates, however when I click INSTALL one disappears as if it were installed but nothing comes up not even the administrative prompt which would be an indication that it want to install then my pro wireless drives read as failed. I tried re-booting, and attempted to try the Intel Rapid-store Utility again, but then got the same thing, and still shows ActiveX as unregistered. You wouldn't know exactly were I could find the link for KB971033? I know that there are privacy issues concerning this update, and even though I do not use a Pirated Copy I am still not sure if I really want to do that because it seems apparent to me that it could have been set up like this to give people no choice to use KB971033 , but then again I could be wrong. Also i remember trying the latest Patch for the Windows Update Agent I believe, but did not work.

I now remember how I did manage to install updates inside of Windows 7 Starter though it was through a third-party update program, but then after that Windows Update I believe would still not find all of the updates. and I would rather not have to use a third party program as my only option to install updates.
My System SpecsSystem Spec
13 May 2016   #7

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

not heard of anyone having problem downloading those drivers.
Lets try a different way
Your comp should have an Acer update GUI, for all drivers use that, if not just go to the support/drivers page on the Acer site for your model and use those, check all the other drivers as well, include BIOS.

For the KB971033 do it via MS link,

My System SpecsSystem Spec
19 May 2016   #8

Windows 7 32 or 64 Bit

First I tried a manual download/install of my Graphics/ProWireless Adapter, and thenI tried that patch [KB971033], but got this from the Windows Update Standalone Installer: "Installer encountered an error: 0xc8000247"

I am wondering if it has something to do with the Digital River ISO or something, but I doubt it because I am getting this on another computer that was installed with a factory restore partition. I sure hope this is not some kind of ploy to switch people over to windows 10 because quite frankly I don't want it -,-; .

If anybody has any other suggestion that might help then please feel free to make it.
My System SpecsSystem Spec
19 May 2016   #9

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

please follow these instructions

Open an Elevated Command Prompt
Run the following commands

REN C:\WINDOWS\SoftwareDistribution SDOLD

wait 15 minutes, and reboot
then wait 10 minutes, and open Windows Updates, and run a Check for Updates.

Attempt to install only the KB971033 WAT Update

what happens?

My System SpecsSystem Spec

 Windows 7 Starter Install (Digital River),CANNOT UPDATE wucitux.dll

Thread Tools

Similar help and support threads
Thread Forum
Why I can't download Windows 7 Profesional 32 bit from Digital River ?
A few days ago I wanted to download Windows 7 Profesional 32 bit iso from Digital River. It started to download and then it stopped to download at 10.9 mb. I tried to download it with Free Download Manager, Internet Download Manager, DownThemAll but it also stopped at 99%. This problem is on all my...
Network & Sharing
Can't find Activation Key for Windows 7 ISO from Digital River
I first purchased Windows 7 Home Edition (32-bit), then upgraded online to Windows 7 Pro (32-bit). The hal.dll corrupted and I couldn't fix the problem because I only had the Home Edition discs. Several sources in Forums advised me to fix the problem using a boot disk from an ISO downloaded...
Windows Updates & Activation
What is Digital River
So I last night I heard someone talk about Windows 7 Digital River. I have never heard of it before. I know its links to download Windows 7 but what is the point of it. I found a link that lets you download them but still don't understand what they are for.
Chillout Room
For those who purchased Windows 7 from Digital River
Microsoft has confirmed a problem that hundreds of users have reported with downloading Windows 7, according to its support forum. The company is currently investigating the reports, but has not yet come up with a solution. Microsoft confirms Windows 7 upgrade install snafu
Installation of Windows 7 from digital river download
I've just registered to get a copy of windows 7 pro 64 bit when its been released from the UK student program and am wondering what format the download will be in. My friends who have got their copies using the MSDN AA have had theirs as iso files which they have been able to burn and install from...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App