Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Acer E1-510 UEFI - Installing Windows 7

30 May 2016   #11

Ubuntu 16.04 x64

In other words, I can't?

My System SpecsSystem Spec

 Acer E1-510 UEFI - Installing Windows 7

Thread Tools

Similar help and support threads
Thread Forum
Install hangs up on ACER windows 8 UEFI laptop
Original drive went bad. No backups or restore available Originally an windows 8 machine and went to 10. Trying to install windows 7 pro 64 bit via DVD so I can get back to 10 1. In UEFI mode it will not get past the windows logo 2. in legacy mode I can get to the disk format and selection...
Installation & Setup
Error on installing Windows 7 with UEFI USB
Hello everyone! I bought a new custom built gaming PC an I've been trying to install Windows 7 for hours. I've been trying to install Windows 7 via a 4GB USB drive. I didn't buy an optical drive. Here's what I've tried: 1) Make a bootable USB drive following this: ...
Installation & Setup
Acer TimelineU M5-581T| UEFI| Windows 7 install hangs at Logo
hi, i am having a peculiar problem with my newly purchased Acer TimelineU M5-581T laptop. it has 20GB SSD and 500GB HDD and UEFI MB also supports legacy BIOS. it came with Windows-8 pre-installed and had a single drive C:. i needed to partition it and had created drive D: with windows disk...
Installation & Setup
Installing Win 7 UEFI on a Windows 8 Computer
So I recently purchased a Lenovo y480, along with a new hard drive to replace the rather slow 5400 rpm stock drive it came with (the new drive is a 7200 rpm Seagate if that is relevant). I wasn't a big fan of the time I spent playing around with windows 8, so I figured when I got the new drive I'd...
Installation & Setup
installing windows 7 in new UEFI motherboard
I just upgraded my motherboard and cpu to asrock H77 Pro4-M mobo intel core i5 3550 the problem is I can't install windows 7 which I'm guessing is because of the UEFI but I can't be sure as this is my first time upgrading except for the storage more HDDs I went into the UEFI menu and...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App