Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Options for recovery/reinstall of pre-installed 7 won't boot?

02 Mar 2017   #1
treehouse

Win 7 Home Premium x64 SP1
 
 
Options for recovery/reinstall of pre-installed 7 won't boot?

Hi, I appreciate the forums very much. I've been doing lots of research trying to fix my Win7 Home Premium x64 on a Toshiba Satellite C660, which suddenly failed to restart. I thought, before I give up and install Linux on it, people here might have some ideas. The laptop was given to me by my son-in-law, who didn't keep any media, and I failed to make a recovery disc or any full backups of the system. It was in a dreadful state, and I spent ages clearing it of garbage, and gradually got it running sweet. Avast and Malwarebytes were happy, until this error. It was grinding to a halt, which I blamed on my having too many tabs open in Firefox and its 2GB memory, exited things and did a restart, but instead there was a brief error message which I think said something like "...failed to boot...", and that was that.

It starts up the screen with the options to start normally or repair, with the default to repair selected and the countdown. If I try to start Windows normally, it gets as far as the progress bar and animated logo, then just hangs. If I opt to repair, it gives the "Loading files" progress bar, completes that, gives a black low-res screen with a working mouse cursor, but then does nothing more. I can start it in Safe Mode, whereupon it loads a list of system files, then hangs with a "Please wait..." or something (it's been a while) at the bottom. Waiting in any of these situations doesn't do anything except the normal start will often automatically re-boot again and we're back to square one.

I'm pretty sure it's a pre-installed version, probably from Currys/PCWorld, and here's where it gets annoying. The product key on the base has everything except about the last two characters, which have rubbed off. I've been through lots of options to extract it from the registry, and have succeeded finally, but putting this into the installation ISO download page on Microsoft says it's invalid. I've also downloaded an ISO from Microsoft, following complicated instructions for hacking into the Win10 delivery page, which involved copying some code into the browser console to reveal a load of other versions. It downloaded. I burned it. I set the boot options. It booted. It went to "Loading files..." and seemed to load more, because it took a bit longer before hanging in a low-res screen with a mouse pointer.

I don't suppose it matters, but I used Magical Jelly Beans Key Finder, after copying the Windows/system32/config/ dir to a pen drive to load the hive from that Windows location (incidentally, you have to create the path and point it to the Windows directory, or it won't read it).

I'm guessing the slim options left might be -
Can PCWorld help? - actually, I'll phone them tomorrow and find out!
Are Toshiba helpful in sorting this kind of thing out? - I'll try, obviously.
Or do the symptoms give you any idea how to fix it?

If the key from the registry doesn't verify because it's an OEM pre-installed job, does that mean that the incomplete one on the base would be valid? Probably a futile question, since I don't think reading most of a product code to a M$ rep will get me very far. I could try to hack it on the download page, trying something like 36^2 variations! Hmmm. Autohotkey...


My System SpecsSystem Spec
.
02 Mar 2017   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
Sounds like fun and all but we can not help with the hacking bit forum rules and all
ShowKeyPlus - Windows 10 Forums

MS broke this I believe :/
Microsoft Windows and Office ISO Download Tool
My System SpecsSystem Spec
02 Mar 2017   #3
Megahertz07

Windows 7 HP 64
 
 

- Witch OS came with the Laptop (Vista or Win 7)
- Do you have a COA key stick on the back or under the battery?
If you do have a Win 7 installation disk, boot from it, go to repair, launch a CMD window and type chkdsk C: \f
If the disk doesn't find any bad block or bad sector, my suggestion is to do a Factory recover if you still have the Factory recover partition on the disk.
My System SpecsSystem Spec
.

03 Mar 2017   #4
treehouse

Win 7 Home Premium x64 SP1
 
 

Thanks for those quick replies, ThrashZone and Megahertz07. I actually clicked Post instead of Preview by mistake and couldn't edit as it was being moderated, so I missed a few things I intended to say. It was probably obvious from what I said that I have two (almost) different product keys, the incomplete one off the base and the one Magical Jelly Beans extracted from the USB-loaded registry hive.

I've got an adaptor for the hard drive (who knew my Seagate external drive has a link bit from the mini-USB to the ribbon thing in the drive?), so just plugged it in to the USB on other machines. On Windows machines (my XP and my partner's Win10), the "WINDOWS" (C:/) drive won't actually read (although the D:/ drive "Data" will). My Linux, however, gives no problem, and that's how I've copied the system32/config folder to a pen drive to plug into a Win machine (it's harder to find a Linux program that reads Win registry hives!).

The main thing I forgot to say is that I'd be very happy if I can just continue to use Windows 7 on the Toshiba, whether fixed or freshly installed. I just don't know if there's any way with no media, OEM install and the product key(s) I've got. Which is kind of infuriating, but I guess this is the user's responsibility, to create rescue discs, back up, etc. Thankfully, I have been able to copy my personal data off the drive.

One other really stupid thing I did - part of trying to clean it up and allow it to do backups to the D: drive, which it reported it couldn't do as it was full - was to delete some of the backup data on there.

With the history it's had, a fresh install might be the best option, if I can just prove it's legal!

As for the 'hacking' thing, yeah, if you meant help putting several different keys into the download page, I was half joking and wouldn't expect any help. As a matter of fact, I'm wondering if this isn't too far fetched (and I don't consider it hacking exactly). The label on the bottom is only missing the very last character, reducing the total possibilities to 36, presumably, and there's enough of a faint mark to suggest it might be a 'N' or 'K' - I might try. I've read so many things about product keys lately, but my head's spinning and I still can't say I understand all the ins and outs. Even some of the key finder programs are said to report wrong keys. ShowKeyPlus looks promising and gives some interesting info. MJBKF did show the correct win version, gave "Installed from: OEM media", a product ID, "match to CD key data", the CD key (which M$ rejects), and the registered owner's name (my son-in-law), but it says "Computer name: Advent", for the loaded hive off the Toshiba (working from an Advent XP, so may be a bug).

The 'hacking' into the win10 download page is described here Download Official ISO's of Windows 7, Windows 8.1 or Windows 10 legally and for free - TechFleece - I've no idea if it's actually worked, but it appears to have. It downloaded and I wrote a disc with InfraRecorder, which seems to run like the built-in rescue function, but it hangs just like that too.

So, as well as the problem of not knowing which key if any ought to be valid (but apparently not the full one from the hive), the installation disc I burned doesn't seem to give any options at all, just runs the repair thing automatically. I was expecting the possibility of doing a fresh install from it. I wonder whether it might if the drive was wiped?

I have run a Linux Mint live CD on it, in case it was some hardware problem. As far as I can see, that's working normally and lists the drives, etc.

ThrashZone, your second link to the download tool seems to be broken.

Megahertz07, the sticker is on the case itself.

I'm not 100% sure, but I think it will have had Win7 on it originally. I could ask the original owner, but they long since moved onto iPads and probably don't have a clue. I have no media other than what I've burned myself, and the result of booting that doesn't seem to get me to anywhere where I can try your other suggestions, unless there's some way to run a command window when it hangs in the state I've described, a black low-res screen with a working trackpad and mouse cursor, but nothing else seems to be active.

Many many thanks for your help. I'm off to see if I can type 36 keys into here https://www.microsoft.com/en-gb/soft...nload/windows7
My System SpecsSystem Spec
03 Mar 2017   #5
Megahertz07

Windows 7 HP 64
 
 

- Programs that extract the Win key read the register of the active machine. So if you run it from a different computer, the key you've got is from that computer.
- The key extracted from a OEM computer are generic. Can't use (as long as i know) to do a fresh install and activation.
- On the COA stick you'll find the windows type (Vista or 7) and brand (home, pro etc)
- Did you run check disk?
- If you still have the factory recover partition, you probably can launch from BIOS to reinstall Windows. No need of CD/ DVD's.
- If you aren't able to do a Factory recover, you still can use a Windows installation disk and the COA key to activate.
My System SpecsSystem Spec
03 Mar 2017   #6
treehouse

Win 7 Home Premium x64 SP1
 
 

Thanks Mega. How do you launch the reinstall from BIOS?

The other advice doesn't really apply, but thanks. Certain keyfinders can load registry hives, which is what I did. It gave a different set of data from the immediate result, which is for the local drive. I haven't got the ful COA.

I've had a long online chat with M$. My only option from that angle seems to be to buy a new licence key, which isn't too bad at $40, although Linux at $0 is tempting! I suspect the agent I talked to could in fact find the product key, but didn't want to, to get me to spend the dosh. To be fair, it probably would have been tricky, too. She said that it would be the one on the COA, but without the missing last digit, couldn't help. She tried the found one and said it was "already blocked". She wasn't very helpful on what that meant or why it was, but I think it might be the old pre-installation problem.

I've just tried Toshiba.co.uk and input the serial number on their recovery media ordering system (it found my computer data in full, when it was bought, etc.), but then it said I couldn't order the recovery media because the item was too old (2011) or wasn't from the Europe region (which it would be - and I already tried the USA site).

Just for the hell of it, I'm now going to try the installation disk I burned, but with another hard drive from a different laptop that I recently wiped, just to see if it offers to install Win7. With the non-booting HD, it tries to repair it.

I did also try putting a few keys into the microsoft win7 download page with the 24 characters I know and making up the last one. Unhelpfully, it just reports "We've encountered a problem with the validation request," after number crunching for about a minute. Not sure if it's actually checking the key or has recognised that the same IP is trying several keys, which could be hacking of the naughty kind.

Oh well, maybe $40 will be worth it. I do a bit of windows programming, so a Win7 machine would be quite useful.
My System SpecsSystem Spec
03 Mar 2017   #7
Megahertz07

Windows 7 HP 64
 
 

Found this:
"Warning: All data on the hard drive will be erased. Back up any important data before proceeding. Make sure the computer is connected to a power supply and do not switch it off or restart during the process.
1) Hold down the power button for ten seconds to switch off your machine
Please note: Holding down the power button on the machine forces it to switch off. Any unsaved data will be lost.
2) Press and hold the zero key and at the same time, tap the power button once to switch on your notebook
3) When the machine starts beeping, release the zero key
4) When prompted by the warning screen, select Yes to continue with the system recovery
5) Select Recovery of Factory Default Software and click Next
6) Select Recover to out-of-box state and Click Next again
7) Click Next to Start the recovery"

It will Format your HDD so you're going to loose all your data on it.

You can download the MS downloader to have a Win 7 OEM installation disk. Use the COA Key to install and activate.
https://www.heidoc.net/php/Windows%2...Downloader.exe
Choose Win 7 (home, pro etc) OEM iso.
My System SpecsSystem Spec
08 Mar 2017   #8
treehouse

Win 7 Home Premium x64 SP1
 
 

That zero-click start thing is interesting, giving access to a memory diagnostics test amongst other things, but on my system it didn't have an install option - probably because it hasn't got the factory recovery files or can't access them. I ran the memory test, which said it would reboot and report, but it didn't report, just went back to the boot error menu, again, not surprising.

The disc I burned is ok - it offered to install Win7 on the other laptop with a wiped drive, so it'll probably do the same on the Toshiba once I wipe that. Presumably it detects that Windows is there and just automatically tries to repair it.

...I've finally got a resolution to this. It took three conversations online with Microsoft reps, two product key finders (actually these were probably unnecessary, but might have added to how seriously they took the issue) and a photograph of the COA with a slightly rubbed edge causing it to have a missing character, but they gave me a once-only product key with which to activate Windows 7 again when I resintall it!

I had almost given up and decided to buy the product key, but then I thought I'd just try with ShowKeyPlus, which found the "original" key in addition to the one Magic Jelly Beans found, so I asked them to check that, explained all the previous discussions and complained that I had a legal copy of Windows and surely they must be able to verify it from all the information I'd given them (despite none of this being strictly enough, probably). The original key, I was told, was for Vista, so it must have been upgraded to 7 from that. It might just come down to which agent you happen to get and how you butter them up!

I'll mark this as solved. Thanks again for your help.
My System SpecsSystem Spec
Reply

 Options for recovery/reinstall of pre-installed 7 won't boot?




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 Error Recovery and Advanced Boot Options
Are the startup repair files installed on the hidden partition? I found this extract from a book does anyone agree with this? I unplugged an system with a 100MB hidden partition which contains the startup repair files but i recieved Figure 8.16 and not Figure 8.17. anyone with any info on this???...
Installation & Setup
Cannot Boot, OS Not in System Recovery Options
I'd recently done a system update and believe that some of it didn't install properly. After perusing and attempting various solutions, I think there are some problems with my boot manager (and maybe some other disk issues). When I try to repair using the Windows 7 disk, my System Recovery Options...
General Discussion
Windows 7 cannot boot System Recovery Options
Hello. I have a Toshiba laptop in which I installed my copy of Windows 7. Recently, it has not been able to boot: it just restarts when trying to. I tried the typical things: booting to safe mode, etc. but they all do the same. So I tried to sin the System Recovery Options, first from the Advanced...
Performance & Maintenance
Need System Recovery Options Advice - will not boot
Been playing with this for about a week... Acer Aspire laptop - one day it booted with the following PXE-E61: Media test failure e, check cable PXE-M0F: Exiting Broadcom PXE ROM No bootable device - insert boot disk and press any key Then it stopped. I put in the CD, selected Repair and...
General Discussion
Windows 7 won't boot and Recovery options don't work
I have a Lenovo G560 0679 series laptop, which i believe is a 64 bit system. Few months ago, my comp shown some blue screen and gave me boot up issues. My friend has been able to help me fix it a few times (he said he simply just let start up repair do its own thing). however, this time, he is away...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App