Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sysprep with Unattented File

21 Mar 2017   #1
giobaxx

Windows 7 PRO 64 Bit
 
 
Sysprep with Unattented File

Hello guy
I'm trying to create a custom Image in order to Install Windows 7 Pro fastly. I have Captured the Image but when i Try to Install i receive the Following below and i don't undestand where i made mistake:

..Windows Could not parse or Process unattend answer file for pass (Specialized)......

I have used an answered file to sysprep the system but not during the installation. I started from a clone of a previous installation and after i have restored the clone i run sysprep in audit mode, i have delete the user created in the previous installation and i started to customize the system with the Following Step:
  • I Have Personalized Desktop with Desktop Wallpaper and the Wallpaper for the Logon Window
  • I have added some link on Desktop and Installed/Updated some Software and the Antivirus
  • Then i have Rebooted the system in audit mode again

In Order to copy the Customization to the Default User i have created the Following Unattended File myprofile.xml(below)

Code:
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="specialize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <CopyProfile>true</CopyProfile>
        </component>
    </settings>
    <settings pass="generalize">
        <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SkipRearm>1</SkipRearm>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="catalog:c:/win7usb3/sources/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
I have also Configured the registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\Sysprep\Settings\sppnp set PersistAllDeviceInstalls to 1 in order to mantain all drivers. Then i run the following comand:

sysprep /generalize /oobe /shutdown /unattend:E:/myprofile.xml

Then i have Captured the Image with dism but when i tried to install that image i receive the error ..Windows Could not parse or Process unattend answer file for pass (Specialized)......

I also tried to restart the system where previously i ran sysprep and i would have expected to perform oobe setup from windows Installation but i receive the same error..
I saw that if i sysprep the system without unattend file i don't receive any error....where i'm wrong, The problem could be that i didn't started from a clean installation?


My System SpecsSystem Spec
.
Reply

 Sysprep with Unattented File




Thread Tools




Similar help and support threads
Thread Forum
Sysprep answer file
I have been reading a lot about imaging lately and I am starting to get it down. Somewhere in my searches I thought I read something about a program that will pull your system configuration and settings for you and create a sysprep answer file from it. I have read so much in the last few days...
Installation & Setup
SysPrep Help?
I made a sysprep file with Windows WAK and it giving us issues. We get a "A fatal error occurred while trying to sysprep the machine." This happens when it is "Processing cleanup phase Sysprep plugins..." Here is our file. <?xml version="1.0" encoding="UTF-8"?> -<unattend...
Installation & Setup
Sysprep - Windows 7 - unable to sysprep image that joins domain
Good morning all: Below is my unattend.xml. I am using the sysprep + win7 for creating virtual machines in Red Hat Enterprise Virtualization 3.0 but having difficulty getting them to auto-join the domain. My sysprep progression proceeds normally and completes. The initial boot of the image...
Virtualization
win7 after sysprep reboot always with sysprep box
hello, 1st sorry for my english (i'm french guy). I made a sysprep and all parameters are corrects. but after the reboot I have always the sysprep preparation tools box. for me the sysprep is correct but I don't know what's happended. in attachment my unattend.xml
Installation & Setup
Sysprep
Can you do Sysprep on Windows 7 like on XP? OK so you do a clean install of W7. Then install all of your software. Now you want to set it up to clear all of the information. That way when you sell it or give it away, the person turns it on is goes through the initial walk-through process...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App