Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: NUC + Win7 / No Usb3 Drivers / Stuck At Username Screen.

09 Apr 2017   #1

Win7 Ultimate x64
NUC + Win7 / No Usb3 Drivers / Stuck At Username Screen.

I bought a NUC6i3SYH, Samsung 850 ssd and 4gb Kingston Ram. I can get windows 7 installed but i get stuck at the screen to select a username and password, my wireless keyboard and mouse cease to work and also my wired usb keyboard does not work.

Firstly should i use UEFI or Legacy mode for booting my NUC with win7?

I had a thought that i could plug the Samsung ssd from the nuc into my htpc or laptop, get past the username screen, install the Intel usb3 drivers, remove and refit the hard drive to the nuc. Would this method work?

I want to install win7 from my usb2 external drive. I am aware that i need to integrate the usb3 drivers into the windows install files on the usb drive. The Microsoft usb download tool does not recognise my usb drive. Rufus fails too but i read it could be a corrupt iso, i can use Rufus it to just format the drive ok but when i try to copy the image to the usb drive with Rufus it fails. The win7 image i have does have a load of updates integrated so it may well be a problem with the iso.

I got win7 installed by making my usb drive bootable using the command prompt. I disabled UEFI boot mode. I used the Intel usb tool which integrates the usb 3 drivers with your win7 install files on the usb drive. It must work because i installed win7 up to a point but the usb devices stopped working when it comes to the screen to enter a username and password. I found a post on the NUC forum and there is a bit where someone says the Intel usb tool does not work with my model of NUC6.

This link has a very long winded way of integrating the usb3 drivers manually but it is very long winded, a few people seem to think this works Installing Windows 7 on the NUC5CPYH or NUC5PPYH (Braswell NUC) The NUC Blog

My System SpecsSystem Spec
09 Apr 2017   #2

Win7 Ultimate x64

I have got round this problem. I formatted the drive and extracted the win7 iso files to the usb drive, i then installed win7 to the NUC, i got the same problem again, this time i removed the Samsung ssd and put it in my laptop which has a 5th gen i7 cpu, anyway i was able to use the keyboard and trackpad and install the Intel usb3 drivers, i refitted the drive into the NUC and when i started windows the usb mouse and keybard now work. Not an ideal solution but it worked.
My System SpecsSystem Spec
29 May 2017   #3

Windows 7 Pro

You could also have used dism to install the drivers in the windows iso. Maybe it will help in the future. Works also for the new raid-only laptops (dell xps for instance) and so on.
My System SpecsSystem Spec

29 May 2017   #4

Windows 7 HP 64

Was the USB keyboard attached to the USB 2.0 or 3.x?
Win 7 installation disk has two "programs" - Installation and maintenance". The Intel usb tool only load the USB 3.x into the installation wizard. It doesn't install to the maintenance wizard and to the installation itself, so after you boot into installed windows, it won't have the USB 3.x drivers.
If you want to learn how to install the drivers into all options, read my tutorial.
Create a Windows 7 USB flash installation with new drives for new MB's - Windows 7 Help Forums
My System SpecsSystem Spec
31 May 2017   #5

Win7 Ultimate x64

Yes i was using the usb 3 ports as my NUC only has usb3. I have bookmarked this page and when i come to do an install again in the future i will have a read through your tutorial. My workaround was not ideal but it worked and it has not given me any negative effects. Thanks for your help guys.
My System SpecsSystem Spec

 NUC + Win7 / No Usb3 Drivers / Stuck At Username Screen.

Thread Tools

Similar help and support threads
Thread Forum
sfc /scannow won't run | stuck on win7 logo screen
Hi everyone, When I run sfc /scannow I get to see "this process will take some time." and a blinking cursor whereupon absolutely nothing happens; this screen stays on forever. My Lenovo Y500 won't boot into win7 anymore all of a sudden and after puzzling around for several hours now I'm close...
Performance & Maintenance
WIN7 wont continue to desktop,get stuck in log in screen,cursor moving
my Acer aspire 4750G uses windows 7 64 bit it boots and get stuck in the log in screen.. I have no password but I have two users, so I have to click on which to log into.. the cursor is moving , but when I click on the User, nothing happens.. the cursor is still moving, but there is no...
General Discussion
Installation Problem - Stuck on Username/Password Screen
Hello, I am stuck on the Username/Password screen that has appeared during the installation of Windows 7 Home Premium. This is an install over an existing version of windows, but is not an upgrade of that version. I enter a Username and Password and I get the error message: "The specified...
Installation & Setup
Screen Resolution Stuck @ 640x480, Can't find drivers
Hello! I just did a fresh install of Windows 7 on my old Dell Dimension 2400, hoping to breathe some new life into the thing. Everything went smoothly except the screen resolution is stuck at 640x480. The monitor, a Dell E172FPt, was running on Generic PnP drivers, so I attempted to update...
Win7 logon screen stuck on 'Please Wait' no Safe Mode
Ok guys, so i've cloned an image from my old laptop to my new Seagate 7200.12 500GB HDD and using Paragon Virtualization Manager P2P made it ready to boot off new hardware. I've put it in my new tower system, installed all the drivers and bundled software and it's been running fine since building...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:35.
Twitter Facebook Google+