Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 UEFI and Fast boot.

28 Nov 2017   #1
Graveflower

Windows 7 Ultimate x64
 
 
Win 7 UEFI and Fast boot.

Before I get into my issue, I would like to state I have read many forum posts and none seem to emulate the issue I have been seeing, secondly, I'm new! Hello!

NOW THEN.....


I have experienced something unusual that I cannot explain.

Let me start by saying that YES I know that secure boot is not designed to run on win 7.

I had been running win 7 in UEFI, secure boot enabled and CSM enabled and everything was going just fine for me. Until I needed to reinstall the OS. I left all my BIOS settings as they were. I installed windows from dvd selecting the UEFI option for my dvd drive. This all worked fine, windows installed, I got my drivers on, got some windows updates done without any issue so I didn't think I would encounter any trouble, then after one of my reboots, I don't remember what I was doing at the time, I got the little red box, secure boot violation or whatever it is, just telling me it wasn't happy. I went into BIOS and disabled secure boot, set the legacy drivers to load before UEFI drivers and windows is fine, although it is definitely slower.

What caused this? Is there something I can do to get UEFI working again ?

If it matters, my OS is installed onto a samsung 840 pro SSD 256gb (sata3)


My System SpecsSystem Spec
.
28 Nov 2017   #2
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Hi Graveflower, welcome to the Forum.

Secure Boot wont work with Windows 7, neither will Fast Boot, so you need to enter the BIOS & disable both those items.
My System SpecsSystem Spec
28 Nov 2017   #3
Graveflower

Windows 7 Ultimate x64
 
 

Nevermind, I found out its due to the windows update KB3133977 that prevents it from working. Secure Boot and Fast boot, do infact work in windows 7 if you are running an ASUS motherboard. I have used it for quite sometime without flaw. I will go and reinstall my OS and hide this update and I suspect I will be fine.
My System SpecsSystem Spec
.

30 Nov 2017   #4
mrjimphelps

Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)
 
 

Please let us know how it all turns out.
My System SpecsSystem Spec
04 Dec 2017   #5
Graveflower

Windows 7 Ultimate x64
 
 

I was indeed correct. I went to bios and enabled fast boot and also CSM. I reinstalled windows using the UEFI option for my optical drive and everything went fine. I ran windows update and looked through the list and hid update KB3133977 and installed all other updates (minus the telemetry updates) and rebooted and everything worked as normal and I have been using secure boot and fast boot now for 5 days with zero issues.
My System SpecsSystem Spec
04 Dec 2017   #6
Megahertz07

Windows 7 HP 64
 
 

When you set CSM to enable, Secure boot is turned off. Win 7 has no digital signature and does NOT work with Secure boot.

Next time you do an installation, use the SP2 offline updates and secure updates only.
MS releases SP2 for Windows 7 - Windows 7 Help Forums
My System SpecsSystem Spec
09 Dec 2017   #7
Graveflower

Windows 7 Ultimate x64
 
 

I know its not supposed to work on win 7, but on asus boards CSM works as a work around and secure boot can be enabled and fast boot enabled. Performance is better with this setup than just turning off secure boot and fast boot
My System SpecsSystem Spec
Reply

 Win 7 UEFI and Fast boot.




Thread Tools




Similar help and support threads
Thread Forum
STILL cannot boot a non-UEFI CD on my UEFI Win 7 64-bit - any fix ??
- A year later, and I discover again that I STILL cannot boot from a non-UEFI CD on my UEFI Win 7 Pro SP1 64-bit Dell Optiplex 7010 MT even though "Enable Legacy ROMs" is ENABLED in the BIOS and Secure Boot is OFF. My original details are here - Cannot boot from CD-DVD in LEGACY mode - NOT...
General Discussion
UEFI hard drive boot order and boot menu are completely ignored
I have a bit of a puzzle, and I don't know whether to blame the motherboard maker, Microsoft, or -- this is a really distant third choice, obviously -- myself. (That being said, UEFIs and GPT drives are new to me, so that distant third choice might not be as distant as I'd hoped.) I recently set...
PC Custom Builds and Overclocking
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
UEFI boot keeps changing; UEFI/Win7 handshaking confusion
Trying to understand handshaking between UEFI & Win 7. Have Win7 Pro sp1 64 installed on SSD, mb=Asus F2A85-V Pro. Example: boot to flashdrive to do Acronis backup of SSD; remove SDD, insert spinner; boot again to flashdrive to do Acronis restore to spinner (to test backup); remove flashdrive, boot...
Installation & Setup
Boot UEFI from wake on lan, or convert UEFI MBR to legacy.
Hi all, Currently having a wake on lan issue with a certain computer. The machine is setup correctly but the windows boot information is stored in a 100mb UEFI partition, and when the computer wakes on lan, it will not boot windows, just sit at a blank screen. When it wakes on lan it is...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:41.
Twitter Facebook Google+