Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 Installed UEFI, but can't boot without Legacy enabled

29 Dec 2017   #1
NAK91

Windows 7 Pro x64
 
 
Win7 Installed UEFI, but can't boot without Legacy enabled

I installed 7 as UEFI months ago and needed to restore from an image. When restoring from image I could not boot from the Windows 7 SP1 disk without legacy enabled... it would sit at the "Starting Windows" screen with the graphics pulsating (not frozen) and ultimately do nothing.

So, I booted with legacy mode enabled and restored. My OS drive is installed as EFI and has an EFI partition, but I can't boot without legacy mode enabled. Why??


My System SpecsSystem Spec
.
29 Dec 2017   #2
Megahertz07

Windows 7 HP 64
 
 

What program did you use for restoring the image to the HDD?
Did you do a Disk restore or only a partition restore?

Open Disk management (C:\Windows\System32\diskmgmt.msc), Maximize the window, expand the columns so we can read them and with the sniping tool (%windir%\system32\SnippingTool.exe) take a snapshot of the hole window.
Post it here as an attachment. Use the paper clip - Browse to the file - upload
My System SpecsSystem Spec
29 Dec 2017   #3
NAK91

Windows 7 Pro x64
 
 

I just used the standard Windows 7 utility for imaging.

I've downloaded Macrium Reflect free and will start using that soon. I'm thinking of installing Windows 8.1 with Start8. I never wanted to touch anything after 7 because I hated the UI, but 8 seems like it would be ok now with the aforementioned UI software and I would have the benefits of quicker booting and more reliability with UEFI.


Attached Thumbnails
Win7 Installed UEFI, but can't boot without Legacy enabled-diskmgmt_.png  
My System SpecsSystem Spec
.

29 Dec 2017   #4
Megahertz07

Windows 7 HP 64
 
 

It seems to me that you're booting disk 0 as UEFI.

You didn't expand the columns and I can't read the Status Column.
Please make another snapshot, edit the previous Post (#3) and replace the image.
My System SpecsSystem Spec
29 Dec 2017   #5
NAK91

Windows 7 Pro x64
 
 

Another snippet shows my OS disk (disk 0) and image disk (disk 1) with GPT partition style, but shows dvd rom as MBR... not sure if that has any meaning.


Attached Thumbnails
Win7 Installed UEFI, but can't boot without Legacy enabled-diskmgmt2.png  
My System SpecsSystem Spec
29 Dec 2017   #6
Megahertz07

Windows 7 HP 64
 
 

You're booting disk 0 as UEFI!!!
Win 7 isn't compatible with secure boot that is the default for Win 8.x and Win 10.
To install win 7, secure boot must be disabled.
Depending on the BIOS manufacturer, it can be made by setting secure boot = off, some are by setting OS=other and some are by setting CSM=on.
Yours seems to be setting as Legacy.
I don't have a way to see the Dell BIOS options but if you want to take a picture on the settings I can have a look.
My System SpecsSystem Spec
29 Dec 2017   #7
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Why does Disk 1 have 7 partitions labeled SYS, was that done on purpose ?

W8.1 ?

Could you right click on the small box to the far left of Disk 0, then click Properties, then Volumes.

Then post a snip.
My System SpecsSystem Spec
Reply

 Win7 Installed UEFI, but can't boot without Legacy enabled




Thread Tools




Similar help and support threads
Thread Forum
Difference with UEFI or Legacy BIOS in Win7 64bit
Well, I have 3 questions before I proceed with new clean Win7 installation 1. Action before Win7 UEFI install "Disable secure boot", but after installation, should user "Enable secure boot" or will this lower security continue and give a vulnerable system ? 2. Is it really a big difference...
Installation & Setup
Win7 Installation via USB failing on UEFI and Legacy
I have read the tutorials and the many posts on this topic so apologise for creating another post on an old topic. I am hoping I am being an idiot and have just missed something really simple. Scenario 1: Created UEFI bootable USB, using Rufus, configured BIOS with CMS disabled and Secure Boot...
Installation & Setup
Windows 7 Installation CD - Can boot in Legacy mode but not in UEFI
When i try and boot my Windows 7 x64 DVD in UEFI mode my computer completely skips it and boots my hard drive. However when I boot in legacy mode i can boot the CD but i get the error 'Windows cannot be installed to this disk. The selected disk is of the GPT partition style'. I'm assuming i get...
Installation & Setup
Install Win7 w/Legacy Oprom enabled for installation - then disable?
Hi I have a brand new Dell Inspiron 15 7548 series that I want to quad boot with 8.1 (as main OS; will be using the OEM OS it came with) , 7 Ultimate, 10 Tech preview and Fedora 21. Because I can ;) I have figured out that i CAN install windows 7 in UEFI / GPT mode, but the "legacy Oprom" needs...
Installation & Setup
Boot UEFI from wake on lan, or convert UEFI MBR to legacy.
Hi all, Currently having a wake on lan issue with a certain computer. The machine is setup correctly but the windows boot information is stored in a 100mb UEFI partition, and when the computer wakes on lan, it will not boot windows, just sit at a blank screen. When it wakes on lan it is...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:49.
Twitter Facebook Google+