Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: MBT Install Seems Impossible on UEFI Boot with Legacy Mode

03 Mar 2018   #1
sometimeshandy2

Windows 7 Ultimate x64
 
 
MBT Install Seems Impossible on UEFI Boot with Legacy Mode

I am trying to install Windows 7 on an HP Spectre x360, but I've run into a blocking snag and I'm hoping for some help. I can run veracrypt in full disk encryption without an MBR partition. When trying to force an MBR parition using command prompt, I get the error "On EFI systems, Windows can only be installed to GPT disks." I do have legacy booting on, and secure boot on.

I have realized that my boot order in the BIOS has two options for my USB drive, UEFI mode, and non-UEFI mode. So one would think I would need to boot into the non-UEFI mode of the Windows Installer. But that fails every single time. Totally black screen with the error:
"Reboot and select proper boot device
Or insert boot media in selected boot device and press any key"

I tried to use a Lubuntu boot USB to get around this (failed), but noticed that the MBR USB of the Lubuntu installer also encounters the same error when trying to boot to its non UEFI counterpart. It has to be booted in UEFI mode.

Is this BIOS locked down? Or what is going on? Seemingly, it is impossible to set up an MBR partition on this table.

After extensive searching, I came across this thread My adventure with changing a GPT / UEFI Windows 8 installation to MBR that details a method for cloning and drive swapping, however then if you run into any situation which requires the USB you'd be screwed.


My System SpecsSystem Spec
.
06 Mar 2018   #2
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Why is Secure boot on ?

Did you clean the drive with Diskpart ?

Recreate your usb installer again, this time use Rufus and choose to create a MBR installer for BIOS or UEFI (it`s in the options)


Attached Images
MBT Install Seems Impossible on UEFI Boot with Legacy Mode-rufus.jpg 
My System SpecsSystem Spec
06 Mar 2018   #3
sometimeshandy2

Windows 7 Ultimate x64
 
 

I made this post in a hurry and had a couple of typos, first the title should have said MBR, and secure boot is off

I tried recreating the installer multiple times before this, but it seems like the problem may have been actually been something that I didn't notice in any of the forums before. The File System needed to be set to NTFS rather than FAT32. Seems to be working fine now with that change! Thank you for your picture!
My System SpecsSystem Spec
.

Reply

 MBT Install Seems Impossible on UEFI Boot with Legacy Mode




Thread Tools




Similar help and support threads
Thread Forum
Win7 Installed UEFI, but can't boot without Legacy enabled
I installed 7 as UEFI months ago and needed to restore from an image. When restoring from image I could not boot from the Windows 7 SP1 disk without legacy enabled... it would sit at the "Starting Windows" screen with the graphics pulsating (not frozen) and ultimately do nothing. So, I booted...
Installation & Setup
New Install, Unsure About SSD Wipe and USing UEFI vs Legacy
Installing 7 x64 (single boot) on a new XPS 13 with 10. I successfully created a USB media that appears to launch fine in legacy mode, but is not detected in UEFI mode. I was reading the clean install thread and didn't know if I should not go the legacy route for any reason. Also, I have...
Installation & Setup
Convert 7 install From UEFI To legacy
My system has several drives, two of which are 4TB drives. The two 4Gb drives are using GPT partition schemes. However, I'm booting off of a 240GB SSD which is using a MBR scheme. When I installed my current motherboard, I did a fresh install of Windows 7. I didn't know much about UEFI,...
Installation & Setup
Windows 7 Installation CD - Can boot in Legacy mode but not in UEFI
When i try and boot my Windows 7 x64 DVD in UEFI mode my computer completely skips it and boots my hard drive. However when I boot in legacy mode i can boot the CD but i get the error 'Windows cannot be installed to this disk. The selected disk is of the GPT partition style'. I'm assuming i get...
Installation & Setup
Boot UEFI from wake on lan, or convert UEFI MBR to legacy.
Hi all, Currently having a wake on lan issue with a certain computer. The machine is setup correctly but the windows boot information is stored in a 100mb UEFI partition, and when the computer wakes on lan, it will not boot windows, just sit at a blank screen. When it wakes on lan it is...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:43.
Twitter Facebook Google+