Update your Win 7 installation media


  1. Posts : 2
    windows 7 x64
       #1411

    SIW2 said:
    Sounds like you have what you need..
    Hello,
    What if I only need to install all the drivers mentioned, in boot.wim, install.win and winre.wim?
    Thank you.
      My Computer


  2. Posts : 16,226
    7 X64
    Thread Starter
       #1412

    You might also need the driverframework update, sha2 updates and import the registry blobs depending on which drivers you need.

    It is easier to run 7updater without simplix pack if that is what you want. It reconstructs winre for you as well.
      My Computers


  3. Posts : 2
    windows 7 x64
       #1413

    SIW2 said:
    You might also need the driverframework update, sha2 updates and import the registry blobs depending on which drivers you need.
    It is easier to run 7updater without simplix pack if that is what you want. It reconstructs winre for you as well.
    Thank you for your rapid response.
    Yes I understand that.
    What I mean is as follows. I only need to install the AHCI/RAID, USB 3.x supported UASP and NVMe for PCI-e bus M-key drivers and related updates, but nothing else. No any regular Windows updates and "nice" features. Just simple Windows 7 x64.

    I tried a similar solution with many different updates and features and I suspect it affected the Bittorrent client over VPN. The exchange speed dropped 50-100 times with all other conditions being the same, fully installed drivers and these various updates and features. Well, at least exclude this possibility.

    Again thank you very much for your kind and rapid response.
      My Computer


  4. Posts : 61
    The one I am using to register is my Windows 7 Professional x64 one.
       #1414

    Win7fuser said:
    Simplix updatepack7R2 seems to have trouble integrating .Net Framework 4.8 on 32-bit windows 7:

    Code:
    Addon - Microsoft .NET Framework 4.8
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Windows.Input.Manipulations\v4.0_4.0.0.0__b77a5c561934e089\System.Windows.Forms.DataVisualization.Design.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Windows.Forms.DataVisualization\v4.0_4.0.0.0__31bf3856ad364e35\System.Windows.Forms.DataVisualization.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Security.Principal\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Security.Cryptography.X509Certificates.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Security.Cryptography.Primitives\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Security.Cryptography.Primitives.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Security.Cryptography.Algorithms\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Security.Cryptography.Algorithms.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Runtime.Serialization.Primitives\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.Serialization.Primitives.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Runtime.Serialization.Formatters.Soap\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.Serialization.Formatters.Soap.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Runtime.Serialization.Formatters\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.Serialization.Formatters.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Runtime.Numerics\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.InteropServices.WindowsRuntime.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Runtime.Numerics\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.InteropServices.RuntimeInformation.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Runtime.CompilerServices.VisualC\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Runtime.CompilerServices.VisualC.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.DirectoryServices.AccountManagement\v4.0_4.0.0.0__b77a5c561934e089\System.DirectoryServices.AccountManagement.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.Diagnostics.TextWriterTraceListener\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Diagnostics.TextWriterTraceListener.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\System.ComponentModel.DataAnnotations\v4.0_4.0.0.0__31bf3856ad364e35\System.ComponentModel.Composition.Registration.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.Workflow.Compiler\v4.0_4.0.0.0__31bf3856ad364e35\Microsoft.Windows.ApplicationServer.Applications.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.VisualBasic.Compatibility.Data\v4.0_10.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualBasic.Compatibility.Data.dll
    Addon  - copy file error:  Windows\Microsoft.NET\assembly\GAC_32\Microsoft.VisualBasic.Activities.Compiler\v4.0_10.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualBasic.Activities.Compiler.dll
    And when you start the next session you get:
    Attachment 420081

    Looked around and found some leftover files and folders that werent deleted:
    Attachment 420082

    Deleted them and the error goes away and the updater continues to work but .Net Framework 4.8 still fails to copy over - so not installed?

    Edit:
    Seems like ultimate is the only version that has .net framework 4.8 integrated successfully:

    The installation log of UpdatePack 7 / 2008 R2 / 21.8.11Installation start t - Pastebin.com
    ....sooo.......anyone managed to fix this or is this still an issue just for me....?
      My Computer


  5. Posts : 18
    Windows 10 x64
       #1415

    Win7fuser said:
    ....sooo.......anyone managed to fix this or is this still an issue just for me....?
    It worked when I used Win Toolkit and the addon dotNetFx48_<date>_x64.WA

    Sorry that's not a fix for use with Simplix but it does mean the .NET Framework 4.8 can be integrated.


    How to do it:

    Run "WinToolkit.exe"

    Click the button "All-In-One Integrator".

    Press Ctrl+W to and browse to your WIM file.

    Once that's done, double click the listing in the box and this brings up a new window.
    Click "Skip" at the bottom (no preset).

    Click the "Addons" tab, then "Add > Add Addons" at the top.

    Browse to the included file:
    "Win Toolkit\dotNetFx48_<date>_x64.WA"

    Click "Start" at the top to slipstream the addon.

    On my system this went quite fast - it slipstreamed in less than 4 minutes, which is faster than the time it was taking to install .NET Framework 4.8 at first logon, which was the way I used to do it. Also this Addon pack is a more up to date.

    Once it's finished, close the All-In-One Integrator window, then close the Win Toolkit window.
      My Computer


  6. Posts : 16,226
    7 X64
    Thread Starter
       #1416

    7UPv64P on first post. Updated wimlib to wimlib-1.14.3 . Updated bcdbootdisk to v18
      My Computers


  7. Posts : 733
    Windows 7 Pro 64-bit / Windows 10 Pro 64-bit (dual boot)
       #1417

    You beat me to it.
    I was going to ask you after October 2023 "patch Tuesday" if you plan to release a new version.
    I now have a copy and will put it to use after the new Simplix update pack and WA add-ons are released.
      My Computer


  8. Posts : 1
    Win 7
       #1418

    Sup guys,

    first of all thanks a lot for the work that's been put on keeping this thread alive!

    I've managed to successfully update and install Win 7 Professional X64 on newer hardware (13th Gen intel) several times, but been struggling with Windows 7 Ultimate N X64 lately. I use both the regular and the simplix pack and everything works during installation, but upon starting Windows for the first time, none of my USB input devices work and I can't get past the initial setup where you enter a user and a PC name.

    Any help would be much appreciated!

    Cheers
      My Computer


  9. Posts : 21
    windows 7 pro 64bit
       #1419

    SIW2 I have done the update a few years ago successfully . I am doing something wrong this time All I see is error elevated permissions required.
    I am the administrator, right click has no option as admin. user accnt is administrator Me. Ya I want to install to an NVMe HDD on the ITX board You have replied to me about.
      My Computer


  10. Posts : 16,226
    7 X64
    Thread Starter
       #1420

    right click has no option as admin
    type netplwiz in start search

    Update your Win 7 installation media-netplwiz1.jpg

    Update your Win 7 installation media-netplwiz2.jpg

    Update your Win 7 installation media-netplwiz3.jpg
    Last edited by SIW2; 21 Dec 2023 at 00:19.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:05.
Find Us