Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to install Win 7 x64 in UEFI mode on ASUS MoBo (TR4 socket)

1 Week Ago   #11
Megahertz07

Windows 7 HP 64
 
 

As I wrote before, Asus name Windows UEFI as Windows 8 / 10.
You have to try other BIOS configuration related to CSM / UEFI

Silly question, but is your Win 7 installation disk 64 bits? Only 64 bits boots as UEFI.


My System SpecsSystem Spec
.
1 Week Ago   #12
BizkitBoy

Windows 7 Ultimate (x64)
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
As I wrote before, Asus name Windows UEFI as Windows 8 / 10.
You have to try other BIOS configuration related to CSM / UEFI
I believe I am out of combinations. I actually think I tried all of them.
It has to be the BIOS... Asus really screwed me over. Just another gimmick to force people into Windows 10.

Quote   Quote: Originally Posted by Megahertz07 View Post
Silly question, but is your Win 7 installation disk 64 bits? Only 64 bits boots as UEFI.
It is.
It's just that the disc doesn't have the boot folder under the efi folder with the bootx64.efi file.
I don't know if that makes any difference in optical media, or it's just for flash drives.
My System SpecsSystem Spec
Reply

 Unable to install Win 7 x64 in UEFI mode on ASUS MoBo (TR4 socket)




Thread Tools




Similar help and support threads
Thread Forum
W7 + new Asus mobo + UEFI Bios + Safeboot = PROBLEMS!
(Edit: Sorry! Title should read Secure Boot, not Safeboot) Project: All-new hardware (case, PS, mobo, CPU etc etc) with an NTLite-integrated-update W7 on a flash drive. Lots of steep learning curves building this W7 + 200 updates flash drive, but that's finally done. But now I've plugged the...
General Discussion
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
Hard Disk Drive not found in ASUS UEFI BIOS Utility - EZ Mode
Hi there, My sister just bought a new desktop. It was working fine and all. But this morning, she forced shut down a windows update. The next thing happen once it gets past through BIOS is "Reboot and select proper boot device or insert boot media in selected boot device and press a key" So I...
Installation & Setup
Failure to install windows 7 pro x64 on uefi Mobo
Hello all: I have been banging my head on this one for far too long. I have a new custom build with the following specs. Mobo: Asus P8H77-M LE (chosen by customer for built in raid) 1) i5-3330 3GHz LGA 1155 Processor Memory 2) Mushkin Silverline 4 GB sticks (1 Kingston 2GB stick Installed...
Installation & Setup
What's the benefit of UEFI and install Windows in UEFI mode?
I am not sure if this subforum is the right place, if not, pleases help me transfer to the right forum... I recently just build a new setup with Asus P8Z77-V LK, this motherboard comes with UEFI boot and legacy BIOS boot support. So I tested install windows 7 in both mode, and I didn't find...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:48.
Twitter Facebook Google+