Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: dual boot problem > no boot at all

3 Weeks Ago   #1
llkk

x64
 
 
dual boot problem > no boot at all

hi all.

long time win user. i really liked w7, and hate w10.
i got myself an ubuntu but, i still need some windows7. some of my softwares are win only.

i'll just dual boot it.

so, i bought a brand new blank ssd, i sticked my W7 flashdrive installation, made a partition for it in ntfs, and installed it.
so far so good.
so i sticked my ubuntu flashdrive, and installed it on the other partition. in ext4.
works. fantastik.

now, when i power on the computer, grub asked me if i wanted to go ubuntu, ubuntu advanced recovery and such. but no windows.

i found a way to enter windows pressing f11 when rebooting and forcing the system to boot on the win partition.




futher research led me to think it was a mbr/uefi missmatch problem. and grub cant see or access legacy mbr.

so, i tried to convert the first partition to efi. i found a command line to do that.

and there is when the real problems came.

now no matter what i do, i can only access a grub comand line if i want to boot from the hard drive.


i reinstalled w7, and it worked only for one boot. (thou, it was pretty painful to install, the installer refused me the location various times)

i reinstalled ubuntu, and it only worked for one boot.

i reformated everything, and repeated all, still cant do anything.
after a restart, i only get a grub command line. (and i don undestand anything to the grub command line)


even through the bios boot order i cant get to any system



i still tend to think its some mbr/uefi missinterpretation or something, but i dont understand well this magic.


any guru here to point me what i did wrong or what to do to fix this ?




i have other hard drives, but to minimize risk, i unpluged them before everything. at the moment, there is only the system ssd pluged in. i dont care about data loss, there is nothing sensible on that ssd.


My System SpecsSystem Spec
.
3 Weeks Ago   #2
Megahertz07

Windows 7 HP 64
 
 

As you have a UEFI BIOS, you can install as Legacy - MBR or UEFI-GPT.
I would recommend to install as UEFI-GPT. (my computer has Win 7 and Lubuntu on same M.2 UEFI-GPT drive)

On a Legacy - MBR, BIOS looks for a disk, takes the boot sequence to the MBR on the disk that takes the boot sequence to a boot loader, in your case, Grup. Grub can then take the boot sequence to Ubuntu or Windows boot loader.

On a UEFI - GPT, BIOS looks for boot loaders on the Fat32 EFI partitions that takes the boot sequence to a OS on a partition.

The advantage of UEFI - GPT is that the installations are completely independent. You can remove one without affecting the other. You will have a default OS to boot from (set on BIOS) but if you want to boot to the other OS, during POST you press F8 to launch the boot menu and select the other.

You can also install Win 7 and Ubuntu as UEFI - GPT, set Ubuntu as default on BIOS and set Grub to have an option to boot Windows.

So, what you want to do, Legacy - MBR or UEFI - GPT installation?
My System SpecsSystem Spec
3 Weeks Ago   #3
llkk

x64
 
 

hi.
i think i'd like to go uefi-gpt
My System SpecsSystem Spec
.

3 Weeks Ago   #4
Megahertz07

Windows 7 HP 64
 
 

How did you set BIOS?
- Turn off Secure boot and Fast Boot.
- Under OS select Other

To Install as UEFI-GPT you MUST boot the installation USB disk as UEFI (not as Legacy)

- Format a USB flash disk as Fat32 and copy all files and folders from the installation disk (or from the iso file) to the USB flash disk. It will boot as UEFI but not as Legacy.
- Detach all other disks from the MB (power or SATA cable) - IMPORTANT
- During POST launch Boot Menu and select the UEFI USB flash disk. Go to install and delete ALL the partitions on the target disk. Install Win 7. clean-install

After Win 7 is runing and with all drivers, install the updates. My suggestion is to set WU to never check and run Simplix
MS releases SP2 for Windows 7
My System SpecsSystem Spec
2 Weeks Ago   #5
llkk

x64
 
 

ok.
so i redid the iso usb with rufus into uefi gpt
in the installer, i destroyed all partitions, and redid new ones, then installed on it.
got an error while the second step (expand files), and the install aborted.
i took a new usb stick and reburned it.
got the same error at the same place.
so i took another iso from the internet.
got another error code, at the same place, then aborted


so i took another iso, burned it on another flashdrive, and tryed to install on another hard drive
and got the same error again.
took off the ram, keeping just one, changing sata slot, switched bios sata mode



always an error while the 2nd step of expanding files.




what to do ?
My System SpecsSystem Spec
2 Weeks Ago   #6
Paul Black

Win 7 HP SP1 64-bit Vista HB SP2 32-bit Linux Mint 18.3
 
 

Hi llkk,

Quote   Quote: Originally Posted by llkk View Post
Got an error while the second step (expand files), and the install aborted.
We need more information!
What was the ERROR?
My System SpecsSystem Spec
2 Weeks Ago   #7
llkk

x64
 
 

i dont remember each error code, but amongst them
0x8007025d
0x80070017
there was another lone, but i didnt take note of the errror code


7025d came up with more than one iso
My System SpecsSystem Spec
2 Weeks Ago   #8
Megahertz07

Windows 7 HP 64
 
 

Did you boot the win 7 installation as UEFI?

After deleting all partitions, did it created the following partitions?
- EFI - 100M Fat32
- MS reserved - 120M RAW
- Big NTFS

Did you choose to install on the big NTFS?
My System SpecsSystem Spec
2 Weeks Ago   #9
llkk

x64
 
 

ok, so i took yet another iso off the internets, rufused it into the flashdrive in gpt. it was like the 10th one.

and this time it seems it works.
win installed itself, i have an efi fat32 partition, an ms reserved partition of an unknown type, and the actual c: ntfs



another one (iso) worked too but it was tempered by some gamerpirate blingbling so badtasted that even if it worked i couldnt live with that. it had some games screenshots hard wired into the file explorer, had explosions when i clicked somewhere.



so, i dont want to scream victory yet, but it seems to work for now.




thanks guys for the help
i'll come back if i run into more troubles
My System SpecsSystem Spec
1 Week Ago   #10
ZakGordon7

Windows 7 Pro 64-bit
 
 

Just in case it helps others, always install Windows first, Linux second. The other way around always has big issues unless you know exactly what to do (and i don't).
My System SpecsSystem Spec
Reply

 dual boot problem > no boot at all




Thread Tools




Similar help and support threads
Thread Forum
Dual boot with Win7 - problem with boot menus on Lenovo laptop
I have just acquired a refurbished Lenovo ThinkPad T430 laptop. It has had Windows 7 Professional cleanly (re)installed. I noticed that on initial boot up, a boot menu-screen flashed up very briefly with two options - 'Boot to Windows', or 'Restore the original Windows Image'. The latter...
Installation & Setup
Dual Boot problem, Ubuntu is the main boot
hello I have Asus laptop with OEM Win7 HomeP 64bit on it, I installed Ubuntu 12.04 along side with Win7, didn't know that Ubuntu will be the main boot, I used Ubuntu 11.10 a year a go and Windows was my main boot, I tired several way to retrieve Win7 as main boot but didn't work. I tried to...
Installation & Setup
Dual boot with cloned copy - boot problem
Hi all, I have windows 7 x64 installed, and need to copy that partition to another partition on the same drive, and be able to boot between the two using EasyBCD. One will be normal/office stuff, the other will be music production stuff. I copied the partition (C) using Acronis (bootCD mode)...
Installation & Setup
Problem reverting from Dual Boot to Single Boot
My situation is almost identical to that of the OP in https://www.sevenforums.com/installation-setup/22578-convert-dual-boot-single-boot-2-hds.html. I have 2 HDDs both of which are partitioned so that the OS and data files are on separate partitions. Windows 7 Home Premium is on a 500GB SATA (i.e....
Installation & Setup
Windows boot up problem in dual boot(win 7 & OSx86)
I was having win 7 RTM and i tried to installl OSx86 in second hard disk after few failure i successfully installed OSx86 in my secondary had disk now the problem is that i cant boot win 7 i changed boot order i tried windows 7 disk repair but both failed im getting some Boot mldr...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:05.
Twitter Facebook