ASRock A520M Motherboard: Windows 7 won't boot


  1. Posts : 22
    Windows 7 Ultimate x64
       #1

    ASRock A520M Motherboard: Windows 7 won't boot


    I just bought a new ASRock A520M motherboard+cpu. My SSD drive is detected in SATA Port 1 (in setup) but I cannot get it to boot.

    The SSD has Windows 7 x64 installed on it. It just won't even try to boot - the motherboard just goes straight back to the BIOS/Setup screen.

    I've tried F11 and Del on startup but no difference.

    In Advanced->Storage, I tried enabling CSM, tried various combinations of UEFI/Legacy settings but I still can't get it to boot. I might be doing something wrong though because CSM is automatically disabled again after it fails to boot so I may need some detailed guidance on this.

    I tried the Windows 10 SSD from my laptop - that boots fine. It just won't boot Windows 7 and that OS has all of my apps that I use. I don't really want to reinstall with Windows 10 - some of the apps probably won't run on Windows 10.

    Can somebody please help me with getting Windows 7 to boot.
      My Computer


  2. Posts : 13
    win7 x64
       #2

    I am no expert on this but I have a pc with the msi a520m mb in it & I was unable to get it working with win 7.
    I ended up bunging win 10 on it & only use it as a backup machine.

    As I understand, there are currently no drivers for this mb for win7.
    I was able to update my win7 iso to overcome the usb3 / mouse/ keyboard / hdd issues.
    I managed to get quite far with installation but eventually failed at the last stage when it gets stuck on windows loading screen.

    I considered putting an old graphics card in to see if that would work but never got around to it. lol
    Hopefully someone more knowledgeable can help you.
      My Computer


  3. Posts : 6,872
    W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
       #3

    Hi

    W7 does not include Ryzen drivers, you are going to need to slipstream them into your image
    look at this thread, link for those drivers is in post #3

    Update your Win 7 installation media
      My Computer


  4. Posts : 13
    win7 x64
       #4

    torchwood said:
    Hi

    W7 does not include Ryzen drivers, you are going to need to slipstream them into your image
    look at this thread, link for those drivers is in post #3

    Update your Win 7 installation media
    The ryzen modded drivers are only for processors 3400g & below.
    If your processor is newer than that, mine is ryzen 3 4300ge, the modded drivers still don't work. Or at least, they weren't working when I tried.
    May have been developments since then though.
    I might give it another try. lol
      My Computer


  5. Posts : 51
    Windows 7 Ultimate x64
       #5

    Check and see if there are any Win7 drivers listed for your MOBO: ASRock > Motherboard

    AFAIK the 4xx series are the last mobos with Win7 drivers, and it's been like that for a while. I suggest you take back your mobo and trade it in for an X470 or B450 (Asrock is a good choice). Make sure to check the drivers listed for your new mobo on the support website.
      My Computer


  6. Posts : 15,181
    Vista x64 / 7 X64
       #6

    ASRock 500 series mainboards CAN NOT work on win7..
    Forum - [Solution] Win7 Drivers for modern AMD USB 3.0/3.1 Controllers
      My Computer


  7. Posts : 22
    Windows 7 Ultimate x64
    Thread Starter
       #7

    Yeah, I didn't realise there wouldn't be any Win7 drivers for the board so I went ahead with a clean install of Win10 instead.

    I'll still be reinstalling software in a few months time..

    Case closed.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:14.
Find Us