Update Win7x86 for USB3/nvme?

Page 2 of 2 FirstFirst 12

  1. Posts : 15,688
    7 X64

    Disk 0 Online 465 GB (current o/s ssd)
    Disk 1 Online 931 GB (current archives hdd)
    Disk 2 Online 465 GB (new ct500p3pssd8 nvme)
    Disk 3 Online 28 GB (Usb boot drive after Integrate7)

    That indicates the booted media is aware of the nvme disk.

    What do you mean by "could not get to it"

    can you provide a screenshot of "could not get to it" ?
      My Computers

  2. Posts : 70
    windows 7 ultimatex64
    Thread Starter

    The display that I copied from running diskpart is of the currently running Win7x86 o/s. The nvme disk shows up there (after the hotfix was applied). I can read and write with it.
    When I boot the newly made Win7x86, it goes thru the usual opening screens and reaches the "Where do you want to put it" screen showing a list of disk partitions. Disk 0, a sata ssd, appears with it's many partitions, one of which contains the current o/s. The next is disk 1, a sata hdd, with it's partitions. But disk 2, the nvme which appeared in diskpart, does not appear. So I cannot select a partition within it as a destination for the new o/s. (I cannot get to the nvme at this point during the installation). I want the new o/s to reside on the nvme disk, replacing the sata ssd which will eventually be used elsewhere.
    I don't know how to do a screenshot during the windows installation.
      My Computer

  3. Posts : 15,688
    7 X64

    from the booted media press shift+F10 to open cmd prompt and type:

    list disk
      My Computers

  4. Posts : 70
    windows 7 ultimatex64
    Thread Starter

    Diskpart shows nvme missing. Only two sata disks and the usb drive are displayed.
    A previous build using 64I shows the same: no nvme drive.

    - - - Updated - - -

    The 64I build had an opening splash screen with a bunch of utilities, one of which was cmd. That's how I ran Diskpart.
    I am going to build another USB boot with Win7x64 and see if the Z270 board is the problem by not allowing 32 bit builds, or Crucial does not allow 32 bit builds, for their products.
      My Computer

  5. Posts : 70
    windows 7 ultimatex64
    Thread Starter

    So ok...
    I decided to see if I could clone the current o/s (Win7x86) to the nvme drive using Partition Master. A few hours later the entire contents of the sata ssd was copied to the nvme . I removed the sata ssd's data cable, and booted from the nvme. It worked, and I was now operating from the nvme. I backed up all to the hdd, and tried to do a normal install (in this case overwrite) of Win7x86 from the usb that I created on the nearby 64bit machine. It did not work. The USB3 drivers were ok, but there was no nvme driver in the installer itself, which could not see any of the partitions on the nvme, only those on the hdd.
    Still thinking about it....

    - - - Updated - - -

    So cloning is not the way to go.
    I made room available on the sata ssd and installed Win7x64 as a dual boot system which allowed all of the work to be done on one machine. I researched Crucial and found that the Micron drivers in Integrate7 had to be replaced with Micron "legacy drivers". Finally, an installation was begun: the nvme drive appeared, was selected, and things proceeded nicely to the first restart. But that was all. The installation stopped with an error on mtinvme.sys: "cannot verify digital signature". It would go no further.
    It has been 6 days now. I am tired. I am marking this thread as finished and will send the nvme stick back to Amazon.
      My Computer

Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:13.
Find Us