Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 0xc0000225 boot error after extending partition?

15 Dec 2009   #1

Windows 8 Pro (32-bit)
0xc0000225 boot error after extending partition?-Solved

So basically I have two partitions: Vista C: and Win7 D:, boot file is on C:
I had installed Jolicloud OS on my computer and it carved out a drive from my Win7 partition. later on I EasyBCD to remove grub when I figured out that it will be a pita to get my wifi working. afterwards i booted from the jolicloud installer, then used Gparted to extend the Win7 partition back to it's original size. i then rebooted, and it ran the disk repair, but now Windows 7 won't boot, giving me:
"Windows did not start correctly. A recent hardware or software change might
be the cause.

If you have aWindows installation disc, insert the disc and restart your
computer. Click system recovery options, and then choose a recovery tool.
(Startup Repair, available in some versions of Windows, can automaitcally
diagnose and fix startup problems.)

If you do not have this disc, contact your system administrator or computer
manufacturer for assistance.
I've tried to use the recovery feature on my disk, but it cannot see my hard drive and it's not able to locate a driver.

help? Windows Vista is AGONY
also: Easy BCD whe running from Vista says:
There are a total of 2 entries listed in the Vista Bootloader.
Bootloader Timeout: 10 seconds.
Default OS: Microsoft Windows Vista

Entry #1

Name: Windows 7
BCD ID: {6d574dfa-cef3-11de-a588-9966156464d7}
Drive: Deleted Partition
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows
i'm going to re add the entry for 7 via easybcd. if you don't hear from me in ten minutes then you will know that this didn't work.

My System SpecsSystem Spec
15 Dec 2009   #2

64-bit Windows 8.1 Pro

That boot manager should also display the option to Rollback your installation.
If the previous installation is inaccessible, try booting from your Windows 7 installation and attempt a Custom (Clean Install). You previous installation will be moved to the root of the drive in a folder called Windows.old.
My System SpecsSystem Spec
15 Dec 2009   #3

Windows 8 Pro (32-bit)

well fixing the bootloader worked, but now when I log in I get a blank screen and in the corner it says "this copy of windows is not genuine".
without reinstalling, is it possible to fix this?
I'm using the Windows 7 Enterprise 90-day trial, so could by any chance it became deactivated?
My System SpecsSystem Spec

15 Dec 2009   #4
Microsoft MVP


In the future, use EasyBCD 2.0 beta which has automated diagnostics.

Since you can now boot Win7, put your DVD in the tray and run a Repair Install from the Win7 desktop which should correctly reconfigure the dual boot as long as GRUB is uninstalled first.

Failing this, you may need to format over the GRUB.

Repair Install
My System SpecsSystem Spec
15 Dec 2009   #5

Windows 8 Pro (32-bit)

Grub is deleted.
I found that the problem is that 7 thinks it's on drive C:, because before I had the Vista drive set to B: in 7.
problem is, I cannot change the registry to correct this in 7, and Vista won't open hives or whatever that means.
My System SpecsSystem Spec
15 Dec 2009   #6

Windows 8 Pro (32-bit)

Same as this
but can't import hive
My System SpecsSystem Spec
15 Dec 2009   #7

Windows 8 Pro (32-bit)

YAY it works now!

the following is a condensed guide on how to repair this problem from a bootable Windows OS:
IMPORTANT: remember what the drive letter was when Windows worked, and find out what it is now
1. from the operational Windows OS; Run regedit.exe from Start -> Run
2. Select HKEY_USERS by single-clicking on it
3. Go to File -> Load Hive
4. Navigate to the registry file folder on your other drive. This is found in DRIVELETTER:/Windows/System32/Config
5. Select the file labeled SYSTEM. Make sure not to select the text file
6. Type whatever name you like in the Key Name field, Hit Enter.
7. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
8. Try to remember your old working drive letter, mine was drive D, and windows changed its drive letter to C. So i swapped the D and C paths in the registry; now windows knows to access the correct drive to boot.
9. To swap drives, find the drive letter you want changed, it should look something like "\DosDevices\C:" where "C" is the drive letter you need swapped.
10. Right click on the key and rename it to a drive letter that is not in use, for example, I renamed mine to "\DosDevices\Z:" This will free up the letter that you need swapped.
11. Right click on the other key and rename it to the first key's letter, for example, if i wanted the D drive swapped with C, I would now rename "\DosDevices\D:" to "\DosDevices\C:".
12. Now rename "\DosDevices\Z:" (Which was previously "\DosDevices\C:") to "\DosDevices\D:"
13. Select the folder the hive was mounted in by right-clicking it once
14. Go to File -> Unload Hive
15. Restart the computer and load your newly working OS!
My System SpecsSystem Spec
15 Dec 2009   #8

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Yes, you could do that.

Much easier to use the boot corrector on the free Paragon Rescue Kit Express :

Paragon FREE Rescue Kit Express - Don't wait for disaster, get instant data recovery software kit!

Hope it helps
My System SpecsSystem Spec
15 Dec 2009   #9

64-bit Windows 8.1 Pro

Glad you got it all sorted out!
My System SpecsSystem Spec

 0xc0000225 boot error after extending partition?

Thread Tools

Similar help and support threads
Thread Forum
error 0xc0000225 after easus partition change, win7 won't boot
Hi everyone. I bought new laptop asus u47vc 2 days ago. After doing some basic changes I did a iso copy of a system (as asus app advice me) but I didn't had any DVDs at the time so I just skipped burning it. Then I wanted to change a partitions size and use this easeus partition master. I had ...
Installation & Setup
After Partition Changes, 0xc0000225 and cannot boot
So i had two partitions on a physical disk, and wanted to delete the first and enlarge the second. I usually use gparted off the ubuntu live cd because it completely separates itself from windows details and allows a lot of disk changes in one interface; no conflicts. I moved forward with my...
BSOD Help and Support
Error 0xc0000225 After Partition Changes & Can't Boot Or Repair Yet
I've got the problem, due to trying to create an extra partition with Partition Wizard which got to the 1 black and white does screen stage (I guess 2 of stage 1?) and hung up there for hours on only creating a 10Gb partition on a 80Gb hard drive in a laptop... I've tried the startup repair...
BSOD Help and Support
Windows 7 - Error 0xc0000225 after resizing partition, can't boot
Hi everybody, I tried to resize my Win7 parition with Esaeus partition manager. So I had to restart win7 and before starting the SO the program began resizing the partitions. Unfortunately my brother plugged off the pc and when I restarted the pc on Win7 I saw this error: 0xc0000225 "boot...
BSOD Help and Support
Error 0xc0000225 after resizing partition, can't boot
Hi, I tried to resize the second partition on a friend's notebook from 252 GB to 75 GB – the partition where Windows 7 is installed (it's a Lenovo IdeaPad U550). I did this with KDE Partition Manager from a Linux Mint 9 KDE LiveUSB after I couldn't find the partitioning utility in Windows 7 in...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:36.
Twitter Facebook Google+