Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 not booting (Disk read error)

25 Dec 2009   #1

Windows 7 not booting (Disk read error)

Recently, I was messing around with my HDD's partitions in GParted. I resized my Windows 7 partition and made a new NTFS for Windows XP, and a new ext2 for Puppy Linux. I installed the GRUB Bootloader and all my partitions booted fine off of it except for Windows 7. I later found out this has something to do with the Master Boot Record and that I should install GRUB and then install Windows 7. I was okay with this for a while, but Windows XP couldnt boot many applications from the Windows 7 partition because I have it's x64. I eventually realized that I hadn't made my Windows XP partition large enough (only 3 gig) for anything I wanted to do with it. After a few days, I just deleted the Windows XP and Puppy Linux partitions and was back to having just my Windows 7 partition. I was hoping everything would be magically better, but when I restarted my computer, the BIOS told me a "disk read error" had occurred and "press any key to restart".

I put in a Puppy Linux Live CD and opened up GParted again. GParted showed me that my HDD was now just one big block of Unallocated space. Then I looked in the lower-left corner of the screen and saw that I still had 4 partitions (sda1, sda2, sda3, sda4). sda1 is now my Windows 7 partition, sda2 is now my Windows XP partition, and for some reason sda3 and sda4 are both HP Recovery partitions.

I tried everything I could think of to save myself. I popped in the Windows 7 Upgrade Disk (I had been running Vista before) and tried the Recovery tools included with it, but the Recovery didn't recognize any partitions on my HDD at all. I ran a Command Prompt and tried all the options in bootrec fixmbr, but two of them didnt work and the other two replied "Element not found". Then I tried sfc /scannow, but that told me I had to be running Windows. I booted back into Puppy, ran GParted, and tried to make a new partition, but GParted told me that doing so would erase ALL data on the HDD. There's probably some more options I tried, but I can't remember them right now.

Can anyone help me out? I feel like I'm close to just backing up my personal files, wiping the HDD, and starting over. Only problem is I don't have anywhere to backup 150 gigs :\


My System SpecsSystem Spec
25 Dec 2009   #2

64-bit Windows 8.1 Pro

Unfortunately, I would bite the bullet and format and reinstall... You have messed around with the partitions so much that recovery looks almost impossible... Good Luck..
My System SpecsSystem Spec
25 Dec 2009   #3

Microsoft Community Contributor Award Recipient



Tews is right, start all over.
My System SpecsSystem Spec

25 Dec 2009   #4


Well guys I kinda fixed it. I used fdisk to delete sda4 and after that GParted started detecting my partitions. Now I'm back to 627 megabytes of unallocated space at the beginning, then my Windows 7 partition, then another 3.0 gigabytes of unallocated space, and finally my 13 gigabytes of the Windows 7 Recovery partition.

I feel like I'm making progress, but the System Recovery disk still isn't detecting Windows 7 as an operating system on my computer. I figure that if I can resolve this, then I can fix the rest of it.

My System SpecsSystem Spec
26 Dec 2009   #5


Boot from the Win7 DVD Repair console and click through to Recov tools to try to run Startup Repair.

In Win7 Startup repair has automated all fomer bootrec and bootsect commands, however if an installation cannot be found sometimes Startup Repair will not agree to run.

If it will run, you need to run it repeatedly as it does its tests and then applies fixes on the assumption that they will work, until you come back to try again the next fix, until ultimately it will rewrite the MBR.

If Startup Repair will not run, then you need to try to make the installation detectable by the installer to do its systematic tests and fixes via Startup Repair. Several times I have gotten it to do this by manually running the bootrec or bootsect commands.

Boot into the WIn7 DVD repair console (or Repair CD), click through to Recovery Tools and open a command line to type:

bootrec.exe /fixmbr
bootrec.exe /fixboot

Now restart and see if OS will start. If not, see if Startup Repair will now begin sequencing - run until it finds nothing else to fix or starts Win7.

If this fails, one last attempt to get the installer to see and Repair Win7. Open a DVD repair Command Prompt and type:

Bootsect.exe /nt60 all /force

Now again restart, boot back into DVD and run Startup Repair repeatedly to see if Win7 will start up.
My System SpecsSystem Spec
26 Dec 2009   #6


Thanks, gregrocker. I'm posting this from Windows 7 right now . The only thing that's weird is that at startup it asks me if I want to boot into Windows 7 or Windows 7 Home Premium (Recovered). This isn't a big deal; I just pick Windows 7 and it works fine.

Thanks again,
My System SpecsSystem Spec
26 Dec 2009   #7


Am I correct that you now only have the WIn7 partition, and in Disk Management it is marked System Active Boot?

If not, please post back a screenshot of your full Disk Management map using the Snipping Tool in Start Menu, attaching file using paper clip in reply box, before proceeding.

Otherwise look for the ghost Boot listing in msconfig Boot tab, highlight and delete.

If it persists, install EasyBCD to see if ghost listing is shown. If so, remove it on Add/Remove tab.
My System SpecsSystem Spec
26 Dec 2009   #8


Okay, everything is completely normal now. Thanks again, gregrocker.
My System SpecsSystem Spec

 Windows 7 not booting (Disk read error)

Thread Tools

Similar help and support threads
Thread Forum
disk read error when attempting to intall windows 7 from bootable USB
Hi, I've had my current PC for a few years now and in that time I've done a fresh installation of Win7 several times always via USB. Today I inserted my trusty flash drive, set it as priority device in BIOS and after pressing "any key to boot from USB" I get hit with "A disk read error occurred"....
Installation & Setup
Error Install Windows 7 - This PC HW may not support booting to disk
Error: Hello, i bought SAS controller (Dell SAS 6 iR controller) + SAS harddisk (HP EH0600JDYTL) to my home pc. When i switch turn on computer, computer freezed on this ( In settings...
Installation & Setup
Drive read error - hdd and bootable usb not booting.
Hi, My build is as follows Gigabyte 970A-DS3P Motherboard AMD FX6300 CPU 8gb HYPER X FURY RAM Gigabyte geforce gtx 750ti graphics card 320gb hitachi sata hdd evga 500w white power supply
General Discussion
Disk read error and recovery disk not working?
Hi, I have a toshiba satellite C650 that has recently come up with a disk read error. I want to access the command prompt to try some potential solutions that I have read about on the internet. I have made a Windows 7 recovery disk using my other acer laptop which also has Windows 7 installed. When...
General Discussion
A disk read error has occurred but disk can be read
TLDR: I get the "A disk read error occurred" error but the system disk is readable and checks OK in the recovery USB. So, I have two hard drives--a terabyte drive with some data on it and a smaller drive with the win7 installation on it--and a USB drive. I made the USB drive into a recovery...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App