Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Upgrade - sometimes works, sometimes doesn't!

21 Feb 2010   #1
CIY

Windows 7 Home Premium
 
 
Windows 7 Upgrade - sometimes works, sometimes doesn't!

Hi there,

I am experiencing a very unusal problem with my new Windows 7 upgrade (previously had Vista) on my 6 month old Acer Aspire laptop. I have seeked support on the Microsoft forums but the nature of the issue wasn't understood. I cannot return to Vista as the upgrade is not undo-able and I didn't get a Vista CD or any kind of restore mechanism with the laptop.... I'm a student, can't afford to take it to a shop and I'm stuck!


Here is the problem:

Before the upgrade - everything worked perfectly on the laptop, I had no software issues and no hardware problems. Since the afternoon I upgraded, things have started to stop working - so I know that it was the upgrade that caused it. Here are a few symptoms...

1) When I try to open certain files (eg. the SD card that is inserted) it will load for ages and not open. When I try to restore, it will 'load' the restore but nothing happens (it essentially freezes).

2) The sleep and hibernate functions do not work. When I close the lid, the screen cuts out and I cannot bring it back to life (although the HDD is still running). I regularly have to hold down the power button and restart to get it working again.

3) Occassionally I will notice that some functions aren't working (eg. the button to open the CD drive tray wont work).

4) sometimes if I leave the laptop alone, after it has passed the screensaver and 'black screen' phases it will not return when I move the mouse/tap a key. I have to hold the power button again.


Whilst these are small niggles they can be very annoying when you need to quickly close the laptop between classes. I have to do a hard shutdown and restart at the start of every glass as it will have frozen when I closed the lid. And then I can't open the SD drive to access my files!!

The strangest thing is that this happens some days, but the next it will operate fine, with Sleep working upon closing the lid and the SD reader opening fine. It is this spontaneous nature of the problem which is making is impossible to solve.

Eg. last week everything was working fine on Tuesday-Thursday but as of Friday it has been doing its annoying niggles!

Any help or suggestions would be gratefully received!

Chris


My System SpecsSystem Spec
.
21 Feb 2010   #2
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Welcome to the Forum

If you have used the term upgrade correctly, I know the problem. You must do a clean install. This can be done with an upgrade DVD. If interested, I will provide more information on how it can be done.
My System SpecsSystem Spec
21 Feb 2010   #3
gregrocker

 

Agree that these are symptoms of a failed in-place Upgrade, for which the fix is a clean reinstall booting from the Win7 DVD.

Select Custom install, use Drive Tools to delete all, repartition as you wish, then format and install Win7 to first partition. Back up your files first; you must reinstall programs.

Until then, type Power Options in Start Search box, change Closing Lid to Do Nothing. Look on Change Plan Settings to see if Sleep appears. If not, update your Display Adapter in Device Manager. See if you have one in Windows Updates>optional, or go to maker's Support Downloads webpage and download/unzip/install it.
My System SpecsSystem Spec
.

22 Feb 2010   #4
CIY

Windows 7 Home Premium
 
 

Hi,

That sounds like the best solution. Can you please advise how I would go about a clean install using my Windows 7 upgrade disk?
My System SpecsSystem Spec
22 Feb 2010   #5
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Hi,

So glad to be able to help. It is easy and you will be thrilled with the results

Clean Install with a Upgrade Windows 7 Version[2]=General Tips

You will have a new OS and not an old one with a new paint job.
My System SpecsSystem Spec
22 Feb 2010   #6
Tews

64-bit Windows 8.1 Pro
 
 

My System SpecsSystem Spec
22 Feb 2010   #7
CIY

Windows 7 Home Premium
 
 

Thanks for your help - hopefully this will solve my ongoing problems!!

However, I don't have an original Vista disc - my laptop was brand new from Currys in September 09 and although I have some Acer software CDs I don't have a Vista disc or any serial numbers... Will I still be able to do this clean installation?
My System SpecsSystem Spec
22 Feb 2010   #8
Tews

64-bit Windows 8.1 Pro
 
 

Yes, just follow the instructions in the link...
My System SpecsSystem Spec
Reply

 Windows 7 Upgrade - sometimes works, sometimes doesn't!




Thread Tools




Similar help and support threads
Thread Forum
Windows Anytime Upgrade no longer works?
Hello folks, I've been trying to upgrade 2 7-Pro x64 machines to Ultimate, using Windows Anytime Upgrade, and I get through the 1st step of my name and address most of the time, and sometimes I even get to where I put my payment information in, but then I get and error saying to close Anytime...
Installation & Setup
Computer Upgrade - Windows Doesn't Load
So I recently upgraded my motherboard, RAM, and CPU. After doing some quick adjustments in the BIOS, I attempted to load into Windows to make sure everything was correct. Upon the Windows loading up, the logo freezes for a second, a BSOD appears (which I cannot read as it disappears within a...
BSOD Help and Support
Dell Bios Doesn't See IDE Hard Disks but Windows 7 Does & Works Fine.
I have Win7 Ultimate installed on a Dell Optiplex GX620 P4 hyperthread, approx 6 years old. Bios is most current Phoenix ROM Bios Plus 1.10 A11. I have 2 sata drives and 2 IDE drives installed. Boot is from SATA 0. SATA drives 2&3 are not present. All is well with this part of the equation. I...
Hardware & Devices
Windows 7 upgrade, now mic doesn't work (soundcard problem)
I previously had windows vista installed on my computer and just the other day reformated and installed windows 7 64bit. Before reformating and installed win7 my computer worked fine. Now after the upgrade to win7 i am having problems with my sound card. I have a Creative Worlds - Sound Blaster...
Sound & Audio
32 bit works, 64 bit doesn't
Clean install using 64 bit retail version. Formatted the drive but after a few minutes after completing the file copying process the computer restarts and an error message pops up. ....computer restarted unexpectedly... Underclocked the 8 gb mem stick. tried only with 2 gb mem stick and still...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:22.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App