Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD installing Windows 7 64-bit: Asus M3N78-EM

14 Apr 2009   #1

Windows 7
BSOD installing Windows 7 64-bit: Asus M3N78-EM

I'm building a new pc with a Asus M3N78-EM mb and AMD Phenom 9600.
I tried installing Windows 7 Ultimate (Bld 7000) 64 bit and was getting the BSOD around the point of expanding files during the install. I tried a couple times, same results. I then updated to the latest bios for the mb and tried installing again. The install goes much further, during the part of "completing install" i get the BSOD. I tried 3 more times, everytime BSOD around the same part of the install. Can someone tell me if this is a mb bios issue, a bad cpu issue or a windows 7 64-bit issue? I tried installing Windows 7 beta 32-bit, and this installed successfully on the first try. This is nothing fancy with my new system, 4 gb (1066) GSkill memory, all default bios settings, sata hd's (non raid).
Any help would be greatly appreciated!

My System SpecsSystem Spec
14 Apr 2009   #2

Win 7

Sounds more like a bad burn issue to me.
My System SpecsSystem Spec
14 Apr 2009   #3
Orbital Shark


I agree. During the 'Expanding Files' process it's actually copying the install.wmi file which is over 2GB of data. If this in any way is corrupt (due to burn speed/write error) then it can produce various bad effects.
My System SpecsSystem Spec

14 Apr 2009   #4

Windows 7

As I stated in my original post, after I installed the latest BIOS, it got past "expanding files" part of the install. The BSOD is happening at the very end of the install during the "completing installation" part. The pc rebooted once I believe.
My System SpecsSystem Spec
06 Oct 2009   #5

Windows 7 Ultimate 64bit

OK, this is just a quick post to let everyone know that I have found a work around for installing Windows 7 32bit and 64bit on a RAID 1. My System is a Asus M4A78-EM with AMD 920 proc and 4x1GB memory. I will post more specific information once I am able to write down all the steps. So Bare with me a little while. If anyone knows of other sites where members have had a problem install Windows 7, please let me know and I will post my notes there. Hopefully I will the information posted today.
My System SpecsSystem Spec
06 Oct 2009   #6

Windows 7
Successful Install

Here's an update.

I was able to successfully install Windows 7 64-bit RC.
So it wasn't a hardware issue.
My System SpecsSystem Spec
06 Oct 2009   #7

Windows 7 Ultimate 64bit

OK first here is my system spec
Asus M4A78-EM
AMD 920 Processor
4x1 GBs of memory
Samsung DVD DL R/W
2 250 GBs Maxtor SATA hard Drives
2 80 GBs Seagate hard Drives
Hauppauge 2250 HVR card
Apevia X-QPack 2 Case
PLEASE READ THROUGH ALL THE STEPS BEFORE STARTING. Because I had to do this several times on the 64bit installation to get it right. Also please feel free to point out any steps you added or did not do so others may hopefully be able to install Windows 7.
Ok let me start off by saying I was ready to give up on ever buying AMD or ASUS products again. Especially, since ASUS web site saying their boards is Windows 7 ready. The truth may be that they are ready but NOT easily ready to install Windows 7 on them. I spend almost 3 days working on this project and I have finally figure out a way to install both the 32bit and 64bit of Windows 7 Ultimate on a RAID 1. I do not know if these steps will work on any other board or with any other RAID setup.
Now you will notice that I have 4 hard drives listed. The reason for that is I discovered these steps while trying to install Windows 7 32bit. I did not want to destroy what I had done when I attempted these steps on a Windows 7 64bit install.
After many BSOD and thousand of very choice words I used the following steps. Now you may or may not need to do some of them but these work for me. Also if after reading this you have questions please post them here so I can try and answer them for everyone.
On the 32bit installation
I first configured the bios so that sata channels 1-4 were set to RAID and 5and 6 set to IDE.
Then is plugged in the hard drives and using the onboard RAID configuration tool, configured a RAID 1
After that was recognized, I then unplugged both drives from channel 1 and 2 and connected only 1 to channel 4. I left the RAID turned on.
I then proceeded to install Windows 7 Ultimate 32bit. I had previously downloaded all the latest drivers and programs from ASUS website. During the installation of the 32bit version, I did NOT install any additional drivers. I did a complete installation of all programs and updated the drivers and Windows update.
Once this was completed, I also install RAIDXpert2.4.1540.4_X2. I used this to view and work with the RAID setup in Windows.
Then I first plugged the one drive that I had installed the O/S to channel 1. Upon booting the built in RAID controller showed the array as critical but continue to post. Once back into the O/S I made sure I could see everything. With that completed, I powered down and plugged the second drive into Channel 2.
Upon rebooting and going into RAIDXpert, the second drive showed up as a JBOD drive. I just deleted that and a rebuild kicked off. Once the rebuild completed everything is running fine.
Now for the 64bit version. Most of the steps are the same expect for what is below.
After creating the RAID, you will have to go back into the bios and set ALL the SATA controller channels to IDE.
I also again only plugged in one drive to channel 5.
During the beginning of the installation I had the following files on my USB key.
I had to uncheck the hide files button, but I choose to install all of the inf files it provided me.
The installation went on without any problems. Again I did a completed installation and update.
Once that was completed, I powered down and went back into the bios and turn on RAID for channels 1-4. I STILL HAD THE DRIVE PLUGGED INTO CHANNEL 5 AT THIS POINT.
I powered on the system and let it completely boot up. Once that was done, I powered down, plugged the one drive into channel 1 and powered on again.
I had to reboot twice in order to see the drive. I receive a no boot device found on the try. But on the second it saw the drive.
Again I let it completely boot up. I powered down one more time, this time I plugged in the second drive. Powered on again. Using RAIDXpert, I saw both drives with the second as a JBOD, again I deleted it and the rebuild started. Once the rebuild was completed everything ran fine.
adobe win7 32bit
Aisuite V1.05.32 07202009
AMD Chipset Program Driver WHQL V3.0.732.0 07312009
AMD HDMI Driver V5.10.0.5880 08072009
AMD VGA Driver V8.632.0.0 07222009
ASUS AMD Cool&Quiet utility V 2.18.01 07222009
ASUS EPU-4 Engine V1.00.29 07082009
ASUS Express Gate Installer V1.4.10.4 07222009
ASUS PC Probe II V1.04.75 07272009
ASUS TurboV V1.00.41 07312009
ASUS Update V7.17.02 Install Program 07302009
Realtek HD Audio Driver v5.10.0.5859_6.0.1.58 07272009
Realtek RTL8111BC & RTL8112L 10_100_1000M LAN Driver V7.3.522.2009 07302009
My System SpecsSystem Spec

 BSOD installing Windows 7 64-bit: Asus M3N78-EM

Thread Tools

Similar help and support threads
Thread Forum
Installing Windows 7 Professional 64-bit on a Asus UEFI-Based Computer
Hello friends, -I am used to installing windows on the M5A99X EVO but it looks to be a whole different thing when it comes to the M5A99FX PRO R2.0. -I am trying to install windows 7 Professional 64-bit OEM DVD with a M5A99FX PRO R2.0 motherboard onto a Samsung EVO 1tb SSD. this is a AMD...
Installation & Setup
Asus M3n78 Pro Sound recognition
I am using onboard graphics with my Asus M3n78 Pro and I have gone to almost every site I could think of to look for drivers and tried to use them (The sound is by Realtek) but there is one problem, Windows is not even recognizing that I have onboard sound on my motherboard. I have no clue what to...
Sound & Audio
geforce 8200 asus m3n78 windows 7 fails to install
hi all, basic gaming system, asus m3n78-emh hdmi mobo, trying to install win7 rc1, all other devices removed (pcie, pci, usb) seems to go ok, re-boots, "starting system first run" and screen goes blank, stays there. any know issues with this nforce/geforce chipset? Tried 3 different...
Installation & Setup
Asus M3N78 audio driver
OK, so I just built a new PC with an ASUS M3N78 PRO motherboard. I installed Windows 7 and almost everything works except for the sound. I have Logitech X-540 Surround Sound speakers hooked up and I installed a RealTec audio driver for Vista x64, which did nothing. Any ideas about how to get this...
Can't get SPDIF to show up in sound control panel. I've tried several bios settings.
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:45.
Twitter Facebook Google+