Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Sysprep Problems

22 Mar 2010   #1

Windows 7 Enterprise 64-bit
Sysprep Problems

Hi All,

I work in an IT department and have developed a sysprepped Windows 7 Professional image using WAIK. It works well, however there are 2 things that I have been unsuccessful in figuring out at this point:

1. At the time of the creation of this image, WAIK was unable to correctly configure the sysprep file to add the Windows 7 machine to an active directory. Has this changed? Has anyone gotten sysprep to prompt for a domain?

2. I also have problems configuring the default user profile. I've tried the copy/paste method I've read on the forums here, but new users always have a black background. Anyone been able to get around this?

Thanks in advance to all help.

My System SpecsSystem Spec
22 Mar 2010   #2

Windows 10 Pro (x64)

Is the background image in a shared space, like in the public directory?
My System SpecsSystem Spec
22 Mar 2010   #3

Windows 7 Enterprise 64-bit

I assume so - it's the standard Windows image used when new accounts are created. I believe the problem lies in my workaround, i.e. configuring a local account and then renaming it Default and overwriting the Default folder in C:\Users
My System SpecsSystem Spec

22 Mar 2010   #4

Windows 7 Enterprise 64-bit

Bit of an update - looks like the profile copy feature of WAIK is now working, so hopefully that issue has been figured out.

Sysprep a Windows 7 Machine ? Start to Finish V2 -

Still unsure on how (if possible) to have sysprep prompt for the AD join.
My System SpecsSystem Spec
16 May 2010   #5

Windows 7 Enterprise

looks like the profile copy feature of WAIK is now working, so hopefully that issue has been figured out.
Does testing confirm this? Still hasnt worked for me.

In my unattend xml, I've got a run once command pointing to a cmd file with a bunch of stuff, one stuff being a .vbs script which does the domain joining.
My System SpecsSystem Spec

 Sysprep Problems

Thread Tools

Similar help and support threads
Thread Forum
Sysprep - Windows 7 - unable to sysprep image that joins domain
Good morning all: Below is my unattend.xml. I am using the sysprep + win7 for creating virtual machines in Red Hat Enterprise Virtualization 3.0 but having difficulty getting them to auto-join the domain. My sysprep progression proceeds normally and completes. The initial boot of the image...
Sysprep problems - New Hardware
Here's the deal: I built a new system completely from the bottom up, but wanted to keep my old hard drive with Windows 7 on it. I started out using sysprep with some problems (windows media network was still on, and such things) I straightened all that out, and fully completed the sysprep. After I...
Hardware & Devices
win7 after sysprep reboot always with sysprep box
hello, 1st sorry for my english (i'm french guy). I made a sysprep and all parameters are corrects. but after the reboot I have always the sysprep preparation tools box. for me the sysprep is correct but I don't know what's happended. in attachment my unattend.xml
Installation & Setup
Sysprep problems on WES 7
Hello all, I am trying to run "sysprep /oobe /generalize" from command prompt (Run as administrator) on my reference machine. It appears to start and run for a while, but my reference machine never reboots. So, I checked the log it generates and it contains errors that I do not understand. ...
Installation & Setup
Having problems using USMT for vhd sysprep!
Hey there. I sysprep'ed my VHD, it booted fine BUT it FORCED me to make a new account, which I do not want to do. I had a custom named administrator as the only admin/user on the box before I made the image etc.. It's fine for it to boot with that custom named administrator, it's what I...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:41.
Twitter Facebook Google+