Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Install cannot load RAID drivers

14 May 2010   #11

windows 7 x64

Thanks for the reply.
Unfortunately I've already moved beyond this, but I'll fill you in on the background in thaw hopes that it'll contribute to the knowledge base.

My MSI (K9NU Neo-V) mobo died, through which I was running my OS & apps on RAID 0 (on board nVidia/Uli M1697 chipset). Most of my important data was on a non-RAID drive, but a couple annoying things (Outlook .pst, and some game saves) were on the RAID array.
The new mobo didn't automatically recognize the array (at this point I had rescued my data using raid recovery program, and was just looking to avoid the hassle of reinstalling OS, games, apps, etc.
I read in another forum/tutorial that I might be able to rebuild the RAID array without disturbing the MFT, as long as I knew the disk order and stripe size (I did).
I did this on the new mobo (that also was running nVidia chipset, but of more recent vintage) and tried a repair install to reset/rebuild the boot loader (if that's the right terminology, even with a "healthy" RAID I still wasn't booting). The interesting thing was that when it was time to load the RAID drivers in the repair, I was able to browse the Computer and see/access all the files in the array.
Installation wasn't acknowledging the presence of an OS, but it was all there. I was hopeful that I could get the install to work, but was continually stymied by "the drivers failed to load". I was able to locate them easily on the USB drive and have the installer list the appropriate ones, but after a minute or two of the computer clicking away and the progress slider shooting across the screen, the error message was the only reward.
So I finally said "F***-it" and proceeded with a clean install.
Bottom line: no resolution, but an unwanted learning experience.

Sorry for the long post. I'm happy to elaborate on anything I've written, but you can consider me resolved.
Too bad I couldn't try your suggestions.


My System SpecsSystem Spec
18 Jun 2013   #12

This should have worked if attemted first

My PC Win7 64 bit had the same issue. Was working fine, until an power outage. After the power outage the raid also got disabled. Another user proceeded with windows start up repair with raid not enabled in my absence. I noticed the raid was disabled and enabled it in the bios. Tried to load drivers when booting from windows 7 disc and entering start up repair but no luck.

I really searched hi and low and got to here. The problems seemed similar.

Then I remembered something...Windows probably tried to correct a registry entry noticing that the system wasn't set up for raid and thus disabled raid in registry.

Here is how to fix

Boot with Disc into recovery as usual.
Ignore loading drivers and select first option.
open up command prompt and type regedit.exe
Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStorVIn the right-hand column, you should see a value named Start. Double-click this entry and change the data from 0 to 1

Restart machine normally.

VERY important: I could get into widows but since I have attempted 4 hours of back ally fixes, boot repairs, check disks (chkdsk) & a bunch of other stupid stuff I had a corrupt user profile. This was probably caused by Chkdsk and Diskpart treating the raid array as a normal drive and thus corrupted some data.
So although you will probably read this after you have done everything I have, I suggest trying the above method of registry fix first in this situation.

Hope it helps someone out there. I just finished repairing all the other newly created issues and my total time count without having to reload is about 11 hours. Where is the good old WINXP repair option when we need it so badly??? I wish MS would understand that I had to waste half a day for something I could have sorted in the XP days in 2 hours.
My System SpecsSystem Spec
09 Jul 2013   #13

Win 7 Pro 64

Thought I'd sign up and see if there would be any more thoughts on this. This thread is the closest thing on the net I could find to my situation.

BOOTMGR is missing
Win 7 Install Disk boots but can't install ICH10R drivers to do repair
Have tried the registry change
Post shows all drives are fine and ICH10 post shows healthy raid 0 setup
Reseating the cables never helped. It did reset my BIOS which I have recorrected the settings again
It was dusty before this occurrence and I have blown it out now
My last backup was in March I've never actually tried a restore (Acronis TI) to see if it would even work on RAID 0
Seems to me I have to get my RAID 0 back to do any commands however I not familiar with the win 7 100mg partition so maybe that's the problem
My System SpecsSystem Spec

12 Jul 2013   #14

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)


Welcome to the forum.

Most of this thread is 2 years old. I don't think may people are following it, in fact I may be the only one and that may be because I forgot to unsubscribe when it got old :) Your best bet is to start a new thread and refer to this one, that will get you the help you need.

My System SpecsSystem Spec
12 Jul 2013   #15

Win 7 Pro 64

Thanks WindowsStar
My System SpecsSystem Spec

 Windows 7 Install cannot load RAID drivers

Thread Tools

Similar help and support threads
Thread Forum
How to install drivers using Windows Recovery "Load Drivers" option.
I was actually getting ready to post here about my x00000124 problem but reading other posts realized that my motherboard drivers were freakishly out of date (2006 versions, forgot about them last time I was installing a system). I dled all new ones, installed them all, performed a restart and then...
Hardware & Devices
Fixed "Unable to load RAID drivers for Windows 7 installation"
Hi Everyone, I am currently attempting to install Windows 7 on an SSD RAID Array, and I have encountered several issues (this has been a one step forward, two steps backward affair). The issue that I am currently facing is the fact that I am unable to load RAID drivers during the OS...
Installation & Setup
Install new RAID drivers without reinstalling Windows 7?
Hello there, I am moving drives to new computer and therefore I need help. I would like to know if there is any possibility to install new RAID drivers without fresh reinstalling Windows (W7 professional x64). Only idea which comes to my mind is booting from W7 install disc and trying...
Still can't install RAID 0 drivers
I've read several forum threads on this, but am still having trouble. I have win 7 32bit RC up and running for a long time on a 500 gig WD. Bought two 1Ts for a raid 0. I have the RAID chosen correctly in the BIOS, and the utility works fine. At the clean install for either 64 or 32 bit, I try...
Load Drivers In Windows 7 Install
Can someone please explain how this works? like where does it put the files etc and can i install the latest NVIDIA drives through the load drivers option during windows 7 install? Cheers,

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App