Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot boot Windows 7 after installing Linux

09 Apr 2010   #1
Bjorn Jonsson

Windows 7
Cannot boot Windows 7 after installing Linux

I recently got a new computer with Windows 7 Professional (64 bit) installed on C:. Everything worked great and this is what things were like back when everything worked: Two 500 MB disks in a RAID 1 array partitioned into C: (for Windows 7) and D: (for data etc.). The 100 MB partition that W7 creates was there as well. Also a 1.5 TB disk with two partitions (drive letters E: and F:).

I then installed Ubuntu Linux in a partition I created on the 1.5 TB drive to get a dual boot configuration. This messed things up - apparently the Linux installer doesn't like RAIDs. I cannot boot Windows 7 now. I'm attempting to fix the MBR, BCD etc. and have read Recovering the Vista Bootloader from the DVD - NeoSmart Technologies Wiki and done lots of Googling.

However, I'm not sure how to proceed because the drive letters are now messed up. The reason is that when I boot from the Windows 7 installation DVD to repair Windows 7, the RAID (i.e. originally C: and D:) cannot be accessed until I load drivers for the RAID from another DVD. Before I do that the partitions on the 1.5 TB drive show up as C: and D: (as previously mentioned, they originally were E: and F:). Once I have loaded the RAID drivers, the partitions on the RAID get the letters H: (the Windows 7 partition, originally C:), G: (the 100 MB partition that didn't have a drive letter) and F: (originally D:).

In a nutshell:
RAID: C -> H (Windows 7 is installed here)
RAID: D -> F
RAID: 100 MB -> G
1.5 TB: E -> C
1.5 TB: F -> D

I have tried doing bootrec /fixmbr etc. but this didn't fix the problem and appears to have created/updated a boot\BCD file on what's now C:\ (was originally E:). There is another boot\BCD on what's currently G:\ (the 100 MB partition that originally didn't have a drive letter). From the date of the BCDs the one on G:\seems to be the one that got messed up by the Ubuntu installation.
How do I get bootrec to fix the correct BCD? Do I need to reassign drive letters? There is no BCD on the partition where Windows 7 is installed (currently H:, it was C: before the mess). Is this normal? How should I proceed?

My System SpecsSystem Spec
09 Apr 2010   #2
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

What a mess. I would say the first order of the day is to get rid of Linux. Apparently the Grub took over. Then resort the drive letters (looks like your G with the MBR is still whole).
My System SpecsSystem Spec
10 Apr 2010   #3

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi Bjorn ! Dont worry , pal There's nothing that can make you worry.
I also got just the same situation when I installed linux for the first time in my machine. It was not possible to boot up in windows 7, even after recovering MBR. Then iseeuu suggested me to update GRUb, so that the windows boot entry is included in grub. That trick worked like a magic.

But unfortunately i forgot the process to updating grub. Still I can recommend it to him. Hope he will help you as he helped me
My System SpecsSystem Spec

10 Apr 2010   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

I could find out these two links those was helpful in my case
MBR - Restore Windows 7 Master Boot Record
Remove Grub - Restore Windows 7
My System SpecsSystem Spec
10 Apr 2010   #5


The only thing that has worked in the past is to deep clean the HD of GRUB and install Win7 first, then Linux and GRUB if you want it to manage boot.

Here's the tutorial that has worked for others: Dual-Boot Windows 7 and Ubuntu in Perfect Harmony - windows 7 - Lifehacker
My System SpecsSystem Spec
10 Apr 2010   #6
Bjorn Jonsson

Windows 7

Thanks for the replies.

I managed to get Windows 7 to boot again after hours of messing with the Windows 7 repair utilities, the MBR/BCD, diskpart etc. The problem was that when I did bootrec /fixmbr etc. it was always the MBR/BCD on the 1.5 TB disk that got modified. This turned out to be because that disk had become disk 0 and the RAID array became disk 1, i.e. the disk numbers were "swapped" compared to what they originally were. I succeeded in forcing a repair of the MBR/BCD on the RAID array (where Windows 7 is installed) by physically disconnecting the 1.5 TB disk and then fixing the MBR/BCD. After this I reconnected the 1.5 TB disk, booted up and voila! Windows 7 now works.

However, now I cannot boot Linux. The original problem seems to have been that Grub doesn't handle RAID arrays correctly, at least not when there is an OS there that you want to be able to boot.

I'm fairly optimistic though that I'll soon succeed in booting Linux via the Windows 7 bootloader.
My System SpecsSystem Spec
16 Apr 2010   #7
Kevin Ismail

Windows 7 Ultimate x64

Thx. I learned from that. I installed Windows 7 prior to Linux Mint 8 Helena. It work perfectly, but the only way to change the boot order is via linux command line. Assistance is is found at Just type boot loader on its search engine then got the topics.
My System SpecsSystem Spec
18 Apr 2010   #8
Bjorn Jonsson

Windows 7

Well, I managed to get a Windows 7/Linux dual boot by using the EasyBCD 2.0 beta to add a Linux entry to the Windows bootloader menu. Note: It is important to use the EasyBCD 2.0 beta and not the official version, at least on a complex system like mine (RAID and/or Linux not on the same disk as Windows).
My System SpecsSystem Spec

 Cannot boot Windows 7 after installing Linux

Thread Tools

Similar help and support threads
Thread Forum
No boot manager after installing Linux.
Windows Boot Manager got corrupted and since I couldn't easily repair it, I installed Linux and wiped the whole drive thinking that the Win 7 CD couldn't require anything to work. The CD is in the mail and so I tried Win Vista, but couldn't install for that reason.
Installation & Setup
Windows won't boot, error 0xc000000e after installing arch linux
I installed arch linux on another partition of my hard disk, after I installed it grub took over the windows boot loader. When I try and boot into window I get the error 0xc000000e saying that windows cannot boot etc. Ive looked online to try and figure out how to solve this problem and they...
Performance & Maintenance
Installing Windows on a Linux machine.
Hi, I recently bought Dell Vostro 1550, it came with linux installed on it. I want to install windows on it, Please guide me in proceeding further. Thanks
Installation & Setup
Unable to boot Windows after installing linux to run side by side
I downloaded and installed Ubuntu and sectioned off a part of my hard drive for it. I intended to have it set up to run both windows 7 and linux together and let me choose which boot disk I wanted to use at start up. Ubuntu took over and so I read through some forums online. I can now get to the...
Installation & Setup
Installing Linux to "triple-boot" with XP and Win7
Hi, I've got a fine working dual-boot system with Windows XP Professional SP3 and Windows 7 Ultimate. I'm gonna install Ubuntu Linux 10, but I also want to keep both Windows systems. I googled after it, and I found many tutorials showing how to install Ubuntu to dual-boot with either XP or...
Installation & Setup
Will Linux partition appear when Installing windows 7
I have windows 7 RC, windows vista, and linux mint running in a triple boot config. I dont really want to keep linux and was planning on installing the Retail version of Windows 7 once i buy it. However, while im booted in windows, i cannot see linux at all. I can only see the Win7 partition (C: )...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App