Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: critical system drivers missing

02 May 2010   #1

Windows 7 32bit OEM (Hopefully!!)
critical system drivers missing


Firstly thank you in advance for any help. I have had a read through the common questions section and tried a few things but to no avail!!

Firstly my laptop is a Acer Aspire 5738z with an Intel T4200 processor.

I bought the laptop with Vista however i was never very impressed and when the OS seemed to get corrupted i decided it was time to try 7 but have been unable to install it.

The installation gets all the way through and restarts. it then comes up with and error:

File: \Windows\system32\DRIVERS\q12300.sys

status: 0xc00000e9

info: Windows failed to load because a critical system driver is missing, or corrupt.

I have deleted the Acer recovery partition and downloaded drivers from the Acer website however each time i get a the same error but with different .sys files.

Am i missing something or is this just a case of getting the correct drivers loaded for the install to work. I have tried numerous combinations and am running out of patience!! PLEASE HELP!

My System SpecsSystem Spec
02 May 2010   #2

Windows® 8 Pro (64-bit)

Hi there, I hope you're doing a Clean Install Windows 7
My System SpecsSystem Spec
02 May 2010   #3

64-bit Windows 8.1 Pro

I agree with Dinesh 100%... Doing an "upgrade" can have problematic results at best..You're most likely going to bring the problems you had with Vista to 7..

when the OS seemed to get corrupted i decided it was time to try 7 but have been unable to install it.
Forget about upgrading and do a clean install... you'll be glad you did...
My System SpecsSystem Spec

02 May 2010   #4

Windows 7 32bit OEM (Hopefully!!)

Hi Dinesh,

Thanks for the reply. Yes doing a clean install, i have deleted all the partitions using diskpart and am installing to unallocated disk space.

The only think i did notice is that in a command window there a drive x: called boot that it will not let me format. could this be the Acer recovery partition and i've not managed to deleted it correctly?

My System SpecsSystem Spec
02 May 2010   #5

Windows® 8 Pro (64-bit)

Simply wipe out the entire HDD and try installing again.
My System SpecsSystem Spec
02 May 2010   #6

Windows 7 32bit OEM (Hopefully!!)

sorry for asking such a simple question but what would be the best way of doing this?
My System SpecsSystem Spec
02 May 2010   #7

Windows® 8 Pro (64-bit)

Solved Hard Drive - Unable to Select or Delete during Installation - Vista Forums

Use the above tutorial to completely erase your HDD.
My System SpecsSystem Spec
02 May 2010   #8

Microsoft Community Contributor Award Recipient


Try a full clean & full format.
Disk - Clean and Clean All with Diskpart Command
1) Boot DVD.
2) Press Shift+F10 (for command prompt)

Type in command line
SELECT DISK # (win 7 HD)

Attached Images
critical system drivers missing-capture5.jpg 
My System SpecsSystem Spec
02 May 2010   #9

Windows 7 32bit OEM (Hopefully!!)


Thanks for help i will try this and report back.

My System SpecsSystem Spec
02 May 2010   #10
Microsoft MVP


Clean All command will zero the drive which takes a long time on a large HD but is the deepest clean.

Very likely that boot partition is blocking your install so good to get it cleaned off since you want your HD cleaned.

Then boot DVD, select Custom install, use Drive Tools to create New partition(s) as you wish, format before installing to first partition.

Intsaller is driver complete with newer arriving quickly via optional Windows updates. Put your wireless driver on a stick in case needed to get online. After updates, find any drivers missing in Device Manager plus any favorite apps on the Support Downloads webpage for your model computer/device.
My System SpecsSystem Spec

 critical system drivers missing

Thread Tools

Similar help and support threads
Thread Forum
System Information shows many Critical drivers
Hello again :) Still trying to figure out why my USB ports and card reader are not being seen, I went into System Information/Software Environment/System Drivers and found 20 drivers were Critical. Then I went to "Problem Devices" and their error codes as follows: Intel(R) 7 Series/C216...
Hardware & Devices
Critical system driver is missing, or corrupt :(
Hello sevenforums, I am greatly needing your assistance. Earlier today I uninstalled avast! antivirus as it was hogging up more RAM that I wanted. After restarting the PC to my dismay it would not boot up, going into a system repair which would then fail. I looked at the details regarding the...
General Discussion
New System - drivers missing error in installation of Windows7
Hello, I have recently assembled a new PC with the following configuration Motherboard - Asus M5A97 R2.0 CPU- AMD FX4100 RAM- Transcend DDR3 4GB x 2 Graphics card - Saphirre AMD RAdeon 5450 HD HDD- 1 TB Seagate Barracuda Sata drive
Installation & Setup
All usb drivers missing on system start
odd problem really and not even sure when it started. But when ever the system starts (reboot or cold) there is no usb drivers installed or the firewire unibrain driver. I go to devices and printers and there is the esclamation sign over the icon for for computer then right click it press...
Base System Device (Missing Drivers...?)
I have a Toshiba laptop that was experiencing numerous problems so I decided to format and reinstall everything. Except this time instead of using the restore CDs I put Windows7 in without all the bundled software that came with the original "out of the box" state. WOW! It runs so much faster and...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App