Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Boot entry missing

28 Aug 2012   #11
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by qwert2k8 View Post
Have the exact same problem, only in my case I also have a dual boot Win7/Ubuntu, I am almost sure GRUB is causing my problem, but would appreciate any suggestions, (GRUB related or not).
Thank you
Post screenshot of disk management with all fields visible (from within win7).
GRUB has been installed in MBR or in "volume bootsector" (if you know)?
In linux:
Code:
sudo dd if=/dev/sda   bs=512  count=1| hexdump -c
Any readable code like "Grub" or "Missing operating system"?

UBUNTU installed before you installed WIN7 or vise versa?


My System SpecsSystem Spec
.
28 Aug 2012   #12
qwert2k8

7 64 bit
 
 

I believe GRUB is in MBR, of disk1, but I am not sure.
Ubuntu (Disk1) was installed after Win7 (Disk0), but I recently changed my second disk (disk1) for a larger one and had to rebuild GRUB after copying the partitions in the older disk.
I donīt know if it matters, but also upgraded processor from a Pentium D to a Core i7 and Mother Board from D945PSN to DP67BA

Thanks for your quick reply


Attached Thumbnails
Boot entry missing-dskmgt01.jpg   Boot entry missing-dskmgt02.jpg  
My System SpecsSystem Spec
28 Aug 2012   #13
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

In elevated command prompt:
Code:
diskpart
sel  vol  d:
inactive
exit
D: is not active anymore in disk management now? Try to boot in win7 and ubuntu. Works?
My System SpecsSystem Spec
.

28 Aug 2012   #14
qwert2k8

7 64 bit
 
 

Ok, in Ubuntu now.
Code:
mario@mario-desktop:~$ sudo dd if=/dev/sda   bs=512  count=1| hexdump -c
[sudo] password for mario: 
1+0 records in
1+0 records out
512 bytes (512 B) copied0000000   �   c 220   �   �  \0   |   �   P  \a   P 037   �   � 033   |
, 5.1943e-05 s, 9.9 MB/s
0000010   � 033 006   P   W   �   � 001   �   �   �   �   �  \a   � 004
0000020   8   n  \0   |  \t   u 023 203   � 020   �   �   � 030 213   
0000030 203   � 020   I   t 031   8   ,   t   �   �   �  \a   �  \a 213
0000040   �   �   <  \0   t   �   �  \a  \0   � 016   � 020   �   � 210
0000050   N 020   �   F  \0   s   *   �   F 020  \0 200 001  \0  \0  \0
0000060  \0  \0  \0  \0   �   � 220 220   �   � 200   t 005   �   �   p
0000070   t 002   � 200   �   y   |  \0  \0   1   � 216   � 216   �   �
0000080  \0       �   �   d   |   <   �   t 002 210   �   R   � 027 004
0000090 200   ' 003   t 006   � 210   }   � 027 001   � 005   |   �   A
00000a0   �   �   U   � 023   Z   R   r   = 201   �   U   �   u   7 203
00000b0   � 001   t   2   1   � 211   D 004   @ 210   D   � 211   D 002
00000c0   � 004 020  \0   f 213 036   \   |   f 211   \  \b   f 213 036
00000d0   `   |   f 211   \  \f   �   D 006  \0   p   �   B   � 023   r
00000e0 005   �  \0   p   �   v   �  \b   � 023   s  \r   �   � 200 017
00000f0 204   �  \0   � 223   }   � 202  \0   f 017   �   � 210   d   �
0000100   @   f 211   D 004 017   �   �   �   � 002 210   � 210   �   @
0000110 211   D  \b 017   �   �   �   � 002   f 211 004   f   �   `   |
0000120   f  \t   �   u   N   f   �   \   |   f   1   �   f   �   4 210
0000130   �   1   �   f   �   t 004   ;   D  \b   }   7   �   � 210   
0000140   0   �   �   � 002  \b   � 210   �   Z 210   �   �  \0   p 216
0000150   �   1   �   � 001 002   � 023   r 036 214   �   ` 036   �  \0
0000160 001 216   �   1   �   �  \0 200 216   �   �   �   � 037   a   �
0000170   &   Z   |   � 216   }   � 003   � 235   }   �   4  \0   �   �
0000180   }   �   .  \0   � 030   �   �   G   R   U   B      \0   G   e
0000190   o   m  \0   H   a   r   d       D   i   s   k  \0   R   e   a
00001a0   d  \0       E   r   r   o   r  \r  \n  \0   � 001  \0   � 016
00001b0   � 020   �   <  \0   u   �   �   �  \t   V 030  \0  \0 200 001
00001c0 001  \0  \a   �   �   �   ?  \0  \0  \0 200   �   j  \n  \0   �
00001d0   �   �  \f   �   �   �   �   �   j  \n 025   !   � 002  \0   �
00001e0   �   �  \a   �   �   �  \0   �   1  \r  \0   � 004 005  \0   �
00001f0   �   � 203   �   �   �  \0   H   p   7  \0 030   � 002   U   �
0000200
mario@mario-desktop:~$
My System SpecsSystem Spec
28 Aug 2012   #15
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

When you boot you see a boot menu. In that menu you select win7 or ubuntu. But is it a grub bootmenu or a win7 bootmenu?
Win7 bootmenu looks like this:
My System SpecsSystem Spec
28 Aug 2012   #16
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by qwert2k8 View Post
Ok, in Ubuntu now.
Code:
mario@mario-desktop:~$ sudo dd if=/dev/sda   bs=512  count=1| hexdump -c
[sudo] password for mario: 
1+0 records in
1+0 records out
512 bytes (512 B) copied0000000   �   c 220   �   �  \0   |   �   P  \a   P 037   �   � 033   |
, 5.1943e-05 s, 9.9 MB/s
0000010   � 033 006   P   W   �   � 001   �   �   �   �   �  \a   � 004
0000020   8   n  \0   |  \t   u 023 203   � 020   �   �   � 030 213   
0000030 203   � 020   I   t 031   8   ,   t   �   �   �  \a   �  \a 213
0000040   �   �   <  \0   t   �   �  \a  \0   � 016   � 020   �   � 210
0000050   N 020   �   F  \0   s   *   �   F 020  \0 200 001  \0  \0  \0
0000060  \0  \0  \0  \0   �   � 220 220   �   � 200   t 005   �   �   p
0000070   t 002   � 200   �   y   |  \0  \0   1   � 216   � 216   �   �
0000080  \0       �   �   d   |   <   �   t 002 210   �   R   � 027 004
0000090 200   ' 003   t 006   � 210   }   � 027 001   � 005   |   �   A
00000a0   �   �   U   � 023   Z   R   r   = 201   �   U   �   u   7 203
00000b0   � 001   t   2   1   � 211   D 004   @ 210   D   � 211   D 002
00000c0   � 004 020  \0   f 213 036   \   |   f 211   \  \b   f 213 036
00000d0   `   |   f 211   \  \f   �   D 006  \0   p   �   B   � 023   r
00000e0 005   �  \0   p   �   v   �  \b   � 023   s  \r   �   � 200 017
00000f0 204   �  \0   � 223   }   � 202  \0   f 017   �   � 210   d   �
0000100   @   f 211   D 004 017   �   �   �   � 002 210   � 210   �   @
0000110 211   D  \b 017   �   �   �   � 002   f 211 004   f   �   `   |
0000120   f  \t   �   u   N   f   �   \   |   f   1   �   f   �   4 210
0000130   �   1   �   f   �   t 004   ;   D  \b   }   7   �   � 210   
0000140   0   �   �   � 002  \b   � 210   �   Z 210   �   �  \0   p 216
0000150   �   1   �   � 001 002   � 023   r 036 214   �   ` 036   �  \0
0000160 001 216   �   1   �   �  \0 200 216   �   �   �   � 037   a   �
0000170   &   Z   |   � 216   }   � 003   � 235   }   �   4  \0   �   �
0000180   }   �   .  \0   � 030   �   �   G   R   U   B      \0   G   e
0000190   o   m  \0   H   a   r   d       D   i   s   k  \0   R   e   a
00001a0   d  \0       E   r   r   o   r  \r  \n  \0   � 001  \0   � 016
00001b0   � 020   �   <  \0   u   �   �   �  \t   V 030  \0  \0 200 001
00001c0 001  \0  \a   �   �   �   ?  \0  \0  \0 200   �   j  \n  \0   �
00001d0   �   �  \f   �   �   �   �   �   j  \n 025   !   � 002  \0   �
00001e0   �   �  \a   �   �   �  \0   �   1  \r  \0   � 004 005  \0   �
00001f0   �   � 203   �   �   �  \0   H   p   7  \0 030   � 002   U   �
0000200
mario@mario-desktop:~$
0000180 } � . \0 � 030 � � G R U B \0 G e

So grub is in MBR of /dev/sda

linux itself is on which disk?
Code:
sudo fdisk -l
My System SpecsSystem Spec
28 Aug 2012   #17
qwert2k8

7 64 bit
 
 

It is an Ubuntu GRUB menu
ubuntu is in /dev/sdb4

*** sorry wrong place disregard sdb4

/dev/sda4 930105344 976773119 23333888 83 Linux
My System SpecsSystem Spec
28 Aug 2012   #18
qwert2k8

7 64 bit
 
 

Code:
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x185609d3

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   174771134    87385536    7  HPFS/NTFS/exFAT
Partition 1 does not start on physical sector boundary.
/dev/sda2       174771135   221375699    23302282+   c  W95 FAT32 (LBA)
Partition 2 does not start on physical sector boundary.
/dev/sda3       221376512   305588223    42105856    7  HPFS/NTFS/exFAT
/dev/sda4       930105344   976773119    23333888   83  Linux

Disk /dev/sdb: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders, total 160836480 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xed8eed8e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63   160826714    80413326    7  HPFS/NTFS/exFAT
My System SpecsSystem Spec
28 Aug 2012   #19
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by qwert2k8 View Post
It is an Ubuntu GRUB menu
ubuntu is in /dev/sdb4
In the disk list you posted it is on /dev/sda4 (?)
My System SpecsSystem Spec
28 Aug 2012   #20
qwert2k8

7 64 bit
 
 

Yes, I mixed up sda and sdb
Windows 7 is in dev/sdb1
Ubuntu is in dev/sda4
I thought they were in sda1 and sdb4 respectively

Sorry for the mix up
My System SpecsSystem Spec
Reply

 Boot entry missing




Thread Tools




Similar help and support threads
Thread Forum
An entry in registry missing
I want gain an access to com ports and require changed in registry entry of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PNP0501 but it seems the folder is not there. I have tried regcleaner and reg fix did not help. thanks
Drivers
No Entry in MSCONFIG > Boot
Hello, I have no entries in the Msconfig > Boot section. I started computer for the day and after logging in, it stopped apparently, with no waiting indication. I then looked in Msconfig. About five months ago I got this or a very similar problem after playing around with the system. Finally had...
General Discussion
Microsoft Excel Application entry missing in DCOMCNFG
Hi I'm using windows 7 home premium. I have an application in ASP.Net which uses Excel Application Object. It used to work fine in XP but in Windows 7 I'm getting an error as mentioned below: Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed...
Microsoft Office
Ubuntu installed inside windows 7 missing boot entry after 7 repair
Hi, Previously I have installed Windows XP then Windows 7 in different drives of my computer. Later installed Ubuntu 10.10 inside Windows 7 and upgraded it to 11.04. After that Accidentally I have formatted Windows XP drive from Ubuntu. I installed XP again to the same drive. I tried to repair...
Installation & Setup
Rename boot entry?
Iv tried multiple times with Easybcd to rename a boot entry with no success. On easy bcd, it shows up as the name I want but It doesnt under the bootloader. I want to rename it from Symantic Recovery Environment Location=W:\boot.wim to Windows 7 PreInstallation Environment
Installation & Setup
Add entry to boot?
I found a tutorial for dual booting linux but still use the windows boot loader. But the issue is that it was for xp and back then all you had to do was goto sartup and recovery and hit "edit" but now Microsoft decided they want to make things more difficult. So now i have to edit in cmd by using...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 05:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App